Bug 798543 - device-mapper-multipath: standard rpm cflags not used during build [rhel-5]
device-mapper-multipath: standard rpm cflags not used during build [rhel-5]
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
5.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Ben Marzinski
Storage QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 03:27 EST by Tomas Hoger
Modified: 2014-09-15 20:21 EDT (History)
9 users (show)

See Also:
Fixed In Version: device-mapper-multipath-0.4.7-61.el5
Doc Type: Bug Fix
Doc Text:
no documentation needed.
Story Points: ---
Clone Of: 798541
Environment:
Last Closed: 2014-09-15 20:21:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Hoger 2012-02-29 03:27:18 EST
+++ This bug was initially created as a clone of Bug #798541 +++

Description of problem:
spec file for device-mapper-multipath does not use rpm macro %configure and invokes make without explicitly adding default rpm cflags.  As a consequence, build is not made with optimization level and protections expected to be the default for all packages.

Version-Release number of selected component (if applicable):
device-mapper-multipath-0.4.7-48.el5
Comment 1 RHEL Product and Program Management 2014-01-29 05:37:04 EST
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Ben Marzinski 2014-03-28 23:48:11 EDT
Multipath has been updated to use RPM_OPT_FLAGS, and the build warnings that resulted were fixed.
Comment 5 errata-xmlrpc 2014-09-15 20:21:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1228.html

Note You need to log in before you can comment on or make changes to this bug.