Bug 798750 - BTRFS crashes in Anaconda when selected as /boot partition
BTRFS crashes in Anaconda when selected as /boot partition
Status: CLOSED DUPLICATE of bug 787341
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 13:27 EST by Max E
Modified: 2012-02-29 15:27 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-29 15:27:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max E 2012-02-29 13:27:58 EST
Description of problem:

currently running F17-alpha, and tried to do a manual partition.  Selected as a filing system on disk partitioning tool [manually setting up virtual machine] and anaconda crashed.  This system is running under Virtualbox 4.1.8

Version-Release number of selected component (if applicable):

Fedora 17 Alpha

How reproducible:

Everytime

Steps to Reproduce:
1. Selected Basic Storage Type
2. Initialised disk
3. named machine f17-tester
4. sorted out the root password
5. Selected Create custom Layout
6. Create Standard Partition
7. selected mount point: /boot
8. selected file system type: btrfs
9. selected size: 500M
10. CRASHED!
11. Pressed DEBUG and Anaconda crashed out to command
  
Actual results:

Anaconda crashes out

Expected results:

Either accept btrfs can be used for /boot or not....

Additional info:

The only thing I could get out was: btrfs_dev=self.storage.devicetree.getChildren(device)[0]
Comment 1 Max E 2012-02-29 13:29:37 EST
sorry - additional error statement:

/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py(946)addDevice()

and crashed out to 

(Pdb) prompt
Comment 2 Chris Lumens 2012-02-29 15:27:41 EST

*** This bug has been marked as a duplicate of bug 787341 ***

Note You need to log in before you can comment on or make changes to this bug.