Bug 787341 - btrfs - IndexError: list index out of range
btrfs - IndexError: list index out of range
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs, ReleaseNotes, Reopened
: 787565 795670 796071 796665 798750 798780 803733 (view as bug list)
Depends On:
Blocks: F17Blocker/F17FinalBlocker
  Show dependency treegraph
 
Reported: 2012-02-04 01:22 EST by masami256
Modified: 2012-04-05 14:29 EDT (History)
29 users (show)

See Also:
Fixed In Version: anaconda-17.14-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-27 14:50:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Anaconda log (281.57 KB, text/plain)
2012-02-04 01:23 EST, masami256
no flags Details
ks file (1.26 KB, text/plain)
2012-03-07 04:28 EST, Hongqing Yang
no flags Details
ks.cfg raveit65 (1.13 KB, application/octet-stream)
2012-04-05 14:29 EDT, Wolfgang Ulbrich
no flags Details

  None (edit)
Description masami256 2012-02-04 01:22:11 EST
Description of problem:
When I choose btrfs for a mount point(/ or /home) I received following exception.
 
anaconda 17.5 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line
 946, in addDevice
    btrfs_dev = self.storage.devicetree.getChildren(device)[0]
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line
 1096, in populate
    self.addDevice(device, iter)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line
 1649, in refresh
    self.populate()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line
 1712, in editPartition
    if self.refresh(justRedraw=not actions):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line
 1587, in createCB
    self.editPartition(device, isNew = True)
IndexError: list index out of range

I made disk image by qemu-img command without "-f" option so that its format should be raw.

Version-Release number of selected component (if applicable):
Fedora 17 Alpha TC1 x86_64
I downloaded it from here.
http://dl.fedoraproject.org/pub/alt/stage/17-Alpha.TC1/Fedora/x86_64/iso/Fedora
-17-Alpha-x86_64-DVD.iso

How reproducible:
always

Steps to Reproduce:
1. Select "Create Custom Layout" in 'Disk Partitioning Setup' screen  
2. Add a partition and Choose btrfs for '/' then click OK button
  
Actual results:
Receive IndexError exception

Expected results:
Can use btrfs
Comment 1 masami256 2012-02-04 01:23:02 EST
Created attachment 559397 [details]
Anaconda log
Comment 2 cornel panceac 2012-02-14 08:42:29 EST
this still happens in tc2 x86, and it also happens if the target system already has btrfs partitions on it.
Comment 3 David Lehman 2012-02-14 10:05:11 EST
*** Bug 787565 has been marked as a duplicate of this bug. ***
Comment 4 Hongqing Yang 2012-02-16 02:40:50 EST
reproduced with F17 Alpha RC2 when create partition with type btrfs
Comment 5 Kevin 2012-02-17 19:59:07 EST
I also could reproduce the bug. RC2 i386 netinstall. Happens when installing inside a VM (F16 host with VirtualBox). Haven't tried a native install.
Comment 6 Adam Williamson 2012-02-20 21:13:08 EST
Proposing as a Final blocker: it's at least that, per criterion "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above" . The fact it crashes on systems with existing btrfs partitions is also worrying.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 cornel panceac 2012-02-21 10:57:10 EST
still present on alpha rc3 netinstall. i tried in virtualbox, too.
Comment 8 Brian Lane 2012-02-21 13:21:20 EST
*** Bug 795670 has been marked as a duplicate of this bug. ***
Comment 9 Hongqing Yang 2012-02-22 03:38:33 EST
*** Bug 796071 has been marked as a duplicate of this bug. ***
Comment 10 Hongqing Yang 2012-02-22 03:40:31 EST
(In reply to comment #9)
> *** Bug 796071 has been marked as a duplicate of this bug. ***

Reproduced with F17 Alpha RC4
Comment 11 John Poelstra 2012-02-22 12:24:46 EST
reproduced creating simple partition layout--500M swap and 9500M btrfs partition... i686 guest on kvm.
Comment 12 John Poelstra 2012-02-22 12:25:15 EST
(In reply to comment #11)
> reproduced creating simple partition layout--500M swap and 9500M btrfs
> partition... i686 guest on kvm.

F17-RC4-i686
Comment 13 Chris Lumens 2012-02-23 10:19:09 EST
*** Bug 796665 has been marked as a duplicate of this bug. ***
Comment 14 David Lehman 2012-02-23 18:22:02 EST
Once bug 796511 and bug 796013 are resolved, you will still be unable to create btrfs filesystems using the custom partitioning interface in anaconda. You will, however, be able to create btrfs volumes using kickstart:

  https://fedoraproject.org/wiki/Anaconda/Kickstart#btrfs

Also, note the availability of a btrfs automatic partitioning scheme, also available only via kickstart:

  https://fedoraproject.org/wiki/Anaconda/Kickstart#autopart

  (autopart --type=btrfs)


Meanwhile, I'll be trying to make the custom partitioning side work more smoothly.
Comment 15 Adam Williamson 2012-02-27 19:47:43 EST

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Adam Williamson 2012-02-28 01:50:56 EST

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 17 Chris Lumens 2012-02-29 15:27:41 EST
*** Bug 798750 has been marked as a duplicate of this bug. ***
Comment 18 Chris Lumens 2012-02-29 15:41:44 EST
*** Bug 798780 has been marked as a duplicate of this bug. ***
Comment 19 Paul Alesius 2012-03-01 16:49:21 EST
Couldn't create btrfs volumes with kickstart either.
Comment 20 David Lehman 2012-03-05 08:45:47 EST
(In reply to comment #19)
> Couldn't create btrfs volumes with kickstart either.

You can create btrfs volumes just fine with kickstart -- just not with encrypted member devices.
Comment 21 Hongqing Yang 2012-03-07 04:28:07 EST
Created attachment 568205 [details]
ks file

btrfs does not work with the ks file in attachment
Comment 22 Adam Williamson 2012-03-11 00:19:17 EST
Chris, Brian - I know this bug only *blocks* Final, but it sure would be nice to have it fixed for Beta, if you could manage it...



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 23 David Lehman 2012-03-12 14:45:13 EDT
(In reply to comment #21)
> Created attachment 568205 [details]
> ks file
> 
> btrfs does not work with the ks file in attachment

That's correct, because btrfs is not just a filesystem. For now, you'll have to create a btrfs volume as described here:

 https://fedoraproject.org/wiki/Anaconda/Kickstart#btrfs
Comment 24 Chris Murphy 2012-03-13 18:35:48 EDT
I get this with F17 Beta TC1 x86_64 netinst.iso, anaconda 17.12. With or without LVM. With or without encryption.
Comment 25 Chris Lumens 2012-03-15 11:42:26 EDT
*** Bug 803733 has been marked as a duplicate of this bug. ***
Comment 26 Fedora Update System 2012-03-23 01:17:23 EDT
anaconda-17.14-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.14-1.fc17
Comment 27 Fedora Update System 2012-03-23 13:09:38 EDT
Package anaconda-17.14-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-17.14-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4546/anaconda-17.14-1.fc17
then log in and leave karma (feedback).
Comment 28 Fedora Update System 2012-03-23 13:44:49 EDT
anaconda-17.14-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 29 cornel panceac 2012-03-23 14:17:58 EDT
how is one supposed to use the updated anaconda if it's not on an install disc/media? if no such media is available, how do you know this is fixed?
Comment 30 David Lehman 2012-03-23 15:19:16 EDT
(In reply to comment #29)
> how is one supposed to use the updated anaconda if it's not on an install
> disc/media? if no such media is available, how do you know this is fixed?

It will be on install media: F17-Beta.

It still may not be "fixed" in the way you hope for. As I stated in comment 14, there will still be no support for creating or editing btrfs filesystems in F17-Beta, except via kickstart.
Comment 31 cornel panceac 2012-03-23 16:50:35 EDT
Thank you for clarifications, David.
Comment 32 Adam Williamson 2012-03-24 16:43:04 EDT
17.14 is in Beta RC1. Bodhi automatically closes any bug an update is marked as 'fixing' when that update is pushed stable.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 33 Kamil Páral 2012-03-26 09:12:32 EDT
This bug was closed automatically by Bodhi, but we still need to verify it. Changing status to ON_QA.
Comment 34 Adam Williamson 2012-03-27 14:50:52 EDT
Confirming that this is 'fixed' in the sense that btrfs isn't on the list of available filesystems in custom partitioning in 17 Beta RC1.

We should probably document this in the release notes for 17.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 35 cornel panceac 2012-03-27 15:17:02 EDT
thank you all very much.
Comment 36 Adam Williamson 2012-03-28 01:26:36 EDT
I also tested that upgrading a system which has btrfs already works okay.
Comment 37 Wolfgang Ulbrich 2012-04-05 14:26:58 EDT
Installing with a kickstart file on a multiboot system with different partitions doesn't work if you don't delete all existings partitions.
My partitioning schema in ks.cfg.

# Disk partitioning information
ignoredisk --drives=sda1,sda3,sda4,sda5,sda6,sda7,sda8,sdb1,sdb2,sdb3,sdb5,sdb6
part /boot --fstype ext4 --grow --noformat --onpart=sda2 --size=1
part / --fstype btrfs --grow --maxsize=30000 --ondisk=sda --size=1

Here i have 40GB left at the end of the disk.
Installation fails with 'can't create disk'.

With a existing unformatet disk:

# Disk partitioning information
part /boot --fstype ext4 --grow --noformat --onpart=sda2 --size=1
part / --fstype btrfs --grow --ondisk=sda4 --size=1

ends up with 'can't create a filessystem because it's mounted read only'.

The only thing what's work with a existing btrfs is

# Disk partitioning information
part /boot --fstype ext4 --grow --noformat --onpart=sda2 --size=1
part / --fstype btrfs --grow --noformat --ondisk=sda4 --size=1

But after the minimal installation is finished i can't do nothing as root in runlevel 3 because the filesystem is read only mounted.

I found a workaround, see http://forums.fedoraforum.org/showthread.php?t=278404
But this isn't a real solution.
In my eyes you doesn't fixed the issue really.
This is fc17 use blocker for people who havea a sdd disk.
Maybe i'm wrong and i have a error in my ks.cfg but i had tried many versions.
ks.cfg is appended.
Comment 38 Wolfgang Ulbrich 2012-04-05 14:29:17 EDT
Created attachment 575522 [details]
ks.cfg raveit65

Note You need to log in before you can comment on or make changes to this bug.