Bug 798780 - IndexError: list index out of range
IndexError: list index out of range
Status: CLOSED DUPLICATE of bug 787341
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:30225b63b41ec8e1d692640194d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 15:35 EST by Paul Alesius
Modified: 2012-02-29 15:41 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-29 15:41:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb-76l0Y3 (844.42 KB, text/plain)
2012-02-29 15:35 EST, Paul Alesius
no flags Details

  None (edit)
Description Paul Alesius 2012-02-29 15:35:50 EST
libreport version: 2.0.8
cmdline:        /usr/bin/python  /sbin/anaconda --graphical --selinux --lang sv_SE.UTF-8 --keymap sv-latin1
executable:     /sbin/anaconda
exnFileName:    /tmp/anaconda-tb-76l0Y3
hashmarkername: anaconda
kernel:         3.3.0-0.rc3.git7.2.fc17.x86_64
other involved packages: 
product:        Fedora
reason:         IndexError: list index out of range
release:        Cannot get release name.
time:           ons 29 feb 2012 23:35:07
version:        17-Alpha

anaconda-tb-76l0Y3: Binary file, 864683 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 17.11 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 946, in addDevice
:    btrfs_dev = self.storage.devicetree.getChildren(device)[0]
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1007, in populate
:    self.addDevice(lv, iter)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1649, in refresh
:    self.populate()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1812, in editLVMLogicalVolume
:    if self.refresh(justRedraw=True):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1668, in editCB
:    self.editLVMLogicalVolume(lv = device)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 1195, in treeActivateCB
:    self.editCB()
:IndexError: list index out of range

environ:
:LC_NUMERIC=C
:live_dir=/boot/livecd/LiveOS/
:LANGKEY=sv
:LVM_SUPPRESS_FD_WARNINGS=1
:GCONF_GLOBAL_LOCKS=1
:PATH=/tmp/product:/tmp/updates:/usr/bin:/bin:/sbin:/usr/sbin:/mnt/sysimage/bin:/mnt/sysimage/usr/bin:/mnt/sysimage/usr/sbin:/mnt/sysimage/sbin:/sbin:/usr/sbin
:PIXMAPPATH=/tmp/updates/pixmaps/:/tmp/updates/:/tmp/product/pixmaps/:/tmp/product/:pixmaps/:/usr/share/anaconda/pixmaps/:/usr/share/pixmaps/:/usr/share/anaconda/:/usr/share/python-meh/:/usr/share/icons/Fedora/48x48/apps/
:HOME=/tmp
:DISPLAY=:1
:LANG=sv_SE.UTF-8
:TERM=linux
:TZ=Europe/Stockholm
:XAUTHORITY=/root/.Xauthority
:GLADEPATH=/tmp/updates/:/tmp/updates/data/ui/:ui/:/usr/share/anaconda/ui/:/usr/share/python-meh/
:SHLVL=0
:LIBUSER_CONF=/tmp/libuser.mQblup
:LD_LIBRARY_PATH=/tmp/product:/tmp/updates
:GNOME_DISABLE_CRASH_DIALOG=1
:PYTHONPATH=/tmp/product:/tmp/updates:/tmp/updates
:LINGUAS=Swedish
:BOOT_IMAGE=/boot/livecd/isolinux/vmlinuz
:LC_COLLATE=C
:PWD=/
:MALLOC_PERTURB_=MALLOC_PERTURB_=106
:MALLOC_CHECK_=2
Comment 1 Paul Alesius 2012-02-29 15:35:57 EST
Created attachment 566638 [details]
File: anaconda-tb-76l0Y3
Comment 2 Paul Alesius 2012-02-29 15:38:15 EST
Happens when selecing btrfs as partition type.
Comment 3 Chris Lumens 2012-02-29 15:41:44 EST

*** This bug has been marked as a duplicate of bug 787341 ***

Note You need to log in before you can comment on or make changes to this bug.