Bug 798920 - tomboy does not start
tomboy does not start
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tomboy (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Thomas Moschny
Fedora Extras Quality Assurance
:
Depends On: 799080 799081
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 04:38 EST by Tomasz Torcz
Modified: 2012-03-13 14:41 EDT (History)
1 user (show)

See Also:
Fixed In Version: tomboy-1.9.8-2.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-13 14:41:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomasz Torcz 2012-03-01 04:38:36 EST
Description of problem:
After upgrade to F17, tomboy no longer starts:

% tomboy

Unhandled Exception: System.TypeInitializationException: An exception was thrown by the type initializer for Tomboy.Logger ---> System.TypeInitializationException: An exception was thrown by the type initializer for Tomboy.Services ---> System.TypeLoadException: A type load exception has occurred.
  at Tomboy.Services..cctor () [0x00000] in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at Tomboy.FileLogger..ctor () [0x00000] in <filename unknown>:0 
  at Tomboy.Logger..cctor () [0x00000] in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at Tomboy.Tomboy.Main (System.String[] args) [0x00000] in <filename unknown>:0 
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: An exception was thrown by the type initializer for Tomboy.Logger ---> System.TypeInitializationException: An exception was thrown by the type initializer for Tomboy.Services ---> System.TypeLoadException: A type load exception has occurred.
  at Tomboy.Services..cctor () [0x00000] in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at Tomboy.FileLogger..ctor () [0x00000] in <filename unknown>:0 
  at Tomboy.Logger..cctor () [0x00000] in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at Tomboy.Tomboy.Main (System.String[] args) [0x00000] in <filename unknown>:0 


Version-Release number of selected component (if applicable):
tomboy-1.9.8-1.fc17.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Try to start tomboy
2.
3.
Comment 1 Fedora Update System 2012-03-01 06:43:04 EST
tomboy-1.9.8-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/tomboy-1.9.8-2.fc17
Comment 2 Thomas Moschny 2012-03-01 13:19:28 EST
Ok, seems to be a packaging issue for both, dbus-sharp[-glib] and ndesk-dbus[-glib].
Comment 3 Fedora Update System 2012-03-01 19:58:52 EST
Package tomboy-1.9.8-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tomboy-1.9.8-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2814/tomboy-1.9.8-2.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-03-13 14:41:09 EDT
tomboy-1.9.8-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.