Bug 799081 - Wrong file locations.
Wrong file locations.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dbus-sharp-glib (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Christian Krause
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 798920
  Show dependency treegraph
 
Reported: 2012-03-01 13:16 EST by Thomas Moschny
Modified: 2012-04-11 22:17 EDT (History)
2 users (show)

See Also:
Fixed In Version: dbus-sharp-glib-0.5.0-3.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 799080
Environment:
Last Closed: 2012-04-11 22:17:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Moschny 2012-03-01 13:16:34 EST
+++ This bug was initially created as a clone of Bug #799080 +++

Problem described below also applies to dbus-sharp-glib-0.5.0-2.fc17.x86_64.


Description of problem:
Package is not really usable, because files are in the wrong location.

See bug 798920 for the symptoms. (In the original bug, tomboy fails to find ndesk-dbus or ndesk-dbus-glib, but the symptoms remain the same when building against dbus-sharp and dbus-sharp-glib instead.)

Problem: Library files are in /usr/lib64/mono/gac/dbus-sharp but are searched by mono runtime in /usr/lib/mono/gac/dbus-sharp.

Also, the symlink should not be in /usr/lib64/mono/dbus-sharp-1.0/ but in /usr/lib/mono/dbus-sharp-1.0/.

Note that this changed recently (well, in July):
https://fedoraproject.org/wiki/Packaging:Mono#File_Locations

Version-Release number of selected component (if applicable):
dbus-sharp-0.7.0-4.fc17.x86_64
Comment 1 Fedora Update System 2012-03-11 19:46:50 EDT
dbus-sharp-glib-0.5.0-3.fc17,dbus-sharp-0.7.0-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dbus-sharp-glib-0.5.0-3.fc17,dbus-sharp-0.7.0-5.fc17
Comment 2 Fedora Update System 2012-03-11 21:22:48 EDT
Package dbus-sharp-glib-0.5.0-3.fc17, dbus-sharp-0.7.0-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dbus-sharp-glib-0.5.0-3.fc17 dbus-sharp-0.7.0-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3598/dbus-sharp-glib-0.5.0-3.fc17,dbus-sharp-0.7.0-5.fc17
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-04-11 22:17:57 EDT
dbus-sharp-glib-0.5.0-3.fc17, dbus-sharp-0.7.0-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.