Bug 798969 - nfs:error message while nfs mount/umount a volume
nfs:error message while nfs mount/umount a volume
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
pre-release
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Vinayaga Raman
Saurabh
:
: 791174 (view as bug list)
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-03-01 07:02 EST by Saurabh
Modified: 2016-01-19 01:09 EST (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:47:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions: 3.3.0qa42
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2012-03-01 07:02:19 EST
Description of problem:


try nfs mount a volume and the nfs.log registers this response,
[2012-03-01 06:25:10.479887] W [rpcsvc.c:175:rpcsvc_program_actor] 0-rpc-service: RPC program not available (req 100227 3)
[2012-03-01 06:25:10.480161] W [rpcsvc.c:1111:rpcsvc_error_reply] (-->/usr/local/lib/libgfrpc.so.0(rpc_transport_notify+0x130) [0x7fb1928beda8] (-->/usr/local/lib/libgfrpc.so.0(rpcsvc_notify+0x181) [0x7fb1928b944c] (-->/usr/local/lib/libgfrpc.so.0(rpcsvc_handle_rpc_call+0x37b) [0x7fb1928b90c4]))) 0-: sending a RPC error reply


with umount you get this response,

[2012-03-01 06:25:14.294514] E [socket.c:2443:socket_getpeeraddr] (-->/usr/local/lib/glusterfs/3git/xlator/nfs/server.so(mnt3svc_umnt+0x2de) [0x7fb18e40ac61] (-->/usr/local/lib/libgfrpc.so.0(rpcsvc_transport_peeraddr+0x4a) [0x7fb1928bae26] (-->/usr/local/lib/libgfrpc.so.0(rpc_transport_get_peeraddr+0xb0) [0x7fb1928bd803]))) 0-socket: invalid argument: sa
[2012-03-01 06:25:14.294600] E [mount3.c:1197:mnt3svc_umnt] 0-nfs-mount: Failed to get remote addr: Bad value for ai_flags
[2012-03-01 06:25:14.294649] W [rpcsvc.c:1111:rpcsvc_error_reply] (-->/usr/local/lib/libgfrpc.so.0(rpc_transport_notify+0x130) [0x7fb1928beda8] (-->/usr/local/lib/libgfrpc.so.0(rpcsvc_notify+0x181) [0x7fb1928b944c] (-->/usr/local/lib/libgfrpc.so.0(rpcsvc_handle_rpc_call+0x37b) [0x7fb1928b90c4]))) 0-: sending a RPC error reply


Version-Release number of selected component (if applicable):
on git head,
commit 70fb696abd6144199bc08b05d403daaca314c7b4
Author: Amar Tumballi <amarts@redhat.com>
Date:   Thu Mar 1 00:35:36 2012 +0530


and also on 3.3.0qa24

How reproducible:
always

Steps to Reproduce:
1.create a dist-rep volume
2.mount over nfs on a client
3.check the log messages while mounting and unmounting
  
Actual results:
as discussed above

Expected results:
this kind of error message should not have occurred

Additional info:
Comment 1 Krishna Srinivas 2012-04-03 05:08:34 EDT
*** Bug 791174 has been marked as a duplicate of this bug. ***
Comment 2 Anand Avati 2012-04-27 08:46:58 EDT
CHANGE: http://review.gluster.com/2973 (nfs: use hostname without port numbers) merged in master by Vijay Bellur (vijay@gluster.com)

Note You need to log in before you can comment on or make changes to this bug.