Bug 799111 - OutOfProcess tasks stuck because of logging.
OutOfProcess tasks stuck because of logging.
Status: CLOSED DUPLICATE of bug 808584
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Kenigsberg
yeylon@redhat.com
:
Depends On:
Blocks: 799722
  Show dependency treegraph
 
Reported: 2012-03-01 14:36 EST by Igor Lvovsky
Modified: 2016-04-18 02:43 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 16:46:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log (734.11 KB, application/octet-stream)
2012-03-04 03:16 EST, Idan Mansano
no flags Details

  None (edit)
Description Igor Lvovsky 2012-03-01 14:36:57 EST
Description of problem:

Sometimes OOP tasks stuck. It happens on very few hosts mostly Fedora 16.
After short investigation it looks like logging inside these tasks cause for this.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Igor Lvovsky 2012-03-04 03:14:04 EST
It's not a solution, it's just a workaround patch
 http://gerrit.ovirt.org/#change,2532
Comment 2 Idan Mansano 2012-03-04 03:14:44 EST
Attached vdsm.log with the error inside.
Comment 3 Idan Mansano 2012-03-04 03:16:01 EST
Created attachment 567375 [details]
vdsm.log
Comment 4 Dan Kenigsberg 2012-03-04 06:49:18 EST
Could you attach a gdb trace of the dead-locked processes? Has it ever happen on RHEL6? (think z-stream!)
Comment 5 Dan Kenigsberg 2012-04-18 16:46:52 EDT
most probably

*** This bug has been marked as a duplicate of bug 808584 ***

Note You need to log in before you can comment on or make changes to this bug.