Bug 808584 - outOfProcess operations time out with abrt-addon-python installed
outOfProcess operations time out with abrt-addon-python installed
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Dan Kenigsberg
: 799111 (view as bug list)
Depends On: 808562 837333
Blocks: 799722
  Show dependency treegraph
Reported: 2012-03-30 14:59 EDT by Adam Litke
Modified: 2013-09-21 20:42 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-09-21 20:42:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Adam Litke 2012-03-30 14:59:46 EDT
Description of problem:

On a Fedora 16 host with the abrt-addon-python package installed, vsdm can enter a state where outOfProcess operations do not complete.  This can cause many different errors (including failure to initialize storage if this machine is also SPM).

Version-Release number of selected component (if applicable):

How reproducible:

A freshly installed vdsm may not exhibit the problem even with the abrt python hook present.  For me, completing a few cycles of: install rpm, start vdsm, stop vdsm, remove rpm, repeat -- will cause the symptoms to appear.

Steps to Reproduce:
1. install vdsm and abrt-addon-python
2. complete several vdsm reinstall/restart cycles until ovirt-engine is unable to initialize storage
Actual results:

Vdsm is unable to locate and connect the master storage domain.

Expected results:

No errors are reported.

Additional info:

The problem can be worked around by removing abrt-addon-python from the system and restarting vdsm.
Comment 1 Dan Kenigsberg 2012-04-07 15:07:11 EDT
This is clearly very odd. I have abrt-addon-python-2.0.7-2.fc16.x86_64 and vdsm installed on my f16, with vdsm doing gazillion installation cycles, and I have never see this.

When it occurs, does it happen repeatedly? Does *all* oop fail? Could you attach a gdb stack of vdsm at this condition? Does `tests/run_tests.sh processPoolTests.py` reproduce any of it?
Comment 2 Dan Kenigsberg 2012-04-09 04:35:08 EDT
Oh, does removal of oop logging makes the issue disappear?
Comment 3 Dan Kenigsberg 2012-04-18 16:46:52 EDT
*** Bug 799111 has been marked as a duplicate of this bug. ***
Comment 4 Dan Kenigsberg 2013-09-21 20:42:54 EDT
Bug solved on the abrt side with bug 837333.

Note You need to log in before you can comment on or make changes to this bug.