Bug 799174 - update-testing repo for Fedora 17 has depenency problems.
update-testing repo for Fedora 17 has depenency problems.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins-bad-free (Show other bugs)
17
x86_64 All
high Severity high
: ---
: ---
Assigned To: Benjamin Otte
Fedora Extras Quality Assurance
RejectedBlocker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-01 20:52 EST by Dan Mashal
Modified: 2014-01-21 18:21 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-27 13:14:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Mashal 2012-03-01 20:52:47 EST
Description of problem:

Run yum update after install of Fedora 17 with updates-testing repo enabled


Steps to Reproduce:
1. Install Fedora 17, run yum update
  
Actual results:

http://fpaste.org/4LwJ/

Expected results:

yum should resolve dependency problem automatically

Additional info:

fixed by disabling update-testing repo, running yum update, yum remove cogl, yum install empathy. 

After turning updates-testing repo back on, yum update fails again:

http://fpaste.org/bnGk/
Comment 1 Dan Mashal 2012-03-01 21:08:19 EST
After removing cogl I also had to reinstall gnome.
Comment 2 Dan Mashal 2012-03-03 20:50:39 EST
After turning updates-testing repo back on I am still experiencing issues running yum update although issues with a different package/dependency:

gstreamer-plugins-bad-free

http://fpaste.org/tcus
Comment 3 Samuel Jones 2012-03-03 20:52:53 EST
I can also reproduce this problem with 'yum update' and gstreamer-plugins-bad-free causes issues against libgstphotography & qt-mobile

http://fpaste.org/FxL1/

removing gstreamer-plugins-bad-free also wants to remove most of KDE.
Comment 4 Samuel Jones 2012-03-03 20:55:58 EST
heres an fpaste of what yum would like to remove as 'dependencies' of gstreamer-plugins-bad-free using 'yum remove gstreamer-plugins-bad-free'

http://fpaste.org/4rVw/

~130 packages that would break the system.
Comment 5 Dan Mashal 2012-03-04 19:56:45 EST
Samuel,

Just to clarify removing gstreamer-plugins-bad-free does not break the system, but KDE has to be reinstalled after doing thisa.
Comment 6 walterhurry 2012-03-05 10:33:05 EST
It is not necessary to remove it. Just downgrading to gstreamer-plugins-bad-free-0.10.22-5 (likewise gstreamer-plugins-bad-free-0.10.22-5) is an easier workaround. Then either pin them until the issue is resolved, or use --skip-broken.

sudo yum downgrade gstreamer-plugins-bad-free gstreamer-plugins-bad-free-extras.
Comment 7 Dan Mashal 2012-03-05 10:45:14 EST
Again, the purpose of filing this bug is to avoid that.
Comment 8 walterhurry 2012-03-06 16:10:52 EST
I am aware of that. I was just pointing out an easier workaround for the issue with gstreamer-plugins-bad-free. Anyway, it is fixed now.
Comment 9 Dan Mashal 2012-03-07 22:57:58 EST
Thanks Walter.

Updates-testing repo looks good to me now.

Dan
Comment 10 Dan Mashal 2012-03-08 00:42:30 EST
I spoke too soon. I ran a test on i686 version.

On 17 x86_64 I'm getting this now:


Skipped (dependency problems):
  ImageMagick.x86_64 0:6.7.5.6-3.fc17  ImageMagick-c++.x86_64 0:6.7.5.6-3.fc17 

Complete!
[root@Fedora17 kernels]# yum update
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: mirrors.kernel.org
 * updates: mirrors.kernel.org
 * updates-testing: mirrors.kernel.org
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package ImageMagick.x86_64 0:6.7.1.9-3.fc17 will be updated
--> Processing Dependency: libMagickCore.so.4()(64bit) for package: autotrace-0.31.1-26.fc15.1.x86_64
--> Processing Dependency: libMagickCore.so.4()(64bit) for package: inkscape-0.48.2-1.fc17.x86_64
---> Package ImageMagick.x86_64 0:6.7.5.6-3.fc17 will be an update
---> Package ImageMagick-c++.x86_64 0:6.7.1.9-3.fc17 will be updated
--> Processing Dependency: libMagick++.so.4()(64bit) for package: inkscape-0.48.2-1.fc17.x86_64
---> Package ImageMagick-c++.x86_64 0:6.7.5.6-3.fc17 will be an update
--> Finished Dependency Resolution
Error: Package: inkscape-0.48.2-1.fc17.x86_64 (@fedora)
           Requires: libMagick++.so.4()(64bit)
           Removing: ImageMagick-c++-6.7.1.9-3.fc17.x86_64 (@fedora)
               libMagick++.so.4()(64bit)
           Updated By: ImageMagick-c++-6.7.5.6-3.fc17.x86_64 (updates-testing)
               Not found
Error: Package: autotrace-0.31.1-26.fc15.1.x86_64 (@fedora)
           Requires: libMagickCore.so.4()(64bit)
           Removing: ImageMagick-6.7.1.9-3.fc17.x86_64 (@anaconda-0)
               libMagickCore.so.4()(64bit)
           Updated By: ImageMagick-6.7.5.6-3.fc17.x86_64 (updates-testing)
               Not found
Error: Package: inkscape-0.48.2-1.fc17.x86_64 (@fedora)
           Requires: libMagickCore.so.4()(64bit)
           Removing: ImageMagick-6.7.1.9-3.fc17.x86_64 (@anaconda-0)
               libMagickCore.so.4()(64bit)
           Updated By: ImageMagick-6.7.5.6-3.fc17.x86_64 (updates-testing)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 11 Adam Williamson 2012-03-09 23:12:53 EST
Discussed at 2012-03-09 blocker review meeting. Agreed that bug is not a blocker: dependency issues in updates-testing are pretty common place and don't affect releases unless the problems get pushed to stable, which we would catch later.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Dan Mashal 2012-03-14 15:00:16 EDT
@Adam,

Then we shouldn't point to updates-testing repo out of the box, or tell people to use the updates-testing repo to fix other problems.

Dan
Comment 13 Adam Williamson 2012-03-14 18:34:15 EDT
Why? Because every so often it has dependency problems? It's a development repository. Of course this can happen. If you sign up to test a pre-release you can't expect everything to be 100% smooth all the time.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 mikolajbugs 2012-03-25 16:19:24 EDT
I believe this is relevant bug: https://bugzilla.redhat.com/show_bug.cgi?id=806661
Due to some dependency problem I am unable to install emacs.
Comment 15 Adam Williamson 2012-03-27 13:14:17 EDT
there's really no point keeping an eternal bug open for 'dependency issues we noticed in updates-testing this week'. it's not really helping anyone. let's close this.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.