Bug 799384 - Problems with glyphs Ѝ (U+040D) for Bulgarian language
Summary: Problems with glyphs Ѝ (U+040D) for Bulgarian language
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
high
high
Target Milestone: ---
Assignee: Pravin Satpute
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 799473 (view as bug list)
Depends On: 659214
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-02 15:56 UTC by Alexander Todorov
Modified: 2012-08-09 23:13 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 659214
Environment:
Last Closed: 2012-05-29 10:33:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Correct letter forms for U+040D and U+045D (52.77 KB, application/pdf)
2012-03-07 09:53 UTC, Mihail Balabanov
no flags Details

Description Alexander Todorov 2012-03-02 15:56:14 UTC
+++ This bug was initially created as a clone of Bug #659214 +++

Hi guys,
bug #659214 adds support for some Cyrillic characters to the Liberations fonts family. 

M. Balabanov, a member of a localization mailing list reported a problem with the glyphs.

The glyphs for CYRILLIC CAPITAL LETTER I WITH GRAVE (U+040D) is wrong (except for Mono Regular). Instead of Ѝ it is Ǹ (i.e it's swapped). 

The actual glyph is LATIN CAPITAL LETTER N WITH GRAVE (I just made that up, hopefully you get the point). 

This is with version:
1.07.1 of the fonts.

Comment 1 Alexander Todorov 2012-03-02 20:07:33 UTC
*** Bug 799473 has been marked as a duplicate of this bug. ***

Comment 2 Pravin Satpute 2012-03-05 03:53:51 UTC
I have fixed this issue in liberation-fonts-1.07.2, check for https://fedorahosted.org/liberation-fonts for latest release.

Comment 3 Mihail Balabanov 2012-03-06 12:21:08 UTC
I have checked liberation-fonts-1.07.2. The glyphs for 'CYRILLIC SMALL LETTER I WITH GRAVE' (U+045D) are indeed improved, now with correct italic shapes in Serif, Sans, and Sans Narrow.

The glyphs for 'CYRILLIC CAPITAL LETTER I WITH GRAVE' (U+040D) are still wrong though. Their current shapes in all fonts but Mono regular are still based on a capital Latin En (N) instead of on a capital Cyrillic I (И).

Comment 4 Pravin Satpute 2012-03-07 07:28:37 UTC
Does U+040D character has different shapes in normal and italic form?

Comment 5 Alexander Shopov 2012-03-07 09:38:48 UTC
U+040D should look exactly like 0+418 Cyrillic Capital Letter I (from the same font variant) + the grave accent

This is the same in all forms - roman, itallic, oblique, tnin, bold, black, demibold, etc.

The same rule is valid both in Bulgaria and Macedonia where the letter is used.

If the italic/cursive variants have different shapes for 0+418 - use them. 

However for the styles of Liberation family this is not the case - Cyrillic itallic capital I is shaped the same way as the non itallic variant.

Thus - just - copy and aggregate 0+418 and the glyph for grave you use.

If you want to be extremely punctual - we can try to place the grave to optically balance in the middle (since it is optically blacker on one side), but to be honest - that will be pointless.

Kind regards.
al_shopov

Comment 6 Mihail Balabanov 2012-03-07 09:53:57 UTC
Created attachment 568216 [details]
Correct letter forms for U+040D and U+045D

Comment 7 Pravin Satpute 2012-03-07 11:22:07 UTC
Thanks for clarifications.

I have done these changes and committed in upstream. This will be available with next release. Let me know, if required i can build this quickly in fedora with patch.

Comment 8 Alexander Shopov 2012-03-08 13:49:56 UTC
Hi, I have just verified that the glyphs look fine now. Thank you for the quick patches.
I expect these will be included in next release of Fedora and perhaps with the next updates of Fedora 16.

Comment 9 Fedora Update System 2012-05-11 05:38:56 UTC
liberation-fonts-1.07.2-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/liberation-fonts-1.07.2-4.fc17

Comment 10 Fedora Update System 2012-05-11 05:59:52 UTC
liberation-fonts-1.07.2-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/liberation-fonts-1.07.2-4.fc16

Comment 11 Fedora Update System 2012-05-11 21:52:50 UTC
Package liberation-fonts-1.07.2-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing liberation-fonts-1.07.2-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7730/liberation-fonts-1.07.2-4.fc17
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2012-05-29 10:33:13 UTC
liberation-fonts-1.07.2-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2012-05-29 16:20:02 UTC
liberation-fonts-1.07.2-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2012-06-26 09:06:31 UTC
liberation-fonts-1.07.2-6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/liberation-fonts-1.07.2-6.fc17

Comment 15 Fedora Update System 2012-06-26 09:08:05 UTC
liberation-fonts-1.07.2-6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/liberation-fonts-1.07.2-6.fc16

Comment 16 Fedora Update System 2012-07-26 22:33:20 UTC
liberation-fonts-1.07.2-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2012-08-09 23:13:53 UTC
liberation-fonts-1.07.2-6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.