Bug 799504 - Application compiled with lazarus are broken in F17 and higher
Application compiled with lazarus are broken in F17 and higher
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lazarus (Show other bugs)
rawhide
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Joost van der Sluis
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 799711
  Show dependency treegraph
 
Reported: 2012-03-02 15:02 EST by Mattia Verga
Modified: 2012-05-26 03:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-26 03:10:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mattia Verga 2012-03-02 15:02:36 EST
Would be possible to update lazarus to 0.9.30.2?
Or give me rights in pkgdb as co-maintainer to do this myself? (I've requested rights some month ago, still in pending status).

Thank you.
Comment 1 Mattia Verga 2012-03-04 05:02:28 EST
The current version in repositories doesn't work because was built against fpc 2.4.

I also tried to compile the 0.9.30 version locally with fpc 2.6 but it fails.

At the moment I'm unable to build package that I maintain (skychart).
Comment 2 Mattia Verga 2012-03-04 09:27:50 EST
I've just discovered that applications compiled with lazarus are all broken in Fedora 17 and higher due to glib2 >= 2.31.

There's a patch available here
http://svn.freepascal.org/cgi-bin/viewvc.cgi?view=rev&root=lazarus&revision=35051

that must be applied to support glib2 >= 2.31. This patch is not applied neither in 0.9.30.4RC1, so must be manually applied.
Comment 3 Mattia Verga 2012-03-10 03:30:16 EST
Lazarus 0.9.30.4RC2 was released a few days ago and it integrates the patch.
Comment 4 Bohuslav "Slavek" Kabrda 2012-03-15 05:32:09 EDT
Joost, any progress on this one? Even the Lazarus IDE won't start... I would really like to use my favourite Double Commander, which needs Lazarus to work.
Comment 5 Joost van der Sluis 2012-03-15 06:14:58 EDT
Wel, the news is that today Lazarus 0.9.30.4 is released. The first release that is build upon Free Pascal 2.6.0. It's not for nothing that it took so long before Free Pascal 2.6.0 was added to Fedora. 

I'll add Lazarus 0.9.30.4 to rawhide (btw: 0.9.30.2 is already in Rawhide, compiled with fpc 2.6.0. When it works in rawhide, I'll merge it to F17.
Comment 6 Mattia Verga 2012-03-23 15:57:18 EDT
Is there any chance to see this fixed soon?

Having apps that don't work in a Release Candidate and cannot fix them is really annoying (for me at least...).
Comment 7 Mattia Verga 2012-04-05 11:29:45 EDT
Any news?

If you don't have time just approve my co-maintainership request in pkgdb and I will do the update...

Thanks
Comment 8 Bohuslav "Slavek" Kabrda 2012-04-12 05:39:49 EDT
Joost, any progress on this one? Could you at least approve Mattia's ACLs, so that we can finally get Lazarus working?
Comment 9 Mattia Verga 2012-04-16 11:08:28 EDT
Without answers in the next 7 days, I will start to follow the "unresponsive package maintainer" policy, as discussed and suggested in the development mailing list.
Comment 10 Fedora Update System 2012-04-20 10:31:06 EDT
lazarus-0.9.30.4-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/lazarus-0.9.30.4-1.fc17
Comment 11 Fedora Update System 2012-04-27 19:34:27 EDT
Package lazarus-0.9.30.4-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lazarus-0.9.30.4-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6864/lazarus-0.9.30.4-1.fc17
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-05-26 03:10:47 EDT
lazarus-0.9.30.4-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.