Bug 799541 - wicd-curses crashes upon keyboard event
wicd-curses crashes upon keyboard event
Status: CLOSED DUPLICATE of bug 800617
Product: Fedora
Classification: Fedora
Component: wicd (Show other bugs)
16
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-02 17:21 EST by My Karlsson
Modified: 2012-03-21 14:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-21 14:24:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description My Karlsson 2012-03-02 17:21:21 EST
Description of problem:

wicd-curses crashes upon keyboard event.

Version-Release number of selected component (if applicable):

Fedora 16.
Wicd 1.7.0 (bzr-r552).

How reproducible:

Tested on a minimal Fedora 16 installation.

Steps to Reproduce:
1. Launch wicd-curses.
2. Push down a key on the keyboard.
  
Actual results:

The following traceback message:

EXCEPTION! Please report this to the maintainer and file a bug report with the backtrace below:
Traceback (most recent call last):
  File "/usr/share/wicd/curses/wicd-curses.py", line 904, in call_update_ui
    self.update_ui(True)                                
  File "/usr/share/wicd/curses/wicd-curses.py", line 89, in wrapper
    return func(*args, **kargs)
  File "/usr/share/wicd/curses/wicd-curses.py", line 915, in update_ui
    self.handle_keys(input_data[1])
  File "/usr/share/wicd/curses/wicd-curses.py", line 884, in handle_keys
    if urwid.is_mouse_event(k):
AttributeError: 'module' object has no attribute 'is_mouse_event'

Program terminates after the message.

Expected results:

Program not crashing.

Additional info:
Comment 1 David Cantrell 2012-03-21 14:24:18 EDT

*** This bug has been marked as a duplicate of bug 800617 ***

Note You need to log in before you can comment on or make changes to this bug.