Bug 800617 - Wicd-curses continues to be broken since F15
Wicd-curses continues to be broken since F15
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wicd (Show other bugs)
16
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 799541 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-06 14:36 EST by xaphir
Modified: 2012-04-11 12:54 EDT (History)
3 users (show)

See Also:
Fixed In Version: wicd-1.7.0-12.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-09 10:50:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xaphir 2012-03-06 14:36:09 EST
Description of problem:

Wicd-curses continues to be inoperable since at least F15.  Configuration
using arrow keys results in the following:



Traceback (most recent call last):
  File "/usr/share/wicd/curses/wicd-curses.py", line 905, in call_update_ui
    self.update_ui(True)                                
  File "/usr/share/wicd/curses/wicd-curses.py", line 89, in wrapper
    return func(*args, **kargs)
  File "/usr/share/wicd/curses/wicd-curses.py", line 916, in update_ui
    self.handle_keys(input_data[1])
  File "/usr/share/wicd/curses/wicd-curses.py", line 885, in handle_keys
    if urwid.is_mouse_event(k):
AttributeError: 'module' object has no attribute 'is_mouse_event'



Version-Release number of selected component (if applicable):

wicd-gtk-1.7.1-0.3.b2.fc17.noarch
wicd-curses-1.7.1-0.3.b2.fc17.noarch
wicd-1.7.1-0.3.b2.fc17.x86_64
wicd-common-1.7.1-0.3.b2.fc17.noarch

(and all lesser versions as well starting
with F16 or F15 or possibly F14 packages)

How reproducible:

Start wicd-curses, hit right or left arrow to configure

Actual results:

It crashes

Expected results:

You should be able to enter configuration mode without crash.


Additional info:

#wicd channel has confirmed that this is a Fedora-specific problem by running their wicd compiled under F16 in a vm.  Wicd author's source compiled under F16 does not exhibit these problems, however the Fedora packages do.

It was reported that this was fixed in 1.7.1; it's not.  Also this has been a problem since Fedora 15 or before.
Comment 1 zombu2 2012-03-11 22:12:41 EDT
same problem 

How reproducible:

Start wicd-curses, hit right or left arrow to configure

Actual results:

It crashes

Expected results:

You should be able to enter configuration mode without crash.
Comment 2 David Cantrell 2012-03-21 14:23:25 EDT
Comparing the 1.7.0 code to 1.7.1, I created this patch:

diff -up wicd-1.7.0/curses/wicd-curses.py.orig wicd-1.7.0/curses/wicd-curses.py
--- wicd-1.7.0/curses/wicd-curses.py.orig	2012-03-21 14:20:39.808063903 -0400
+++ wicd-1.7.0/curses/wicd-curses.py	2012-03-21 14:21:04.392066581 -0400
@@ -881,7 +881,11 @@ class appGUI():
                                                 data[4], False)
             
         for k in keys:
-            if urwid.is_mouse_event(k):
+            if urwid.VERSION < (1, 0, 0):
+                check_mouse_event = urwid.is_mouse_event
+            else:
+                check_mouse_event = urwid.util.is_mouse_event
+            if check_mouse_event(k):
                 event, button, col, row = k
                 self.frame.mouse_event( self.size,
                         event, button, col, row,

With this patch in place, I can use the arrow keys in wicd-curses and it doesn't crash.  Creating a testing update for this fix for F-16.
Comment 3 David Cantrell 2012-03-21 14:24:18 EDT
*** Bug 799541 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2012-03-21 14:41:10 EDT
wicd-1.7.0-11.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/wicd-1.7.0-11.fc16
Comment 5 Fedora Update System 2012-03-21 21:54:38 EDT
Package wicd-1.7.0-11.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wicd-1.7.0-11.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4397/wicd-1.7.0-11.fc16
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-03-26 16:04:58 EDT
wicd-1.7.0-12.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/wicd-1.7.0-12.fc16
Comment 7 xaphir 2012-04-04 13:11:24 EDT
Unless someone else has different results, this bug looks fixed to me.
Comment 8 xaphir 2012-04-09 10:49:51 EDT
How long before this gets pushed to the mainline updates?  I did a new F16 install today and it isn't showing up yet?
Comment 9 David Cantrell 2012-04-09 11:28:21 EDT
I just marked it as stable in the updates system.  FWIW, you can report that the update works for you in the updates system (requires a Fedora account).  When updates go out, they go to the updates-testing repo and if the karma reaches 3, it automatically moves it to the updates stable repo.  However, I've never had that happen in all the years we've had this update system so I have to wait for 7 days until I can manually push the update to the stable repo.
Comment 10 Fedora Update System 2012-04-11 12:54:19 EDT
wicd-1.7.0-12.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.