Bug 799564 - Cypress Touchpad isn't identified correctly
Cypress Touchpad isn't identified correctly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: FutureFeature
: 845071 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-02 22:43 EST by James Turner
Modified: 2013-02-15 20:20 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-08 11:55:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lspci -vvnn output (21.07 KB, text/plain)
2012-03-05 17:54 EST, James Turner
no flags Details
lsusb -vv output (44.87 KB, text/plain)
2012-03-05 17:55 EST, James Turner
no flags Details
xinput (1010 bytes, application/octet-stream)
2013-02-12 17:03 EST, Sten Turpin
no flags Details
lspci (8.59 KB, application/octet-stream)
2013-02-12 17:04 EST, Sten Turpin
no flags Details
lsusb (42.01 KB, application/octet-stream)
2013-02-12 17:05 EST, Sten Turpin
no flags Details

  None (edit)
Description James Turner 2012-03-02 22:43:36 EST
On a fully updated Fedora 16 x86_64 system on a Dell XPS 13 ultrabook, the touchpad isn't identified correctly and shows up as "ImPS/2 Generic Wheel Mouse".

Because of this, the synaptics drive is not loaded and none of the touchpad features are available.

I: Bus=0011 Vendor=0002 Product=0005 Version=0000
N: Name="ImPS/2 Generic Wheel Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input5
U: Uniq=
H: Handlers=mouse0 event5 
B: PROP=0
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=103

Please let me know what other information you need.
Comment 1 Josh Boyer 2012-03-05 13:56:32 EST
Can you provide the output of 'lspci -vvnn' and 'lsusb -vv' ?

I have a feeling this is going to be another ALPS device that isn't supported yet.
Comment 2 James Turner 2012-03-05 17:54:36 EST
Created attachment 567774 [details]
lspci -vvnn output
Comment 3 James Turner 2012-03-05 17:55:09 EST
Created attachment 567775 [details]
lsusb -vv output
Comment 4 James Turner 2012-03-05 17:55:37 EST
Output from both commands are attached.
Comment 5 Dave Jones 2012-03-22 12:51:10 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 6 Dave Jones 2012-03-22 12:55:25 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 7 Dave Jones 2012-03-22 13:06:07 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 8 James Turner 2012-03-23 09:37:02 EDT
The touchpad still isn't identified correctly under 3.3.0.
Comment 9 Neo Jia 2012-04-13 05:16:36 EDT
Upgrading to the latest Fedora 16 kernel (3.3.1), problem still exists, please let me know if there is anything I can help.
Comment 10 Neo Jia 2012-04-16 22:19:06 EDT
the problem is that currently there is no way for me to do a copy & paste with this trackpad on Xterm. Anybody has a solution for this?

I have tried the liveCD for Fedora 17 as well, same result, it doesn't work there.
Comment 11 James Turner 2012-04-17 18:34:46 EDT
(In reply to comment #10)
> the problem is that currently there is no way for me to do a copy & paste with
> this trackpad on Xterm. Anybody has a solution for this?
> 
> I have tried the liveCD for Fedora 17 as well, same result, it doesn't work
> there.

You will need to install xorg-x11-apps. Then create a script that contains the following

/usr/bin/xinput set-prop 'ImPS/2 Generic Wheel Mouse' 'Evdev Middle Button Emulation' 1

I have gnome-session run the script on log in. This should enable middle clicking.
Comment 12 Neo Jia 2012-04-17 20:09:08 EDT
James, thanks! that works for me although it is hard to press right and left button together on this cypress trackpad to do a copy & paste.
Comment 13 James Turner 2012-04-17 21:17:00 EDT
(In reply to comment #12)
> James, thanks! that works for me although it is hard to press right and left
> button together on this cypress trackpad to do a copy & paste.

On an unrelated note, you can always use shift+insert to paste text inside xterm rather then pressing the right and left mouse buttons.
Comment 14 Jonathan Billings 2012-06-26 08:49:40 EDT
It appears that Ubuntu has a patch that makes the Cypress touchpad work on the Dell XPS-13:

http://kernel.ubuntu.com/git?p=kamal/ubuntu-precise.git;a=commit;h=8591b1a6356aa4d4db9557ba2b86f7bacabec376

Discussed on: https://launchpad.net/~kamalmostafa/+archive/dellxps
Comment 15 Josh Boyer 2012-06-26 09:51:37 EDT
That driver hasn't been posted upstream to my knowledge.  It isn't in the linux-next tree either.
Comment 16 Jonathan Billings 2012-06-26 10:51:38 EDT
(In reply to comment #15)
> That driver hasn't been posted upstream to my knowledge.  It isn't in the
> linux-next tree either.

Just a heads-up, then.  If it does get incorporated upstream, it does fix this issue.  I built a custom fedora 17 kernel with the patch, and when I use that kernel it appears as a touchpad, with both horizontal and vertical scrolling and all those features.

From /proc/bus/input/devices:

I: Bus=0011 Vendor=0002 Product=0008 Version=0001
N: Name="CyPS/2 Cypress Trackpad"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input5
U: Uniq=
H: Handlers=mouse0 event5 
B: PROP=0
B: EV=b
B: KEY=e520 70000 0 0 0 0
B: ABS=660800011000003
Comment 17 Josh Boyer 2012-09-05 09:41:32 EDT
*** Bug 845071 has been marked as a duplicate of this bug. ***
Comment 18 Josh Boyer 2012-09-18 11:12:13 EDT
Moving this to rawhide so we can track it there.
Comment 19 Ozan Çağlayan 2012-11-06 17:39:30 EST
Hi people,

I also patched this series to the latest 3.6.3 kernel in fc17. The same touchpad is also in Lenovo U300s ultrabook and probably in a lot of other notebooks too.

It brings multi-touch scrolling, disable-while-tapping and most importantly after a quick-fix to udev keymap file the Fn-Fx combination for enabling/disabling the touchpad now works. It was not working with the generic PS/2 mouse driver with the same quick-fix applied.

I'm now posting to LKML, linux-input, Canonical, Dell and Cypress about why they are not pushing this to upstream.

I do not know the policy of Fedora but it would be nice to see this patch applied.

Thanks.
Comment 20 Josh Boyer 2013-01-28 20:42:10 EST
The patches for the cypress ps/2 trackpad are in the upstream linux-next kernel now as part of the input tree.  I've started a scratch build with the patches included here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=4910262

If you would like to test this kernel to see if the trackpad is working, that would be much appreciated.  NOTE: I do not believe it supports multitouch at this time.
Comment 21 Lorenzo Villani 2013-01-29 02:15:23 EST
Works for me, including two finger scrolling and tap to click (Fedora 18, x86_64).
Comment 22 Lorenzo Villani 2013-01-29 02:17:19 EST
Forgot to mention that I'm on a Dell XPS 13.
Comment 23 Josh Boyer 2013-01-29 07:13:53 EST
Great.  Thanks for testing Lorenzo.
Comment 24 Jonathan Billings 2013-01-29 08:30:37 EST
Just tested the test kernel two finger scrolling and tap to click on my Dell XPS 13 running Fedora 18 x86_64, and it works.  In Gnome, you have to enable the extra features in the Mouse and Trackpad applet in System Settings.
Comment 25 Josh Boyer 2013-01-29 08:50:50 EST
Excellent.  We've had one other confirmed case of it working as well.  I've included the patches in the F17-rawhide kernels.  Thanks to everyone for testing.
Comment 26 Vinod Kutty 2013-02-01 12:20:57 EST
Thanks for this kernel. Tested on Dell XPS 13 running F18 x86_64 and now the touchpad is recognized correctly and two-finger scrolling works.

Looking forward to GA of this fix in F18.
Comment 27 Fedora Update System 2013-02-04 16:51:20 EST
kernel-3.7.6-201.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.7.6-201.fc18
Comment 28 Fedora Update System 2013-02-04 16:57:00 EST
kernel-3.7.6-102.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.7.6-102.fc17
Comment 29 Fedora Update System 2013-02-05 11:56:23 EST
Package kernel-3.7.6-201.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.7.6-201.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1961/kernel-3.7.6-201.fc18
then log in and leave karma (feedback).
Comment 30 Fedora Update System 2013-02-08 11:55:30 EST
kernel-3.7.6-201.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 31 Sten Turpin 2013-02-12 17:02:10 EST
Hi, I'm using Fedora 18 with 3.7.6-201.fc18 on a Dell XPS-12, which also has a Cypress touchpad, and my touchpad still shows up incorrectly.
Comment 32 Sten Turpin 2013-02-12 17:03:19 EST
Created attachment 696625 [details]
xinput
Comment 33 Sten Turpin 2013-02-12 17:04:37 EST
Created attachment 696626 [details]
lspci
Comment 34 Sten Turpin 2013-02-12 17:05:51 EST
Created attachment 696627 [details]
lsusb
Comment 35 Josh Boyer 2013-02-13 09:26:00 EST
Please open a different bug.
Comment 36 Fedora Update System 2013-02-15 20:20:06 EST
kernel-3.7.6-102.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.