Bug 845071 - Experimental Cypress PS/2 Trackpad Driver With Multi-Touch Support
Experimental Cypress PS/2 Trackpad Driver With Multi-Touch Support
Status: CLOSED DUPLICATE of bug 799564
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-01 12:09 EDT by Lorenzo Villani
Modified: 2012-09-05 09:41 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-05 09:41:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[PATCH 1/2] The Cypress Trackpad Driver from Kamal Mostafa's kernel tree. (41.75 KB, patch)
2012-08-01 12:09 EDT, Lorenzo Villani
no flags Details | Diff
[PATCH 2/2] Cypress Driver Debug Parameter (908 bytes, patch)
2012-08-01 12:12 EDT, Lorenzo Villani
no flags Details | Diff
Fedora kernel package .spec changes (46.28 KB, patch)
2012-08-01 16:44 EDT, Lorenzo Villani
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 978807 None None None 2012-08-01 12:09:59 EDT

  None (edit)
Description Lorenzo Villani 2012-08-01 12:09:59 EDT
Created attachment 601780 [details]
[PATCH 1/2] The Cypress Trackpad Driver from Kamal Mostafa's kernel tree.

Description of problem:
The Cypress trackpad on some laptops (such as the Dell XPS 13) is recognized as a generic PS/2 input device. While basic functionality such as moving the cursor and left/right mouse click works, other features such as two-finger scrolling and tap-to-click do not.


Version-Release number of selected component (if applicable):
3.4.6-1


How reproducible:
Always

  
Actual results:
Tap-to-click and two-finger-scrolling don't work.


Expected results:
It should be possible to use Gnome's System Settings to change trackpad properties the same way we can do for e.g. Synaptics devices.


Additional info:

The driver is available at:

http://kernel.ubuntu.com/git?p=kamal/ubuntu-precise.git;a=commit;h=c53e513de4dea9da025a1d9f92f45e9d44d58c0a
Comment 1 Lorenzo Villani 2012-08-01 12:12:02 EDT
Created attachment 601781 [details]
[PATCH 2/2] Cypress Driver Debug Parameter
Comment 2 Lorenzo Villani 2012-08-01 16:44:10 EDT
Created attachment 601822 [details]
Fedora kernel package .spec changes
Comment 3 Lorenzo Villani 2012-08-01 16:45:44 EDT
Tested on both 3.4.6 and 3.5.0 kernels. No major problems so far.
Comment 4 Josh Boyer 2012-08-01 20:41:38 EDT
This isn't something we're going to carry out of tree.  The driver isn't in linux-next from what I can tell, nor has it been submitted upstream.

Pretty sure this is a duplicate of bug 799564
Comment 5 Josh Boyer 2012-09-05 09:41:32 EDT

*** This bug has been marked as a duplicate of bug 799564 ***

Note You need to log in before you can comment on or make changes to this bug.