Bug 799686 - Plymouth boot splash is randomly interrupted
Plymouth boot splash is randomly interrupted
Status: CLOSED DUPLICATE of bug 785662
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
16
Unspecified Linux
unspecified Severity low
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-04 04:44 EST by Saurav Sengupta
Modified: 2012-03-07 01:36 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-07 01:36:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurav Sengupta 2012-03-04 04:44:08 EST
Description of problem:
The boot splash rendered by Plymouth is sometimes interrupted and either a text-mode boot screen flashes and disrupts the continuity of the splash, or the splash disappears for several seconds or till the completion of the boot process and the text mode is displayed instead, without any boot messages in both cases. I have noticed that when this does happen, it always does so when the system attempts to start the Plymouth service. What I cannot understand is, since the message about starting the Plymouth service appears quite late in the boot sequence (the service is apparently started after several others), how and/or why is the splash screen shown before that anyway? Also, I could not figure out whether this problem is caused by Plymouth or systemd, so I have not been able to select the proper component for this bug report.

Version-Release number of selected component (if applicable):


How reproducible:
Often

Steps to Reproduce:
1. Boot a Fedora desktop system with Plymouth enabled.
  
Actual results:
The splash screen is sometimes interrupted by display of the text mode.

Expected results:
The splash screen is displayed continuously in an uninterrupted manner during the entire boot process.

Additional info:
I have installed my system, on which this happens, from a live image on a Dell Inspiron 1545 laptop with integrated Intel GM45 graphics.
Comment 1 Bill Nottingham 2012-03-05 12:04:29 EST
This is almost certainly "interactions between plymouth and systemd".

Moving to systemd, cc'ing plymouth maintainer.
Comment 2 Jóhann B. Guðmundsson 2012-03-05 12:52:18 EST
More likely this is an xorg-x11-drv-intel bug which affects all 3.kernels . 

We have had quite a few of those lately which are having weird effects like monitors suddenly suspend when plymouth loads and what not. 

The easiest way to test if that's the case is to install and boot pre 3.x kernel or follow what's something like is suggested in comment 8 and comment 9 in bug 753881
Comment 3 Michal Schmidt 2012-03-05 13:41:54 EST
Or it could be bug 785662
Comment 4 Saurav Sengupta 2012-03-06 05:53:13 EST
Yes, it does seem to be bug 785662. I'll close this one as a duplicate after some more testing. Thanks.
Comment 5 Saurav Sengupta 2012-03-07 01:36:13 EST

*** This bug has been marked as a duplicate of bug 785662 ***

Note You need to log in before you can comment on or make changes to this bug.