Bug 785662 - fedora-readonly.service claims StandardInput=tty for no apparent reason
Summary: fedora-readonly.service claims StandardInput=tty for no apparent reason
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 799686 805312 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-01-30 08:59 UTC by Michal Schmidt
Modified: 2014-03-17 03:29 UTC (History)
9 users (show)

Fixed In Version: initscripts-9.37-1.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-15 02:22:56 UTC
Type: ---


Attachments (Terms of Use)

Description Michal Schmidt 2012-01-30 08:59:41 UTC
Description of problem:
/lib/systemd/system/fedora-readonly.service specifies 'tty' for its StandardInput.
The script it runs does not seem to require interaction, so this is unnecessary.
Furthermore, if tty were necessary, the service would have to deal with plymouth somehow.

Suggested fix: Remove the StandardInput line. Let the default be used.

Version-Release number of selected component (if applicable):
initscripts-9.34-2.fc16.x86_64

Additional info:
The setting causes a superfluous reset of the terminal by systemd when the service is starting. Current systemd versions will switch the terminal to text mode on reset. This causes cosmetic issues with plymouth, as in bug 785548.

Comment 1 leigh scott 2012-01-30 09:40:54 UTC
I can confirm commenting out the line in /lib/systemd/system/fedora-readonly.service resolves my plymouth issue.

Comment 2 Bill Nottingham 2012-01-30 21:41:16 UTC
Thanks, fixed in git.

Comment 3 Saurav Sengupta 2012-03-07 06:36:13 UTC
*** Bug 799686 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2012-03-09 16:56:32 UTC
initscripts-9.35-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/initscripts-9.35-1.fc17

Comment 5 Fedora Update System 2012-03-09 17:57:27 UTC
Package initscripts-9.35-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing initscripts-9.35-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3459/initscripts-9.35-1.fc17
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2012-03-09 18:25:26 UTC
initscripts-9.34.1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/initscripts-9.34.1-1.fc16

Comment 7 Fedora Update System 2012-03-12 18:22:13 UTC
initscripts-9.34.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/initscripts-9.34.2-1.fc16

Comment 8 Fedora Update System 2012-03-12 18:32:11 UTC
initscripts-9.36-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/initscripts-9.36-1.fc17

Comment 9 Fedora Update System 2012-03-15 02:22:56 UTC
initscripts-9.34.2-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Bill Nottingham 2012-03-20 21:19:53 UTC
*** Bug 805312 has been marked as a duplicate of this bug. ***

Comment 11 Fedora Update System 2012-03-23 17:44:24 UTC
initscripts-9.37-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.