Bug 799976 - Review Request: hibernate-validator - Bean Validation (JSR 303) Reference Implementation
Review Request: hibernate-validator - Bean Validation (JSR 303) Reference Imp...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Andy Grimm
Fedora Extras Quality Assurance
:
: 767050 (view as bug list)
Depends On: 796204
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-05 09:28 EST by Juan Hernández
Modified: 2016-11-07 22:46 EST (History)
5 users (show)

See Also:
Fixed In Version: hibernate-validator-4.2.0-4.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-13 12:44:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
agrimm: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Juan Hernández 2012-03-05 09:28:16 EST
Spec URL:

http://jhernand.fedorapeople.org/rpms/hibernate-validator/4.2.0-4/hibernate-validator.spec

SRPM URL:

http://jhernand.fedorapeople.org/rpms/hibernate-validator/4.2.0-4/hibernate-validator-4.2.0-4.fc17.src.rpm

Description:

Reference implementation of JSR 303 - Bean Validation. Bean Validation defines
a metadata model and API for JavaBean validation. The default metadata source
is annotations, with the ability to override and extend the meta-data through
the use of XML validation descriptors.
Comment 1 Andy Grimm 2012-03-05 10:14:15 EST
*** Bug 767050 has been marked as a duplicate of this bug. ***
Comment 2 Andy Grimm 2012-03-12 15:54:52 EDT
I think there are some deps missing here -- maven-anno-plugin, xsom, possibly more.  Please make sure this builds in koji first, and then I'll continue the review.
Comment 3 Juan Hernández 2012-03-13 07:13:28 EDT
You are right Andy, there were issues in the dependencies in maven-jaxb2-plugin and glassfish-jaxb, but not in hibernate-validator itself. I have fixed both and the package builds correctly now in Koji:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3888605

Sorry for the inconveniences.
Comment 4 Andy Grimm 2012-03-13 11:20:19 EDT
Package Review
==============

Key:
- = N/A
x = Check
! = Problem
? = Not evaluated

=== REQUIRED ITEMS ===
[x]  Rpmlint output:
hibernate-validator.noarch: W: invalid-url URL: http://www.hibernate.org/subprojects/validator.html HTTP Error 403: Forbidden
hibernate-validator.src: W: invalid-url URL: http://www.hibernate.org/subprojects/validator.html HTTP Error 403: Forbidden
hibernate-validator.src: W: invalid-url Source0: hibernate-validator-4.2.0.Final.tar.xz
hibernate-validator-javadoc.noarch: W: invalid-url URL: http://www.hibernate.org/subprojects/validator.html HTTP Error 403: Forbidden
3 packages and 0 specfiles checked; 0 errors, 4 warnings.

this is normal for jboss packages' URLs

[x]  Package is named according to the Package Naming Guidelines[1].
[x]  Spec file name must match the base package name, in the format %{name}.spec.
[x]  Package meets the Packaging Guidelines[2].
[x]  Package successfully compiles and builds into binary rpms.
[x]  Buildroot definition is not present
[x]  Package is licensed with an open-source compatible license and meets other legal requirements as defined in the legal section of Packaging Guidelines[3,4].
[x]  License field in the package spec file matches the actual license.
License type: ASL 2.0
[x]  If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package is included in %doc.
[x]  All independent sub-packages have license of their own
[x]  Spec file is legible and written in American English.
[x]  Sources used to build the package matches the upstream source, as provided in the spec URL.
Git source, unpacked tarball matches
[x]  All build dependencies are listed in BuildRequires, except for any that are listed in the exceptions section of Packaging Guidelines[5].
[x]  Package must own all directories that it creates or must require other packages for directories it uses.
[x]  Package does not contain duplicates in %files.
[x]  File sections do not contain %defattr(-,root,root,-) unless changed with good reason
[x]  Permissions on files are set properly.
[x]  Package does NOT have a %clean section which contains rm -rf %{buildroot} (or $RPM_BUILD_ROOT). (not needed anymore)
[x]  Package consistently uses macros (no %{buildroot} and $RPM_BUILD_ROOT mixing)
[x]  Package contains code, or permissable content.
[-]  Fully versioned dependency in subpackages, if present.
[-]  Package contains a properly installed %{name}.desktop file if it is a GUI application.
[x]  Package does not own files or directories owned by other packages.
[x]  Javadoc documentation files are generated and included in -javadoc subpackage
[x]  Javadocs are placed in %{_javadocdir}/%{name} (no -%{version} symlinks)
[x]  Packages have proper BuildRequires/Requires on jpackage-utils
[x]  Javadoc subpackages have Require: jpackage-utils
[x]  Package uses %global not %define
[x]  If package uses tarball from VCS include comment how to re-create that tarball (svn export URL, git clone URL, ...)
[-]  If source tarball includes bundled jar/class files these need to be removed prior to building
[x]  All filenames in rpm packages must be valid UTF-8.
[x]  Jar files are installed to %{_javadir}/%{name}.jar (see [6] for details)
[x]  If package contains pom.xml files install it (including depmaps) even when building with ant
[x]  pom files has correct add_maven_depmap

=== Maven ===
[x]  Use %{_mavenpomdir} macro for placing pom files instead of %{_datadir}/maven2/poms
[-]  If package uses "-Dmaven.test.skip=true" explain why it was needed in a comment
[-]  If package uses custom depmap "-Dmaven.local.depmap.file=*" explain why it's needed in a comment
[x]  Package DOES NOT use %update_maven_depmap in %post/%postun
[x]  Packages DOES NOT have Requires(post) and Requires(postun) on jpackage-utils for %update_maven_depmap macro

=== Other suggestions ===
[x]  If possible use upstream build method (maven/ant/javac)
[x]  Avoid having BuildRequires on exact NVR unless necessary
[x]  Package has BuildArch: noarch (if possible)
[x]  Latest version is packaged.
[x]  Reviewer should test that the package builds in mock.
Tested on: http://koji.fedoraproject.org/koji/taskinfo?taskID=3888606

=== Issues ===
None noted.

================
*** APPROVED ***
================
Comment 5 Juan Hernández 2012-03-13 11:30:39 EDT
New Package SCM Request
=======================
Package Name: hibernate-validator
Short Description: Bean Validation (JSR 303) Reference Implementation
Owners: jhernand
Branches: f17
InitialCC: goldmann, arg
Comment 6 Gwyn Ciesla 2012-03-13 11:34:19 EDT
Git done (by process-git-requests).
Comment 7 Fedora Update System 2012-03-23 12:16:23 EDT
hibernate-validator-4.2.0-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/hibernate-validator-4.2.0-4.fc17
Comment 8 Fedora Update System 2012-04-11 23:19:27 EDT
hibernate-validator-4.2.0-4.fc17 has been pushed to the Fedora 17 stable repository.

Note You need to log in before you can comment on or make changes to this bug.