This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 799999 - WFK2 Enterprise Maven repository cleanup
WFK2 Enterprise Maven repository cleanup
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Maven (Show other bugs)
2.0.0.ER1
Unspecified Unspecified
medium Severity medium
: ---
: 2.0.0.ER7
Assigned To: Marius Bogoevici
Karel Piwko
:
Depends On:
Blocks: 820740
  Show dependency treegraph
 
Reported: 2012-03-05 10:20 EST by Karel Piwko
Modified: 2013-03-03 20:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 820740 (view as bug list)
Environment:
Last Closed: 2012-06-22 04:03:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Piwko 2012-03-05 10:20:43 EST
According to our Maven repository verified, following problem were identified in Maven repository:

1/ 

jboss-wfk-2.0.0.ER1-repository/org/richfaces/examples/richfaces-showcase/4.2.0.Final-redhat-1/ contains -sources.jar and -javadoc.jar, but war file is missing => remove completely

2/ 

jboss-wfk-2.0.0.ER1-repository/com/redhat/jboss/jboss-wfk/2.0.0.ER1/jboss-wfk-2.0.0.ER1.pom => this is a build file, should not be in the repository

3/ org.jboss.logging:jboss-logging-processor:jar must be a valid version but is '${version.org.jboss.logging.jboss-logging-tools}'. @ org.hibernate:hibernate-search-parent:4.1.0.Beta2-redhat-1

(can be applied to multiple POMs)

4/ org.hibernate:hibernate-search-orm:jar:4.1.0.Beta2-redhat-1 (compile)
Could not find artifact org.apache.commons:commons-parent:pom:22-redhat-1 

(can be applied to multiple POMs)

5/ org.jboss.snowdrop:snowdrop-facade:jar:2.0.2.Final-redhat-1: Could not find artifact org.jboss.kernel:jboss-dependency:jar:2.2.0.SP2 

6/richfaces-ui-validator-ui: Nested: Could not find artifact org.jboss.test-jsf:maven-mockgenerator-plugin:jar:1.1.2-redhat-1
Comment 1 Marek Novotny 2012-03-05 11:03:39 EST
ad 1 - already in filter for Maven repository 

ad 2 - already in filter for Maven repository

ad 3 - 4.1.0.Beta2-redhat-1 was old artifact, now there should be only 4.1.0.CR1-redhat-1

ad 4 - commons-parent should be in EAP6 repository

ad 5 - not sure what solution will be here, it is only in JBoss Releases repository

ad 6 - it should be in WFK repository at least here http://download.devel.redhat.com/brewroot/repos/jb-wfk-2-rhel-6-build/latest/maven/org/jboss/test-jsf/maven-mockgenerator-plugin/1.1.2-redhat-1/, will check the inclusion in WFK repo for ER2
Comment 2 Karel Piwko 2012-03-05 13:53:13 EST
Is there a chance to make org.jboss.kernel in snowdrop-facade optional? Because this seems like JBoss AS 6 dependency to me.
Comment 3 Marek Novotny 2012-03-05 16:20:37 EST
it is like JBoss AS 5/6 dependency, unfortunately we didn't say if we strictly support only EAP6/AS7 or the whole bunch of AS 5,6,7? I don't recall it, but I suppose that we wan to continue to support Snowdrop 1.x in 2.x
Comment 4 Marek Novotny 2012-04-27 07:09:05 EDT
Marius, could you decide if I can make org.jboss.kernel in snowdrop-facade optional?
Comment 5 Karel Piwko 2012-05-10 06:04:11 EDT
This issue affects building from source for Snowdrop users in ER5.
Comment 6 Marius Bogoevici 2012-05-10 09:15:56 EDT
Yes, the snowdrop dependency can be made optional (even provided) but I'm not 
sure how this will help with building from source. I think we need a TN for 
this.
Comment 7 Karel Piwko 2012-06-05 06:37:31 EDT
Points 1/ to 6/ were verified. JBoss Kernel is included in WFK, but it still requires some of the external dependencies, tracked in bug 820740.

Note You need to log in before you can comment on or make changes to this bug.