Bug 820740 - Snowdrop sources cannot be built out of the box
Snowdrop sources cannot be built out of the box
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Spring, doc-Maven-Repository-User-Guide (Show other bugs)
2.0.0.ER1
Unspecified Unspecified
low Severity low
: CR2
: 2.2.0
Assigned To: Petr Penicka
Tomas Repel
: Documentation
Depends On: 799999
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-10 16:26 EDT by Karel Piwko
Modified: 2014-01-13 03:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Snowdrop sources could not be compiled out of the box because they required artifacts that were not present in Maven Central nor in the Maven repositories distributed with JBoss Web Framework Kit. To fix this issue, the dependencies on missing artifacts have been updated to versions that are present in the JBoss Enterprise Application Platform 6.0.1 Maven repository, and several unnecessary transitive dependencies have been excluded. As a result of the fix, Snowdrop sources can be compiled out of the box successfully.
Story Points: ---
Clone Of: 799999
Environment:
Last Closed: 2013-05-14 10:51:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Piwko 2012-05-10 16:26:56 EDT
+++ This bug was initially created as a clone of Bug #799999 +++

Snowdrop requires artifacts which are not present in Maven Central nor distributed directories, you have to enable JBoss Nexus repository according to instructions at https://community.jboss.org/wiki/MavenGettingStarted-Users


<profile>
      <id>jboss-public-repository</id>
      <repositories>
        <repository>
          <id>jboss-public-repository-group</id>
          <name>JBoss Public Maven Repository Group</name>
          <url>https://repository.jboss.org/nexus/content/groups/public-jboss/</url>
          <layout>default</layout>
          <releases>
            <enabled>true</enabled>
            <updatePolicy>never</updatePolicy>
          </releases>
          <snapshots>
            <enabled>true</enabled>
            <updatePolicy>never</updatePolicy>
          </snapshots>
        </repository>
      </repositories>
      <pluginRepositories>
        <pluginRepository>
          <id>jboss-public-repository-group</id>
          <name>JBoss Public Maven Repository Group</name>
          <url>https://repository.jboss.org/nexus/content/groups/public-jboss/</url>
          <layout>default</layout>
          <releases>
            <enabled>true</enabled>
            <updatePolicy>never</updatePolicy>
          </releases>
          <snapshots>
            <enabled>true</enabled>
            <updatePolicy>never</updatePolicy>
          </snapshots>
        </pluginRepository>
      </pluginRepositories>
    </profile>


  <activeProfiles>
    <activeProfile>jboss-public-repository</activeProfile>
  </activeProfiles>
Comment 1 Marius Bogoevici 2012-05-11 10:53:14 EDT
Yes, we need a technical note on this (the attached proposal looks right to me).
Comment 4 Karel Piwko 2012-06-05 06:35:44 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Compilation of Snowdrop requires artifacts which are not present in Maven Central nor distributed Maven repositories. You have to enable JBoss Nexus repository according to instructions at https://community.jboss.org/wiki/MavenGettingStarted-Users, namely include following snippet into settings.xml file:

<profile>
      <id>jboss-public-repository</id>
      <repositories>
        <repository>
          <id>jboss-public-repository-group</id>
          <name>JBoss Public Maven Repository Group</name>
          <url>https://repository.jboss.org/nexus/content/groups/public-jboss/</url>
          <layout>default</layout>
          <releases>
            <enabled>true</enabled>
            <updatePolicy>never</updatePolicy>
          </releases>
          <snapshots>
            <enabled>true</enabled>
            <updatePolicy>never</updatePolicy>
          </snapshots>
        </repository>
      </repositories>
      <pluginRepositories>
        <pluginRepository>
          <id>jboss-public-repository-group</id>
          <name>JBoss Public Maven Repository Group</name>
          <url>https://repository.jboss.org/nexus/content/groups/public-jboss/</url>
          <layout>default</layout>
          <releases>
            <enabled>true</enabled>
            <updatePolicy>never</updatePolicy>
          </releases>
          <snapshots>
            <enabled>true</enabled>
            <updatePolicy>never</updatePolicy>
          </snapshots>
        </pluginRepository>
      </pluginRepositories>
    </profile>


  <activeProfiles>
    <activeProfile>jboss-public-repository</activeProfile>
  </activeProfiles>
Comment 5 Rebecca Newton 2012-06-19 00:56:39 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,5 +1,7 @@
-Compilation of Snowdrop requires artifacts which are not present in Maven Central nor distributed Maven repositories. You have to enable JBoss Nexus repository according to instructions at https://community.jboss.org/wiki/MavenGettingStarted-Users, namely include following snippet into settings.xml file:
+Snowdrop source cannot be build out of the box because it requires artifacts which are not present in Maven Central nor distributed Enterprise Maven repositories. The workaround for this issue is to enable JBoss Nexus repository
 
+To workaround this issue, enable the JBoss Nexus repository by including the following snippet in the settings.xml file:
+
 <profile>
       <id>jboss-public-repository</id>
       <repositories>
@@ -39,4 +41,7 @@
 
   <activeProfiles>
     <activeProfile>jboss-public-repository</activeProfile>
-  </activeProfiles>+  </activeProfiles>
+
+
+More information on setting the public repository is available here: https://community.jboss.org/wiki/MavenGettingStarted-Users
Comment 6 Rebecca Newton 2012-06-19 02:08:53 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,4 +1,4 @@
-Snowdrop source cannot be build out of the box because it requires artifacts which are not present in Maven Central nor distributed Enterprise Maven repositories. The workaround for this issue is to enable JBoss Nexus repository
+Snowdrop source cannot be build out of the box because it requires artifacts which are not present in Maven Central nor distributed Enterprise Maven repositories.
 
 To workaround this issue, enable the JBoss Nexus repository by including the following snippet in the settings.xml file:
Comment 7 Karel Piwko 2012-09-24 10:35:30 EDT
This should be either fixed or workaround mentioned in Maven repository section.
Comment 8 Marek Novotny 2012-09-25 02:57:53 EDT
Isaac, could you add this additional workaround to documentation?
Comment 9 Isaac Rooskov 2012-09-25 21:09:56 EDT
Marek, it is documented as a known issue in the release notes of WFK 2.0 here: https://access.redhat.com/knowledge/docs/en-US/JBoss_Web_Framework_Kit/2/html-single/2.0.0_Release_Notes/index.html#Known_Issues_with_this_release

Is this not something that is been worked on to be fixed?
Comment 10 Karel Piwko 2012-09-26 03:50:22 EDT
Well, fixing this would require either:

* changing Snowdrop build structure to be able to distribute only AS7/EAP6 related part
* syncing AS6 (<- yes, it's AS6) from JBoss Nexus to Maven Central.

I don't think anybody is working on these. Runtime is not affected as those are provided dependencies and user do not use non-AS7 bindings with EAP6.
Comment 11 Isaac Rooskov 2012-09-26 18:08:11 EDT
Thanks for the info Karel. I'll make sure this gets into a permanent doc for the WFK doc set this time then (instead of just the release notes that changes every release). 

Am I reading it right though that this only affects AS6 (which wasn't productized into a version of EAP)?
Comment 12 Isaac Rooskov 2012-11-18 17:56:21 EST
Hey Karel, just a ping for my question. If this only affects AS6 then it probably doesn't apply to enterprise documentation right?
Comment 13 Petr Penicka 2013-02-08 12:03:11 EST
Karel, are we still keeping this in the Known Issues in WFK 2.2 docs? Or can we incorporate the workaround as part of the standard Snowdrop building procedure [1], as Isaac suggested in comment 11?

[1] http://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Web_Framework_Kit/2.1/html/Snowdrop_Sportsclub_Example/sect_building.html
Comment 14 Karel Piwko 2013-02-11 08:56:13 EST
Petr, I'll let you know if this is still valid. Snowdrop was cleaned up so the module are no longer distributed, so workaround should not be needed anymore.
Comment 15 Petr Penicka 2013-02-13 04:28:12 EST
Lauren: this is one of the issues I mentioned in today's meeting. Please wait for Karel's confirmation, and then remove the item from the release notes for WFK 2.2.
Comment 16 Karel Piwko 2013-02-13 11:59:03 EST
This issue si still valid with WFK 2.2.0.DR1.

Here is detailed output:

[INFO] Snowdrop Parent POM ............................... SUCCESS [32.318s]
[INFO] Snowdrop - VFS .................................... SUCCESS [45.142s]
[INFO] Snowdrop - Deployers .............................. SUCCESS [0.014s]
[INFO] Snowdrop - Deployers Core ......................... FAILURE [32.993s]
[INFO] Snowdrop - Deployers - VFS3 ....................... SKIPPED
[INFO] Snowdrop - Deployers Aggregator ................... SKIPPED
[INFO] Snowdrop AS7 Subsystem - Parent ................... SKIPPED
[INFO] Snowdrop AS7 Subsystem ............................ SKIPPED
[INFO] Snowdrop AS7 Subsystem - Spring Modules ........... SKIPPED
[INFO] Snowdrop AS7 Subsystem - Spring 2.5 Module ........ SKIPPED
[INFO] Snowdrop AS7 Subsystem - Spring 3 Module .......... SKIPPED
[INFO] Snowdrop AS7 Subsystem - Spring 3.1 Module ........ SKIPPED
[INFO] Snowdrop AS7 Subsystem - Distribution Aggregator .. SKIPPED
[INFO] Snowdrop - Namespace support for JBoss AS ......... SKIPPED
[INFO] Snowdrop - Facade ................................. SKIPPED
[INFO] Snowdrop - Weaving ................................ SKIPPED
[INFO] Snowdrop Distribution ............................. SKIPPED
[INFO] JBoss Spring Deployer ............................. SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1:51.475s
[INFO] Finished at: Wed Feb 13 17:52:31 CET 2013
[INFO] Final Memory: 26M/434M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project snowdrop-deployers-core: Could not resolve dependencies for project org.jboss.snowdrop:snowdrop-deployers-core:jar:2.0.5.Final-redhat-1: Failed to collect dependencies for [org.jboss.snowdrop:snowdrop-vfs:jar:2.0.5.Final-redhat-1 (compile), org.jboss.deployers:jboss-deployers-vfs-spi:jar:2.2.2.GA (test), xml-apis:xml-apis:jar:1.3.04 (compile), org.jboss:jboss-vfs:jar:3.1.0.Final-redhat-2 (provided), org.jboss:jboss-common-core:jar:2.2.17.GA-redhat-2 (provided), org.jboss.logging:jboss-logging-spi:jar:2.1.2.GA (provided), org.jboss.logging:jboss-logging-log4j:jar:2.1.2.GA (provided), org.jboss.kernel:jboss-dependency:jar:2.2.0.SP2 (provided), org.jboss.deployers:jboss-deployers-spi:jar:2.2.2.GA (provided), org.jboss.deployers:jboss-deployers-structure-spi:jar:2.2.2.GA (provided), org.jboss.deployers:jboss-deployers-vfs:jar:2.2.2.GA (test), org.jboss.deployers:jboss-deployers-core-spi:jar:2.2.2.GA (provided), org.jboss.kernel:jboss-kernel:jar:2.2.0.SP2 (provided), org.jboss.aop:jboss-aop:jar:2.0.1.GA (provided), org.jboss.javaee:jboss-ejb-api-3.0_spec:jar:5.0.2.GA (provided), org.springframework:spring-aop:jar:2.5.6.SEC03 (compile), org.springframework:spring-beans:jar:2.5.6.SEC03 (compile), org.springframework:spring-context:jar:2.5.6.SEC03 (compile), org.springframework:spring-core:jar:2.5.6.SEC03 (compile), org.springframework:spring-web:jar:2.5.6.SEC03 (compile), junit:junit:jar:4.10 (compile)]: Failed to read artifact descriptor for org.jboss.aop:jboss-aop:jar:2.0.1.GA: Could not find artifact org.jboss.aop:jboss-aop-parent:pom:2.0.1.GA in eap-plugin-repository (http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/) -> [Help 1]
Comment 21 Tomas Repel 2013-04-03 04:59:13 EDT
I have tried with WFK 2.2.0.CR1. The workaround described in RN is no longer sufficient. For build to work properly you have to enable `http://download.devel.redhat.com/brewroot/repos/jb-wfk-2-rhel-6-build/latest/maven`. But this repository should not be exposed to customers I think.
Comment 22 Tomas Repel 2013-04-03 06:02:06 EDT
Enabling eap-plugin-repository (http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/) is not sufficient. The build fails on module `Snowdrop - Deployment Core`: Could not find artifact org.jboss:jbossxb:jar:2.0.3.GA-redhat-1. 
This version is specified directly in module `Snowdrop Parent POM` pom.xml in dependencyManagenent section.
Comment 23 Marek Novotny 2013-04-03 06:25:43 EDT
OK, then as I can see, Snowdrop should use 2.0.3.GA-redhat-2 from EAP 6.0.1 instead of 2.0.3.GA-redhat-1, which was/is in EAP 6.0.0 Maven repository.
Comment 24 Tomas Repel 2013-04-03 07:59:51 EDT
Enabling EAP 6.0.0 Maven repository is still enough for build to pass. Problem:
Failure to find org.apache.ant:ant:jar:1.8.3-redhat-1.
There is only 1.8.2-redhat-1 in EAP6 Plugin Repository (http://download.devel.redhat.com/brewroot/repos/mead-jb-eap-6-rhel-6-maven-plugins/latest/maven/).
Comment 25 Tomas Repel 2013-04-11 08:13:29 EDT
Verified, sources are buildable with WFK 2.2.0, EAP 6.0.1 and EAP 6 Plugin repositories.
Comment 26 Petr Penicka 2013-04-12 11:24:32 EDT
Release rewritten and moved to fixed issues in the RN book.

Docs stage URL: https://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Web_Framework_Kit/2.2/html-single/2.2.0_Release_Notes/index.html

Build: JBoss_Web_Framework_Kit-2.2.0_Release_Notes-2.2-en-US-0-20
Comment 28 Petr Penicka 2013-04-16 13:33:55 EDT
I see, my wrong understanding... I rewrote the RN both here and in the 2.2.0 RN book.

Docs stage URL: https://documentation-devel.engineering.redhat.com/docs/en-US/JBoss_Web_Framework_Kit/2.2/html-single/2.2.0_Release_Notes/index.html

Build: JBoss_Web_Framework_Kit-2.2.0_Release_Notes-2.2-en-US-0-21
Comment 29 Karel Piwko 2013-05-14 10:51:23 EDT
Closed as CURRENTRELEASE, part of WFK 2.2.0 distributables.

Note You need to log in before you can comment on or make changes to this bug.