Bug 800016 - yum installs package obsoleted/provided by other package
yum installs package obsoleted/provided by other package
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-05 10:53 EST by nucleo
Modified: 2014-01-21 18:21 EST (History)
10 users (show)

See Also:
Fixed In Version: yum-3.4.3-23.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-02 19:27:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nucleo 2012-03-05 10:53:33 EST
Description of problem:
"yum install konq-plugins" tries to install konq-plugins-4.6.1-1.fc15 obsoleted/provided by kde-baseapps. 

This is only i686 problem, fine on x86_64.

Version-Release number of selected component (if applicable):
yum-3.4.3-7.fc16.noarch

Steps to Reproduce:
1. Run F16 KDE i686 live CD
2. Add repo http://repos.fedorapeople.org/repos/rdieter/kde48/fedora-kde48.repo
3. Run "yum install konq-plugins"
  
Actual results:
It tries to install konq-plugins-4.6.1-1.fc15

Expected results:
kde-baseapps-4.8.0 should be installed.

Additional info:
If fedora-kde48 is not enabled then no such problem, kdebase-4.7.2 (which also obsoletes/provides konq-plugins) installs both on i686 and x86_64 CD.
Comment 1 Rex Dieter 2012-03-05 11:05:46 EST
Yeah, further data point, both kdebase-4.7.2 and the newer newer kde-baseapps contain in their .spec the snippet:

Obsoletes: konq-plugins < 4.6.80-1
Provides:  konq-plugins = %{version}-%{release}

and "fine on x86_64", the behavior of
yum install konq-plugins 
is
Package konq-plugins is obsoleted by kde-baseapps, trying to install kde-baseapps-4.8.0-2.x86_64 instead
or
Package konq-plugins-4.6.1-1.fc15.x86_64 is obsoleted by kde-baseapps-4.8.0-2.x86_64 which is already installed

depending on if it's installed or not yet, of course.


could it be a repo metadata problem of some sort? just in case,
http://kdeforge.unl.edu/apt/kde-redhat/fedora/16/i386/kde48/repodata/
vs.
http://kdeforge.unl.edu/apt/kde-redhat/fedora/16/x86_64/kde48/repodata/
Comment 2 James Antill 2012-03-05 17:19:18 EST
Ugh ... you've run into an edge case bug, the problem is that yum sees:

kdebase obs. konq-plugins
kde-baseapps obs. kdebase

...but then uses the wrong variable, and so tests that kdebase == kdebase (instead of kde-baseapps == kdebase) ... and decides there is a loop in the obsoletes, and ignores everything.
 Fix is a one-liner, but I'm not sure how easily you can work around it.
Comment 3 Kevin Kofler 2012-03-05 18:20:52 EST
Can you please push an update to yum to fix this? I don't think this is critical enough to worry about the case where people hit this when installing straight from a non-updated installation (they should get the Obsoletes triggered when they eventually update), but we should fix it now.
Comment 4 Fedora Update System 2012-03-12 16:20:27 EDT
yum-3.4.3-22.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/yum-3.4.3-22.fc16
Comment 5 Fedora Update System 2012-03-14 22:33:39 EDT
Package yum-3.4.3-22.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-3.4.3-22.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3766/yum-3.4.3-22.fc16
then log in and leave karma (feedback).
Comment 6 John Beranek 2012-03-19 10:54:38 EDT
I have just run into this problem, but in Anaconda.

We use a kickstart system that installs Fedora, and this adds the updates repository so that a newly installed system is up the "latest and greatest".

Installs run this morning install all but one of the packages, and then Anaconda aborts trying to install konq-plugins, complaining of a checksum error.

At this point I changed to the shell, chrooted to the almost installed system and tried:

yum install konq-plugins

This shows the 'Obsoletes' conflict as described here.

So, an updated Yum RPM is not going to fix an Anaconda installation...
Comment 7 John Beranek 2012-03-19 10:55:27 EDT
Oh, my workaround for now is to edit the kickstart files and add:

-konq-plugins

to the package selection section.
Comment 8 Kevin Kofler 2012-03-19 14:41:37 EDT
Ouch, konq-plugins was still listed in comps-f16, oops…

This should help the Anaconda with updates case:
http://git.fedorahosted.org/git/?p=comps.git;a=commitdiff;h=c8abd695933ee563e2316e403aff0ecd9c678d39
Comment 9 John Beranek 2012-03-19 17:28:31 EDT
(In reply to comment #8)
> Ouch, konq-plugins was still listed in comps-f16, oops…
> 
> This should help the Anaconda with updates case:
> http://git.fedorahosted.org/git/?p=comps.git;a=commitdiff;h=c8abd695933ee563e2316e403aff0ecd9c678d39

Not understanding the Yum update procedures, how/when does that change go live?
Comment 10 Kevin Kofler 2012-03-19 17:39:59 EDT
As I understand it, comps gets regenerated at every update push.
Comment 11 Fedora Update System 2012-03-20 22:32:07 EDT
Package yum-3.4.3-23.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-3.4.3-23.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3766/yum-3.4.3-23.fc16
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-04-02 19:27:47 EDT
yum-3.4.3-23.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 James Antill 2012-04-23 14:47:13 EDT
*** Bug 810543 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.