Bug 800302 - plugin: kerneloops, fix the libcurl use
plugin: kerneloops, fix the libcurl use
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreport (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nikola Pajkovsky
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 800307
  Show dependency treegraph
 
Reported: 2012-03-06 04:23 EST by Anton Arapov
Modified: 2014-06-18 04:03 EDT (History)
11 users (show)

See Also:
Fixed In Version: abrt-2.0.10-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 19:00:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (1.17 KB, patch)
2012-03-06 04:23 EST, Anton Arapov
no flags Details | Diff
change the url for the kerneloops reports (695 bytes, patch)
2012-03-06 04:32 EST, Anton Arapov
no flags Details | Diff
1/2 libreport upstream changes (1.04 KB, patch)
2012-03-06 04:54 EST, Anton Arapov
no flags Details | Diff
2/2 libreport upstream changes (2.01 KB, patch)
2012-03-06 04:55 EST, Anton Arapov
no flags Details | Diff

  None (edit)
Description Anton Arapov 2012-03-06 04:23:01 EST
Created attachment 567876 [details]
proposed patch

The patch fixes following issue:

* Connected to kerneloops.descope.org (184.72.83.237) port 80 (#0)
> POST /submitoops.php HTTP/1.1
Host: kerneloops.descope.org
Accept: */*
Content-Length: 2444
Expect: 100-continue
Content-Type: multipart/form-data; boundary=----------------------------bd6b682457c1
< HTTP/1.1 417 Expectation Failed
< Date: Tue, 06 Mar 2012 08:47:12 GMT
< Content-Length: 453
< Connection: close
< Content-Type: text/html; charset=iso-8859-1
< 
* Closing connection #0


Steps to Reproduce:
1. KerneloopsReporter_SubmitURL="http://kerneloops-descope.rhcloud.com/submitoops.php" ./reporter-kerneloops -vvv
  
Actual results:
Submitting oops report to http://kerneloops-descope.rhcloud.com/submitoops.php
Kernel oops has not been sent due to HTTP response code said error

Expected results:
Kernel oops report was uploaded
Comment 1 Anton Arapov 2012-03-06 04:26:33 EST
And please, fix it in Fedora 16 as well, please.
Comment 2 Anton Arapov 2012-03-06 04:32:52 EST
Created attachment 567879 [details]
change the url for the kerneloops reports

Please, change the configuration as well.
Comment 3 Anton Arapov 2012-03-06 04:35:13 EST
And upstream the changes please.
Comment 4 Anton Arapov 2012-03-06 04:54:34 EST
Created attachment 567885 [details]
1/2 libreport upstream changes

From 2b8b99670e3c67bf7662a1bc3af56a7d4be33963 Mon Sep 17 00:00:00 2001
From: Anton Arapov <anton@redhat.com>
Date: Tue, 6 Mar 2012 10:49:47 +0100
Subject: [PATCH 1/2] plugin: kerneloops: change the kerneloops url to report

  www.kerneloops.org is in transit. we will roll back this change once
the domain is ours.

Signed-off-by: Anton Arapov <anton@redhat.com>
---
 src/plugins/report_Kerneloops.xml.in |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)
Comment 5 Anton Arapov 2012-03-06 04:55:26 EST
Created attachment 567889 [details]
2/2 libreport upstream changes

From b7e6cf22213c10b2ab48b91692625088d09703b3 Mon Sep 17 00:00:00 2001
From: Anton Arapov <anton@redhat.com>
Date: Tue, 6 Mar 2012 10:50:47 +0100
Subject: [PATCH 2/2] plugin: kerneloops: fix the libcurl use ("Expect:"
 header)

The patch fixes following issue:

* Connected to kerneloops.descope.org (184.72.83.237) port 80 (#0)
* > POST /submitoops.php HTTP/1.1
* Host: kerneloops.descope.org
* Accept: */*
Content-Length: 2444
Expect: 100-continue
Content-Type: multipart/form-data;
boundary=----------------------------bd6b682457c1
< HTTP/1.1 417 Expectation Failed
< Date: Tue, 06 Mar 2012 08:47:12 GMT
< Content-Length: 453
< Connection: close
< Content-Type: text/html; charset=iso-8859-1
<
* Closing connection #0

Signed-off-by: Anton Arapov <anton@redhat.com>
---
 src/plugins/reporter-kerneloops.c |    7 +++++++
 1 files changed, 7 insertions(+), 0 deletions(-)
Comment 7 Fedora Update System 2012-03-27 06:18:14 EDT
abrt-2.0.9-1.fc17, libreport-2.0.10-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.9-1.fc17,libreport-2.0.10-1.fc17
Comment 8 Fedora Update System 2012-03-28 01:59:04 EDT
Package abrt-2.0.9-1.fc17, libreport-2.0.10-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.9-1.fc17 libreport-2.0.10-1.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4804/abrt-2.0.9-1.fc17,libreport-2.0.10-1.fc17
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-04-02 09:34:11 EDT
abrt-2.0.10-1.fc17,libreport-2.0.10-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.10-1.fc17,libreport-2.0.10-2.fc17
Comment 10 Fedora Update System 2012-04-18 19:00:06 EDT
abrt-2.0.10-1.fc17, libreport-2.0.10-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.