Bug 800755 - Input/output error on lookup of files from mountpoint
Input/output error on lookup of files from mountpoint
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Pranith Kumar K
BETA1
:
: 802018 (view as bug list)
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-03-07 02:23 EST by Shwetha Panduranga
Modified: 2015-12-01 11:45 EST (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:59:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
client2 log file (44.49 KB, text/x-log)
2012-03-07 02:23 EST, Shwetha Panduranga
no flags Details

  None (edit)
Description Shwetha Panduranga 2012-03-07 02:23:45 EST
Created attachment 568175 [details]
client2 log file

Description of problem:
Lookup of files from mount point reports Input/Output error. 

Version-Release number of selected component (if applicable):
mainline

How reproducible:
often

Steps to Reproduce:
1.create a distribute-replicate volume 
2.start the volume
3.create a gluster,nfs mount from client1 and client2
4.start dd on gluster, nfs mount from client1
5. lookup of files from client2 mount points
  
Actual results:
Client1:-
---------
[03/07/12 - 17:56:09 root@APP-CLIENT1 gfsc1]# dd if=/dev/zero of=gfsf1 bs=1M count=102400

[03/07/12 - 17:56:19 root@APP-CLIENT1 nfsc1]# dd if=/dev/zero of=nfsf1 bs=1M count=102400

Client2:-
-----------
[03/07/12 - 12:52:49 root@Shwetha-Laptop gfsc1]# ls -lh
ls: cannot access nfsf1: Input/output error
ls: cannot access gfsf2: Input/output error
ls: cannot access nfsf2: Input/output error
ls: cannot access gfsf1: Input/output error
total 0
?????????? ? ? ? ?            ? gfsf1
?????????? ? ? ? ?            ? gfsf2
?????????? ? ? ? ?            ? nfsf1
?????????? ? ? ? ?            ? nfsf2



Expected results:
Should list the all the files without error. 

Additional info:
Comment 1 Shwetha Panduranga 2012-03-08 05:28:27 EST
Lookup of files giving Invalid argument:

Setup:-
1. Distribute-Replicate Volume (2 x 2)
2. auth.allow set to client1
2. dd running on gluster mount and nfs mount from client1
3. lookup performed on nfs mount from client2

[03/08/12 - 15:21:24 root@Shwetha-Laptop nfsc1]# df -h .
Filesystem            Size  Used Avail Use% Mounted on
192.168.2.35:/dstore  100G   65M  100G   1% /mnt/nfsc1

[03/08/12 - 15:22:19 root@Shwetha-Laptop nfsc1]# ls -lh 
total 331M
-rw-r--r--. 1 root root 331M Mar  8  2012 gfsf1
-rw-r--r--. 1 root root    0 Mar  8  2012 nfsf1

[03/08/12 - 15:23:05 root@Shwetha-Laptop nfsc1]# ls -lh 
total 331M
-rw-r--r--. 1 root root 331M Mar  8  2012 gfsf1
-rw-r--r--. 1 root root    0 Mar  8  2012 nfsf1

[03/08/12 - 15:23:07 root@Shwetha-Laptop nfsc1]# ls -lh 
ls: cannot access gfsf1: Invalid argument
total 0
-?????????? ? ?    ?    ?            ? gfsf1
-rw-r--r--. 1 root root 0 Mar  8  2012 nfsf1

[03/08/12 - 15:23:08 root@Shwetha-Laptop nfsc1]# ls -lh 
ls: cannot access gfsf1: Invalid argument
total 80M
-?????????? ? ?    ?      ?            ? gfsf1
-rw-r--r--. 1 root root 80M Mar  8  2012 nfsf1

[03/08/12 - 15:23:18 root@Shwetha-Laptop nfsc1]# ls -lh 
ls: cannot access gfsf1: Invalid argument
total 189M
-?????????? ? ?    ?       ?            ? gfsf1
-rw-r--r--. 1 root root 248M Mar  8  2012 nfsf1

[03/08/12 - 15:23:28 root@Shwetha-Laptop nfsc1]# ls -lh 
ls: cannot access nfsf1: Invalid argument
ls: cannot access gfsf1: Invalid argument
Comment 2 Raghavendra G 2012-03-14 07:29:15 EDT
*** Bug 803209 has been marked as a duplicate of this bug. ***
Comment 3 Raghavendra G 2012-03-16 01:49:01 EDT
*** Bug 802018 has been marked as a duplicate of this bug. ***
Comment 4 Anand Avati 2012-03-18 03:30:26 EDT
CHANGE: http://review.gluster.com/2963 (cluster/afr: set_read_child when xactions in progress in fresh lookup) merged in master by Anand Avati (avati@redhat.com)
Comment 5 Shwetha Panduranga 2012-04-04 08:11:51 EDT
verified on 3.3.0qa33.

Note You need to log in before you can comment on or make changes to this bug.