Bug 803209 - [fa5b0347193f8d1a4b917a2edb338423cb175e66] EIO while doing graph change
[fa5b0347193f8d1a4b917a2edb338423cb175e66] EIO while doing graph change
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: fuse (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
: Reopened
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-03-14 04:41 EDT by Anush Shetty
Modified: 2013-07-24 13:15 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:15:47 EDT
Type: ---
Regression: ---
Mount Type: fuse
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2012-03-14 04:41:26 EDT
Description of problem: While doing graph change using volume set command when the I/O is going in the fuse client, the I/O exited with EIO errors. This was on 2-replica volume. 


Version-Release number of selected component (if applicable): Upstream


How reproducible: Consistently


Steps to Reproduce:
1. while true; do echo 'sdsd' > dot; cat dot > /dev/null; done
2. while true; do gluster volume set test2 performance.quick-read off; sleep 1; gluster volume set test2 performance.quick-read on; sleep 1; done
3.
  
Actual results:

cat: dot: Input/output error
bash: dot: Input/output error



Expected results:

The I/O should continue on without any errors

Additional info:

[2012-03-14 14:04:41.882082] W [fuse-resolve.c:150:fuse_resolve_gfid_cbk] 0-fuse: 6a3d65e0-3551-4ab6-9fad-1b07fbdec2be: failed to resolve (Input/output error)
[2012-03-14 14:04:41.882101] E [fuse-bridge.c:1838:fuse_open_resume] 0-glusterfs-fuse: 247: OPEN 6a3d65e0-3551-4ab6-9fad-1b07fbdec2be resolution failed
[2012-03-14 14:04:41.882655] D [afr-common.c:129:afr_lookup_xattr_req_prepare] 1-test2-replicate-0: <gfid:00000000-0000-0000-0000-000000000000>: failed to get the gfid from dict
[2012-03-14 14:04:41.883021] W [fuse-resolve.c:150:fuse_resolve_gfid_cbk] 0-fuse: 6a3d65e0-3551-4ab6-9fad-1b07fbdec2be: failed to resolve (Input/output error)
[2012-03-14 14:04:41.883042] E [fuse-bridge.c:1838:fuse_open_resume] 0-glusterfs-fuse: 248: OPEN 6a3d65e0-3551-4ab6-9fad-1b07fbdec2be resolution failed
[2012-03-14 14:04:41.884103] D [afr-common.c:129:afr_lookup_xattr_req_prepare] 1-test2-replicate-0: <gfid:00000000-0000-0000-0000-000000000000>: failed to get the gfid from dict
[2012-03-14 14:04:41.884452] W [fuse-resolve.c:150:fuse_resolve_gfid_cbk] 0-fuse: 6a3d65e0-3551-4ab6-9fad-1b07fbdec2be: failed to resolve (Input/output error)
[2012-03-14 14:04:41.884476] E [fuse-bridge.c:1838:fuse_open_resume] 0-glusterfs-fuse: 249: OPEN 6a3d65e0-3551-4ab6-9fad-1b07fbdec2be resolution failed
[2012-03-14 14:04:41.884962] D [afr-common.c:129:afr_lookup_xattr_req_prepare] 1-test2-replicate-0: <gfid:00000000-0000-0000-0000-000000000000>: failed to get the gfid from dict
[2012-03-14 14:04:41.885252] W [fuse-resolve.c:150:fuse_resolve_gfid_cbk] 0-fuse: 6a3d65e0-3551-4ab6-9fad-1b07fbdec2be: failed to resolve (Input/output error)
[2012-03-14 14:04:41.885273] E [fuse-bridge.c:1838:fuse_open_resume] 0-glusterfs-fuse: 250: OPEN 6a3d65e0-3551-4ab6-9fad-1b07fbdec2be resolution failed
[2012-03-14 14:04:41.886285] D [afr-common.c:129:afr_lookup_xattr_req_prepare] 1-test2-replicate-0: <gfid:00000000-0000-0000-0000-000000000000>: failed to get the gfid from dict
[2012-03-14 14:04:41.886615] W [fuse-resolve.c:150:fuse_resolve_gfid_cbk] 0-fuse: 6a3d65e0-3551-4ab6-9fad-1b07fbdec2be: failed to resolve (Input/output error)
[2012-03-14 14:04:41.886636] E [fuse-bridge.c:1838:fuse_open_resume] 0-glusterfs-fuse: 251: OPEN 6a3d65e0-3551-4ab6-9fad-1b07fbdec2be resolution failed
[2012-03-14 14:04:41.887073] D [afr-common.c:129:afr_lookup_xattr_req_prepare] 1-test2-replicate-0: <gfid:00000000-0000-0000-0000-000000000000>: failed to get the gfid from dict
[2012-03-14 14:04:41.887341] W [fuse-resolve.c:150:fuse_resolve_gfid_cbk] 0-fuse: 6a3d65e0-3551-4ab6-9fad-1b07fbdec2be: failed to resolve (Input/output error)
[2012-03-14 14:04:41.887363] E [fuse-bridge.c:1838:fuse_open_resume] 0-glusterfs-fuse: 252: OPEN 6a3d65e0-3551-4ab6-9fad-1b07fbdec2be resolution failed
Comment 1 Raghavendra G 2012-03-14 07:29:15 EDT

*** This bug has been marked as a duplicate of bug 800755 ***
Comment 2 Pranith Kumar K 2012-03-17 04:59:21 EDT
After the fix for lookup, this test case lead to a hang in the fuse-client. Send a patch for review. So assigning it to myself.
Comment 3 Anand Avati 2012-03-18 04:09:49 EDT
CHANGE: http://review.gluster.com/2966 (protocol/server: Clear internal locks on disconnect) merged in master by Anand Avati (avati@redhat.com)
Comment 4 Anand Avati 2012-03-18 04:40:43 EDT
CHANGE: http://review.gluster.com/2967 (rpc: cancel reconnect timer in rpc_clnt_disable) merged in master by Anand Avati (avati@redhat.com)
Comment 5 Anand Avati 2012-03-18 04:53:47 EDT
CHANGE: http://review.gluster.com/2968 (Logs: Improved logs in lock/unlock execution path) merged in master by Anand Avati (avati@redhat.com)
Comment 6 Anush Shetty 2012-03-19 02:16:12 EDT
Verified with 3.3.0qa29

Note You need to log in before you can comment on or make changes to this bug.