Bug 800776 - P2V fail with error:Error receiving data
P2V fail with error:Error receiving data
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-p2v (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Matthew Booth
: TestBlocker, TestOnly
Depends On: 804145
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 03:20 EST by tingting zheng
Modified: 2013-04-27 23:35 EDT (History)
8 users (show)

See Also:
Fixed In Version: libssh2-1.2.2-7.el6_2.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 11:09:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
P2V error screenshot (51.28 KB, image/png)
2012-03-07 03:20 EST, tingting zheng
no flags Details

  None (edit)
Description tingting zheng 2012-03-07 03:20:03 EST
Created attachment 568189 [details]
P2V error screenshot

Description of Problem:
P2V fail with error:Error receiving data

Version-Release number of selected component:
rubygem-virt-p2v-0.8.6-1.el6
virt-v2v-0.8.7-3.el6.x86_64

How reproducible:
Always

Step to Reproduce:
1.Download the virt-p2v iso from brewweb.

2.Plug in USB,boot the Live CD with USB
#livecd-iso-to-disk --format VirtP2V_0.8.6-1.iso  /dev/sdb 

3.Boot from USB,input the ip and password of conversion server to connect the virt-p2v server.

4.Configure the server address and target storage,start to convert the host.

Actual Results:
When the data transferred about 60-70G,then the error occurred:
in p2v-client:Error writing to channel:unable to send channal data.
Also can find error in log:Error receiving data.


Expected Results:
It should be converted successfully.

Additional info:
The screenshot of p2v error is attached.
Comment 4 Matthew Booth 2012-03-16 11:41:07 EDT
Lets track this here because this bug is critically important to virt-p2v, however it's actually a bug in libssh2. I've posted an upstream patch here:

http://www.libssh2.org/mail/libssh2-devel-archive-2012-03/0106.shtml
Comment 11 tingting zheng 2012-03-29 05:32:26 EDT
Verified this issue with :
Virt-P2V_0.8.6-2.iso
virt-v2v-0.8.7-4.el6.x86_64

Use virt-p2v to convert a physical machine with about 350G disk,it can convert successfully.So set the bug to VERIFIED.
Comment 12 errata-xmlrpc 2012-06-20 11:09:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0965.html

Note You need to log in before you can comment on or make changes to this bug.