Bug 804145 - libssh2 fails key re-exchange when write channel is saturated
libssh2 fails key re-exchange when write channel is saturated
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libssh2 (Show other bugs)
6.3
All Linux
high Severity high
: rc
: ---
Assigned To: Kamil Dudka
Karel Srot
: ZStream
Depends On:
Blocks: 800776 805026 806862
  Show dependency treegraph
 
Reported: 2012-03-16 12:03 EDT by Matthew Booth
Modified: 2013-02-21 03:42 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When sending a large amount of data over SSH, libssh2 could, under certain circumstances, fail to resume an interrupted key exchange. Instead of that, further data was erroneously sent, which caused the remote site to close the connection immediately. This update modifies the code of libssh2 so that libssh2 now properly resumes the interrupted key exchange before sending any further data. The connection remains open and the data transfer proceeds as expected.
Story Points: ---
Clone Of:
: 804155 804156 (view as bug list)
Environment:
Last Closed: 2013-02-21 03:42:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to openssh to aid testing (662 bytes, patch)
2012-03-16 12:08 EDT, Matthew Booth
no flags Details | Diff
Backport of upstream fix (2.55 KB, patch)
2012-03-16 12:43 EDT, Matthew Booth
no flags Details | Diff
Backport of upstream fix (V2) (2.55 KB, patch)
2012-03-16 12:54 EDT, Matthew Booth
no flags Details | Diff

  None (edit)
Description Matthew Booth 2012-03-16 12:03:07 EDT
Description of problem:
This bug is fixed upstream:
http://www.libssh2.org/mail/libssh2-devel-archive-2012-03/0106.shtml

It's a blocker for virt-p2v. virt-p2v sends a large amount of data over ssh using libssh2. When it has sent enough data (about 64G), the peer will request key re-exchange. Because virt-p2v sends data continuously, it will hit this bug with almost 100% reliability, making it impossible to transfer more than 64G of data.

Version-Release number of selected component (if applicable):
libssh2-1.2.2-7.el6_1.1.x86_64
Comment 1 Matthew Booth 2012-03-16 12:08:23 EDT
Created attachment 570649 [details]
Patch to openssh to aid testing

It takes about 45-60 mins of sending data on my system to hit this bug. I'm using a version of openssh with this patch to aid testing. It causes openssh to force a rekey 32x sooner than normal.
Comment 2 Matthew Booth 2012-03-16 12:43:26 EDT
Created attachment 570652 [details]
Backport of upstream fix

This is a backport of upstream commit cc4f9d5679278ce41cd5480fab3f5e71dba163ed. The backport was uncomplicated: code has shifted a bit, but nothing close to the affected lines has been altered.
Comment 3 Matthew Booth 2012-03-16 12:54:28 EDT
Created attachment 570653 [details]
Backport of upstream fix (V2)

Spoke too soon! libssh2_kex_exchange was renamed to _libssh2_kex_exchange, so the above doesn't compile. This version is fixed.
Comment 14 Miroslav Svoboda 2012-03-21 09:35:28 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
When sending a large amount of data over SSH, libssh2 could, under certain circumstances, fail to resume an interrupted key exchange. Instead of that, further data was erroneously sent, which caused the remote site to close the connection immediately. This update modifies the code of libssh2 so that libssh2 now properly resumes the interrupted key exchange before sending any further data. The connection remains open and the data transfer proceeds as expected.
Comment 19 errata-xmlrpc 2013-02-21 03:42:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0329.html

Note You need to log in before you can comment on or make changes to this bug.