Bug 800869 - [RFE] Project Grouping required
[RFE] Project Grouping required
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
unspecified
Unspecified Linux
unspecified Severity medium
: ---
: 1.6-beta-1
Assigned To: Alex Eng
Joyce Chang
:
: 716782 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 07:24 EST by Ankit Patel
Modified: 2013-03-03 22:19 EST (History)
5 users (show)

See Also:
Fixed In Version: Zanata version 1.6.0-beta-2-SNAPSHOT (20120531-0020).
Doc Type: Bug Fix
Doc Text:
Cause Versions of multiple projects may have a real-world relationship. For example, the versions of various projects which go into a certain version of Fedora, and need to be translated together. Consequence It was difficult to navigate to associated projects/versions. Change Introduced the concept of Project Groups, which can contain Project Versions. Result By visiting a Project Group, it is easy to navigate to the Project Versions it contains.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-21 20:58:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 2 Runa Bhattacharjee 2012-04-17 02:08:00 EDT
Project groups need to be introduced into Zanata, so that the hosted projects and/or their modules can be grouped according to a relevant trait like affiliation to a larger project group, or version.
Comment 3 Sean Flanigan 2012-04-17 02:33:47 EDT
*** Bug 716782 has been marked as a duplicate of this bug. ***
Comment 4 Alex Eng 2012-05-23 01:50:33 EDT
Basic project version group has been implemented 
- version group maintainer
- filtering version group by status


See https://github.com/zanata/zanata/commit/064644c2064e26efe6dd54d1fb18bd70e7cc124d.
Comment 5 Joyce Chang 2012-05-30 23:07:12 EDT
verified in Zanata version 1.6.0-beta-2-SNAPSHOT (20120531-0020).
Comment 6 Sean Flanigan 2012-06-05 21:32:30 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause

Versions of multiple projects may have a real-world relationship.  For example, the versions of various projects which go into a certain version of Fedora, and need to be translated together.

Consequence

It was difficult to navigate to associated projects/versions.

Change

Introduced the concept of Project Groups, which can contain Project Versions.

Result

By visiting a Project Group, it is easy to navigate to the Project Versions it contains.

Note You need to log in before you can comment on or make changes to this bug.