Bug 800897 - After doing "ctrl+space", ibus tray icon freezes.
After doing "ctrl+space", ibus tray icon freezes.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
: i18n
: 801878 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 08:34 EST by sangu
Modified: 2012-07-02 21:01 EDT (History)
5 users (show)

See Also:
Fixed In Version: ibus-fbterm-0.9.1-14.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-10 10:06:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2012-03-07 08:34:28 EST
Description of problem:
After doing "ctrl+space", ibus tray icon freezes.

Version-Release number of selected component (if applicable):
ibus-1.4.99.20120304-2.fc17

How reproducible:
always

Steps to Reproduce:
1. ctrl + space
2. click ibus tray icon in gnome-shell.
3.
  
Actual results:


Expected results:


Additional info:
ibus-hangul-1.4.0-5.fc17.x86_64
Comment 1 sangu 2012-03-07 08:47:25 EST
The Same problem happens in ibus-1.4.99.20120203-3.fc17.x86_64
$ /usr/bin/ibus-daemon -r -R -v
IBUS-DEBUG: 22:41:28.626665: _connection_closed_cb: Underlying GIOStream returned 0 bytes on an async read
IBUS-DEBUG: application.vala:88: signal_name = NameAcquired

IBUS-WARNING **: ibus_bus_call_sync: org.freedesktop.IBus.GetGlobalEngine: GDBus.Error:org.freedesktop.DBus.Error.Failed: No global engine.
IBUS-DEBUG: keybindingmanager.vala:81: Binding key <Control>space
IBUS-DEBUG: keybindingmanager.vala:105: Successfully binded key <Control>space
IBUS-DEBUG: keybindingmanager.vala:81: Binding key <Control><Shift>space
IBUS-DEBUG: keybindingmanager.vala:105: Successfully binded key <Control><Shift>space
IBUS-DEBUG: keybindingmanager.vala:81: Binding key Hangul
IBUS-DEBUG: keybindingmanager.vala:105: Successfully binded key Hangul
IBUS-DEBUG: keybindingmanager.vala:81: Binding key Alt_R
IBUS-DEBUG: keybindingmanager.vala:105: Successfully binded key Alt_R

IBUS-WARNING **: org.freedesktop.IBus.Config.GetValue: GDBus.Error:org.freedesktop.DBus.Error.Failed: Config value [engine/Hangul:AutoReorder] does not exist.

Click ctrl + space -> response, No messages
----
Click Hangul Key -> GLib-CRITICAL messages

GLib-CRITICAL **: g_main_loop_quit: assertion `loop != NULL' failed

GLib-CRITICAL **: g_main_loop_quit: assertion `loop != NULL' failed

glib2-2.31.20-1.fc17.x86_64
gnome-session-3.3.90-1.fc17.x86_64
gnome-settings-daemon-3.3.91-1.fc17.x86_64
gtk3-3.3.18-1.fc17.x86_64
Comment 2 A S Alam 2012-03-09 12:46:11 EST
issue confirmed. Reproduced on x86_64.
--
 /usr/bin/ibus-daemon -r -R -v
IBUS-DEBUG: application.vala:88: signal_name = NameAcquired

IBUS-WARNING **: ibus_bus_call_sync: org.freedesktop.IBus.GetGlobalEngine: GDBus.Error:org.freedesktop.DBus.Error.Failed: No global engine.
IBUS-DEBUG: keybindingmanager.vala:81: Binding key <Control>space
IBUS-DEBUG: keybindingmanager.vala:105: Successfully binded key <Control>space
IBUS-DEBUG: keybindingmanager.vala:81: Binding key <Control><Shift>space
IBUS-DEBUG: keybindingmanager.vala:105: Successfully binded key <Control><Shift>space

** WARNING **: skipped m17n:kk:kbd since its rank is lower than 0

** WARNING **: skipped m17n:cmc:kbd since its rank is lower than 0

** WARNING **: skipped m17n:ar:kbd since its rank is lower than 0

** WARNING **: skipped m17n:hy:kbd since its rank is lower than 0

** WARNING **: skipped m17n:lo:kbd since its rank is lower than 0

** WARNING **: skipped m17n:ka:kbd since its rank is lower than 0

** WARNING **: skipped m17n:sr:kbd since its rank is lower than 0

** WARNING **: skipped m17n:ko:romaja since its rank is lower than 0

** WARNING **: skipped m17n:ko:han2 since its rank is lower than 0

** WARNING **: skipped m17n:ua:kbd since its rank is lower than 0

** WARNING **: skipped m17n:my:kbd since its rank is lower than 0

** WARNING **: skipped m17n:ru:kbd since its rank is lower than 0

** WARNING **: skipped m17n:cs:kbd since its rank is lower than 0

** WARNING **: skipped m17n:sk:kbd since its rank is lower than 0

** WARNING **: skipped m17n:he:kbd since its rank is lower than 0

** WARNING **: skipped m17n:ug:kbd since its rank is lower than 0

** WARNING **: skipped m17n:be:kbd since its rank is lower than 0

** WARNING **: skipped m17n:uz:kbd since its rank is lower than 0

** WARNING **: skipped m17n:hr:kbd since its rank is lower than 0

** WARNING **: skipped m17n:el:kbd since its rank is lower than 0

IBUS-WARNING **: org.freedesktop.IBus.Config.GetValue: GDBus.Error:org.freedesktop.DBus.Error.Failed: Config value [engine/M17N/pa/jhelum:preedit_foreground] does not exist.

IBUS-WARNING **: org.freedesktop.IBus.Config.GetValue: GDBus.Error:org.freedesktop.DBus.Error.Failed: Config value [engine/M17N/pa/jhelum:preedit_background] does not exist.

IBUS-WARNING **: org.freedesktop.IBus.Config.GetValue: GDBus.Error:org.freedesktop.DBus.Error.Failed: Config value [engine/M17N/pa/jhelum:preedit_underline] does not exist.

IBUS-WARNING **: org.freedesktop.IBus.Config.GetValue: GDBus.Error:org.freedesktop.DBus.Error.Failed: Config value [engine/M17N/pa/jhelum:lookup_table_orientation] does not exist.

IBUS-WARNING **: org.freedesktop.IBus.Config.GetValue: GDBus.Error:org.freedesktop.DBus.Error.Failed: Config value [engine/M17N/pa/jhelum:virtual_keyboard_enabled] does not exist.
Comment 3 fujiwara 2012-03-12 05:51:52 EDT
*** Bug 801878 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2012-03-13 07:17:51 EDT
ibus-fbterm-0.9.1-14.fc17, ibus-qt-1.3.1-8.fc17, ibus-handwrite-2.1.4-4.fc17, sunpinyin-2.0.3-4.fc17, ibus-input-pad-1.4.0-7.fc17, eekboard-1.0.5-4.fc17, ibus-skk-1.4.0-3.fc17, ibus-sayura-1.3.1-4.fc17, ibus-rawcode-1.3.1.20100707-7.fc17, ibus-m17n-1.3.3-9.fc17, ibus-hangul-1.4.0-5.fc17, ibus-chewing-1.3.10-3.fc17, ibus-pinyin-1.4.0-14.fc17, ibus-1.4.99.20120304-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-3532/ibus-fbterm-0.9.1-14.fc17,ibus-qt-1.3.1-8.fc17,ibus-handwrite-2.1.4-4.fc17,sunpinyin-2.0.3-4.fc17,ibus-input-pad-1.4.0-7.fc17,eekboard-1.0.5-4.fc17,ibus-skk-1.4.0-3.fc17,ibus-sayura-1.3.1-4.fc17,ibus-rawcode-1.3.1.20100707-7.fc17,ibus-m17n-1.3.3-9.fc17,ibus-hangul-1.4.0-5.fc17,ibus-chewing-1.3.10-3.fc17,ibus-pinyin-1.4.0-14.fc17,ibus-1.4.99.20120304-3.fc17
Comment 5 Fedora Update System 2012-03-16 17:22:59 EDT
ibus-fbterm-0.9.1-14.fc17, ibus-qt-1.3.1-8.fc17, ibus-handwrite-2.1.4-4.fc17, sunpinyin-2.0.3-4.fc17, ibus-input-pad-1.4.0-7.fc17, eekboard-1.0.5-4.fc17, ibus-skk-1.4.0-3.fc17, ibus-sayura-1.3.1-4.fc17, ibus-rawcode-1.3.1.20100707-7.fc17, ibus-m17n-1.3.3-9.fc17, ibus-hangul-1.4.0-5.fc17, ibus-chewing-1.3.10-3.fc17, ibus-pinyin-1.4.0-14.fc17, ibus-1.4.99.20120304-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Jayway 2012-07-02 17:14:33 EDT
I am using fc17. I have installed these packets.

ibus.x86_64                            1.4.99.20120428-2.fc17 @updates          
ibus-anthy.x86_64                      1.4.99.20120327-1.fc17 @koji-override-0/$releasever
ibus-chewing.x86_64                    1.3.10-3.fc17          @koji-override-0/$releasever
ibus-gtk2.x86_64                       1.4.99.20120428-2.fc17 @updates          
ibus-gtk3.x86_64                       1.4.99.20120428-2.fc17 @updates          
ibus-hangul.x86_64                     1.4.1-4.fc17           @updates          
ibus-hunspell-table.noarch             0.0.6-1.fc17           @koji-override-0/$releasever
ibus-libs.x86_64                       1.4.99.20120428-2.fc17 @updates          
ibus-m17n.x86_64                       1.3.3-11.fc17          @koji-override-0/$releasever
ibus-pinyin.x86_64                     1.4.0-16.fc17          @koji-override-0/$releasever
ibus-pinyin-db-android.noarch          1.4.0-16.fc17          @koji-override-0/$releasever
ibus-pinyin-db-open-phrase.noarch      1.4.0-16.fc17          @fedora           
ibus-rawcode.x86_64                    1.3.1.20100707-7.fc17  @koji-override-0/$releasever


But, when I hit ctrl-space, the chinese icon comes out, but what I type in is still english. Is this the same bug? how can I fix that?
Comment 7 fujiwara 2012-07-02 21:01:12 EDT
(In reply to comment #6)
> But, when I hit ctrl-space, the chinese icon comes out, but what I type in
> is still english. Is this the same bug? how can I fix that?

Your problem is not this bug and I don't see any problems.
Maybe a new bug would be good for you or ask #fedora-i18n on freenode chat.

Note You need to log in before you can comment on or make changes to this bug.