Bug 80100 - SMP kernel declares BIOS bug on DL560 G2. Identifies only one physical processor
SMP kernel declares BIOS bug on DL560 G2. Identifies only one physical proce...
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
Blocks: 79579 CambridgeTarget
  Show dependency treegraph
Reported: 2002-12-19 18:25 EST by Larry Troan
Modified: 2016-04-18 05:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:40:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
dmesg (14.91 KB, text/plain)
2002-12-19 18:31 EST, Larry Troan
no flags Details
dmesg_4CPU_DL560.txt (14.91 KB, text/plain)
2002-12-19 18:32 EST, Larry Troan
no flags Details
dmesg_beta1 (14.94 KB, text/plain)
2002-12-19 18:34 EST, Larry Troan
no flags Details
dmesg_beta4.txt (14.90 KB, text/plain)
2003-02-06 19:11 EST, Larry Troan
no flags Details
lspci-vvn_beta4.txt (8.50 KB, text/plain)
2003-02-06 19:11 EST, Larry Troan
no flags Details

  None (edit)
Description Larry Troan 2002-12-19 18:25:00 EST
During boot several  "BIOS bug" messages are issued regarding the IO APIC.  Only
one physical processor is seen by the kernel.  

GinGin BETA 2

DL 560 P2
Dual 1.9GHz procs
11/15/02 ROM
1024 MB RAM
SA 5302-128 

This is a new issue for beta 2.  All physical/virtual processors detected
correctly in beta1.  logs attached. 
Action by: Bryan.Leopard
Issue Registered
Action by: Bryan.Leopard

Status set to: Waiting on Tech

Action by: arjanv
are you sure your MPTABLE is correct ?

Action by: Bryan.Leopard
The MPTABLE is the same for both the BETA1 and BETA2 test results.  Beta 1
works, Beta 2 does not.  Changing from Full Table to Full Table Mapped did not
change the results, either.  In order to cover both possibilities, I have asked
the 560 ROM developer to look at the logs. Hyper-Threading is also broke on ALL

Action by: Bryan.Leopard
This is on a DL560, not a DL560 G2 (typo on my part).  I am attaching another dmesg.

File uploaded: dmesg_4cpu_DL560

Action by: Bryan.Leopard
New Data!:  With 2 (of 4) physical processors (Hyper-Threading Enabled), only
one processor identified in /proc/cpuinfo.

With 3 (of 4) physical processors installed, FIVE processors are listed in

With 4 (of 4) physical processors installed, ALL EIGHT Physical/Logical
processors are identified in /proc/cpuinfo.
Comment 1 Larry Troan 2002-12-19 18:25:37 EST
Issue Tracker 12240.
Comment 2 Larry Troan 2002-12-19 18:31:23 EST
Created attachment 88818 [details]
Comment 3 Larry Troan 2002-12-19 18:32:30 EST
Created attachment 88819 [details]
Comment 4 Larry Troan 2002-12-19 18:34:42 EST
Created attachment 88820 [details]
Comment 5 Larry Troan 2002-12-19 18:35:45 EST
Two message files from Issue Tracker were invalid attachments thre and therefore
not attached here.
Comment 6 Larry Troan 2003-01-16 17:48:34 EST
Arjan, any update on this? Do you need additional info from HP? They say this
was OK on beta2 but broken on beta3.
Comment 7 Arjan van de Ven 2003-01-16 18:52:59 EST
rawhide info ?
Comment 8 Arjan van de Ven 2003-01-21 08:58:37 EST
how does phoebe2/beta4 work ?
Comment 9 Larry Troan 2003-02-06 19:07:36 EST
 With beta4, the following messages still appear in the dmesg log (although the
OS claims to fix up the problem)
BIOS bug, IO-APIC#0 ID 2 is already used!...
... fixing up to 8. (tell your hw vendor)
...changing IO-APIC physical APIC ID to 8 ... ok.
BIOS bug, IO-APIC#1 ID 3 is already used!...
... fixing up to 9. (tell your hw vendor)
...changing IO-APIC physical APIC ID to 9 ... ok.
BIOS bug, IO-APIC#2 ID 4 is already used!...
... fixing up to 10. (tell your hw vendor)
...changing IO-APIC physical APIC ID to 10 ... ok.
BIOS bug, IO-APIC#3 ID 5 is already used!...
... fixing up to 11. (tell your hw vendor)
...changing IO-APIC physical APIC ID to 11 ... ok.


checking TSC synchronization across CPUs:
BIOS BUG: CPU#1 improperly initialized, has 2 usecs TSC skew! FIXED.
adding lspci -vv and demsg from beta 4.

File uploaded: dmesg_beta4.txt    Event posted 01-31-2003 11:17am by
Bryan.Leopard with duration of 0.00
File uploaded: lspci-vvn_beta4.txt 
Comment 10 Larry Troan 2003-02-06 19:11:06 EST
Created attachment 89911 [details]
Comment 11 Larry Troan 2003-02-06 19:11:41 EST
Created attachment 89912 [details]
Comment 12 Bugzilla owner 2004-09-30 11:40:18 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.