Bug 801272 - [abrt] kernel: WARNING: at /builddir/build/BUILD/kernel-3.2.fc16/compat-wireless-3.3-rc1-2/drivers/net/wireless/ath/ath9k/rc.c:697 ath_rc_get_highest_rix+0x1f9/0x210 [ath9k]()
[abrt] kernel: WARNING: at /builddir/build/BUILD/kernel-3.2.fc16/compat-wirel...
Status: CLOSED DUPLICATE of bug 768639
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:d0dec392c83f7d9ca9b41813b27...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-08 01:17 EST by Jeff Sandys
Modified: 2012-03-08 11:45 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-08 11:45:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Sandys 2012-03-08 01:17:55 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.2.7-1.fc16.x86_64 root=/dev/mapper/vg_chladni-lv_root ro rd.md=0 rd.dm=0 KEYTABLE=us rd.lvm.lv=vg_chladni/lv_swap quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 LANG=en_US.UTF-8 rd.lvm.lv=vg_chladni/lv_root
comment:        How did it happen?  Don't know.  But it happens a few times with every new kernel (including the PlanetCCRMA RT patched kernel).  Eventually it stops happening.
kernel:         3.2.7-1.fc16.x86_64
reason:         WARNING: at /builddir/build/BUILD/kernel-3.2.fc16/compat-wireless-3.3-rc1-2/drivers/net/wireless/ath/ath9k/rc.c:697 ath_rc_get_highest_rix+0x1f9/0x210 [ath9k]()
time:           Tue 06 Mar 2012 08:23:53 PM PST

backtrace:
:WARNING: at /builddir/build/BUILD/kernel-3.2.fc16/compat-wireless-3.3-rc1-2/drivers/net/wireless/ath/ath9k/rc.c:697 ath_rc_get_highest_rix+0x1f9/0x210 [ath9k]()
:Hardware name: Studio 1440   
:Modules linked in: fuse lockd ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack snd_hda_codec_hdmi snd_hda_codec_idt snd_hda_intel snd_hda_codec snd_hwdep snd_seq arc4 uvcvideo snd_seq_device snd_pcm ath9k videodev snd_timer snd mac80211 soundcore media ath9k_common ath9k_hw ath cfg80211 shpchp v4l2_compat_ioctl32 snd_page_alloc r8169 i2c_nforce2 mii dell_laptop rfkill joydev dell_wmi microcode dcdbas sparse_keymap uinput sunrpc binfmt_misc firewire_ohci sdhci_pci sdhci mmc_core firewire_core crc_itu_t nouveau ttm drm_kms_helper drm i2c_algo_bit i2c_core mxm_wmi wmi video [last unloaded: scsi_wait_scan]
:Pid: 5, comm: kworker/u:0 Not tainted 3.2.7-1.fc16.x86_64 #1
:Call Trace:
: <IRQ>  [<ffffffff8106dd4f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff8106ddaa>] warn_slowpath_null+0x1a/0x20
: [<ffffffffa03a5769>] ath_rc_get_highest_rix+0x1f9/0x210 [ath9k]
: [<ffffffffa03a58bc>] ath_get_rate+0x8c/0x410 [ath9k]
: [<ffffffff81154a63>] ? dma_pool_alloc+0x1c3/0x2c0
: [<ffffffffa02fa7c6>] rate_control_get_rate+0x96/0x170 [mac80211]
: [<ffffffffa030659f>] invoke_tx_handlers+0x6ff/0x13e0 [mac80211]
: [<ffffffffa02e5dac>] ? sta_info_get+0x6c/0x80 [mac80211]
: [<ffffffffa03073d0>] ieee80211_tx+0x60/0xc0 [mac80211]
: [<ffffffffa03074b1>] ieee80211_xmit+0x81/0xd0 [mac80211]
: [<ffffffffa0307b5f>] ieee80211_subif_start_xmit+0x3af/0x9f0 [mac80211]
: [<ffffffff81099327>] ? getnstimeofday+0x57/0xe0
: [<ffffffff814d4d72>] dev_hard_start_xmit+0x322/0x6e0
: [<ffffffff814f087f>] sch_direct_xmit+0xef/0x1c0
: [<ffffffff814f09f6>] __qdisc_run+0xa6/0x130
: [<ffffffff810e4854>] ? __rcu_process_callbacks+0x54/0x380
: [<ffffffff814d2e83>] net_tx_action+0xe3/0x1f0
: [<ffffffff81075378>] __do_softirq+0xb8/0x230
: [<ffffffff815ebfec>] call_softirq+0x1c/0x30
: <EOI>  [<ffffffff81016275>] do_softirq+0x65/0xa0
: [<ffffffff810752b4>] local_bh_enable_ip+0x94/0xa0
: [<ffffffff815e1dd5>] _raw_spin_unlock_bh+0x15/0x20
: [<ffffffffa03a1229>] ath_txq_unlock_complete+0x79/0xd0 [ath9k]
: [<ffffffffa03a1316>] ath_tx_complete_poll_work+0x96/0xf0 [ath9k]
: [<ffffffffa02eaa50>] ? ieee80211_scan_rx+0x1a0/0x1a0 [mac80211]
: [<ffffffffa03a1280>] ? ath_txq_unlock_complete+0xd0/0xd0 [ath9k]
: [<ffffffff81089ddd>] process_one_work+0x11d/0x470
: [<ffffffff8108b1df>] worker_thread+0x15f/0x350
: [<ffffffff8108b080>] ? manage_workers+0x230/0x230
: [<ffffffff8108fb9c>] kthread+0x8c/0xa0
: [<ffffffff815ebef4>] kernel_thread_helper+0x4/0x10
: [<ffffffff8108fb10>] ? kthread_worker_fn+0x190/0x190
: [<ffffffff815ebef0>] ? gs_change+0x13/0x13

smolt_data:
:
:
:General
:=================================
:UUID: 1d8cfef7-af78-4d23-9b70-5834335df0fd
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 4199.97
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Duo CPU     T6500  @ 2.10GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 2
:CPU Speed: 2100
:System Memory: 2759
:System Swap: 6015
:Vendor: Dell Inc.
:System: Studio 1440 A04
:Form factor: Portable
:Kernel: 3.2.7-1.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4318:2720:4318:0) pci, None, PCI/PCI, MCP79 PCI Express Bridge
:(5772:42:5772:512) pci, ath9k, NETWORK, AR928X Wireless Network Adapter (PCI-Express)
:(4318:2690:0:0) pci, None, HOST/PCI, MCP79 Host Bridge
:(4318:2696:0:0) pci, None, RAM, MCP79 Memory Controller
:(4332:33128:4136:698) pci, r8169, ETHERNET, RTL8111/8168B PCI Express Gigabit Ethernet controller
:(6523:9088:4136:698) pci, firewire_ohci, FIREWIRE, IEEE 1394 Host Controller
:(4318:2150:4136:698) pci, nouveau, VIDEO, C79 [GeForce 9400M G]
:(4318:2759:4318:0) pci, pcieport, PCI/PCI, MCP79 PCI Express Bridge
:(4318:2759:4318:0) pci, pcieport, PCI/PCI, MCP79 PCI Express Bridge
:(4318:2759:4318:0) pci, pcieport, PCI/PCI, MCP79 PCI Express Bridge
:(4318:2758:4318:0) pci, pcieport, PCI/PCI, MCP79 PCI Express Bridge
:(4318:2723:4136:698) pci, None, PROCESSOR, MCP79 Co-processor
:(4318:2726:4136:698) pci, ehci_hcd, USB, MCP79 EHCI USB 2.0 Controller
:(4318:2724:4136:698) pci, None, RAM, MCP79 Memory Controller
:(4318:2734:4136:698) pci, None, PCI/ISA, MCP79 LPC Bridge
:(4318:2697:4136:698) pci, None, RAM, MCP79 Memory Controller
:(4318:2722:4136:698) pci, nForce2_smbus, SERIAL, MCP79 SMBus
:(4318:2752:4136:698) pci, snd_hda_intel, MULTIMEDIA, MCP79 High Definition Audio
:(4318:2731:4318:52089) pci, None, PCI/PCI, MCP79 PCI Bridge
:(4480:57904:4480:57904) pci, None, BASE, Memory Stick Host Controller
:(4480:59426:4480:59426) pci, sdhci-pci, BASE, MMC/SD Host Controller
:(4318:2725:4136:698) pci, ohci_hcd, USB, MCP79 OHCI USB 1.1 Controller
:(4480:59474:4480:59474) pci, None, BASE, N/A
:(4318:2745:4136:698) pci, ahci, STORAGE, MCP79 AHCI Controller
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_chladni-lv_root / ext4 4096 4096 16355252 13806900 12987700 4096000 3791738 3791738
:/dev/sda3 /boot ext4 1024 1024 508745 333268 307668 128016 127706 127706
:/dev/mapper/vg_chladni-lv_home /home ext4 4096 4096 33900977 33004070 31306688 8486912 8475111 8475111
:
Comment 1 Dave Jones 2012-03-08 11:45:55 EST

*** This bug has been marked as a duplicate of bug 768639 ***

Note You need to log in before you can comment on or make changes to this bug.