Bug 768639 - [abrt] kernel: WARNING: at /builddir/build/BUILD/kernel-3.1.fc17/compat-wireless-2011-12-01/drivers/net/wireless/ath/ath9k/rc.c:697 ath_rc_get_highest_rix+0x158/0x1f0 [ath9k]()
[abrt] kernel: WARNING: at /builddir/build/BUILD/kernel-3.1.fc17/compat-wirel...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
abrt_hash:d1d2de34d82c88b5d20be9dc9c5...
:
: 771113 772437 773123 782392 782544 783569 783700 783720 783773 783983 784830 785009 785285 785294 785578 785579 785597 786409 786579 787052 787374 787385 787859 787965 788053 788499 788503 788505 788507 789130 789629 789657 789716 789882 790646 790906 794938 794969 795013 795236 795483 795485 795486 795985 796029 797058 797275 798140 798201 800248 800651 801272 804137 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-17 10:05 EST by somsom01
Modified: 2012-03-30 05:29 EDT (History)
92 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-26 10:22:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: smolt_data (3.05 KB, text/plain)
2011-12-17 10:05 EST, somsom01
no flags Details
File: backtrace (3.52 KB, text/plain)
2011-12-17 10:05 EST, somsom01
no flags Details
Patch for the ath9k driver to print what is going on (1.26 KB, patch)
2012-01-26 18:01 EST, Pavel Roskin
no flags Details | Diff
lines starting with "legacy" (28.64 KB, text/x-log)
2012-01-31 00:51 EST, Alexander
no flags Details
Fix for memory corruption (1.23 KB, patch)
2012-02-06 13:48 EST, Pavel Roskin
no flags Details | Diff
Fix for memory corruption (with corrected printk) (1.25 KB, patch)
2012-02-06 14:08 EST, Pavel Roskin
no flags Details | Diff
Photo of my crash screen...looks like a rate table issue with the ath9k driver. (2.19 MB, image/jpeg)
2012-02-07 17:51 EST, gcarter
no flags Details
One-line patch to be submitted upstream (1.12 KB, patch)
2012-02-11 10:00 EST, Pavel Roskin
no flags Details | Diff

  None (edit)
Description somsom01 2011-12-17 10:05:50 EST
libreport version: 2.0.7
abrt_version:   2.0.6
cmdline:        BOOT_IMAGE=/vmlinuz-3.2.0-0.rc5.git0.1.fc17.x86_64 root=/dev/mapper/VolGroup-lv_root ro rd.md=0 acpi=off rd.dm=0 rd.lvm.lv=VolGroup/lv_swap quiet SYSFONT=latarcyrheb-sun16 rhgb rd.lvm.lv=VolGroup/lv_root rd.luks=0 KEYTABLE=hu LANG=en_US.UTF-8
kernel:         3.2.0-0.rc5.git0.1.fc17.x86_64
reason:         WARNING: at /builddir/build/BUILD/kernel-3.1.fc17/compat-wireless-2011-12-01/drivers/net/wireless/ath/ath9k/rc.c:697 ath_rc_get_highest_rix+0x158/0x1f0 [ath9k]()
time:           2011. dec. 17., szombat, 16.00.59 CET

backtrace:      Text file, 3603 bytes
smolt_data:     Text file, 3128 bytes

event_log:
:2011-12-17-16:01:39> Smolt profile successfully saved
:2011-12-17-16:04:40> Submitting oops report to http://submit.kerneloops.org/submitoops.php
:2011-12-17-16:05:43  Kernel oops has not been sent due to Couldn't connect to server
:2011-12-17-16:05:43* (exited with 1)
Comment 1 somsom01 2011-12-17 10:05:53 EST
Created attachment 548216 [details]
File: smolt_data
Comment 2 somsom01 2011-12-17 10:05:55 EST
Created attachment 548217 [details]
File: backtrace
Comment 3 John W. Linville 2012-01-09 14:27:02 EST
Pinged ath9k-devel@qualcomm.com for some help...
Comment 4 John W. Linville 2012-01-10 14:04:45 EST
*** Bug 772437 has been marked as a duplicate of this bug. ***
Comment 5 John W. Linville 2012-01-10 14:05:08 EST
*** Bug 771113 has been marked as a duplicate of this bug. ***
Comment 6 John W. Linville 2012-01-10 14:06:28 EST
Bug 772107 comment 3 suggest using "nohwcrypt=1" as a modprobe option for ath9k
to avoid this issue -- not sure I see the connection, but just in case it is
helpful...
Comment 7 Josh Boyer 2012-01-11 09:04:35 EST
*** Bug 773123 has been marked as a duplicate of this bug. ***
Comment 8 Gustavo 2012-01-13 17:39:45 EST
added options ath9k nohwcrypt=1 to /etc/modprobe.d/ath9k (new file). Wireless networking works fine, and I even noticed better speedtest.net results. Don't know if it's related to.
Comment 9 Gustavo 2012-01-14 16:15:40 EST
Problem remains.
Comment 10 Pavel Roskin 2012-01-15 09:29:14 EST
I cannot reproduce the problem anymore.  Those who can reproduce the problem, please do following.  Download http://linuxwireless.org/download/compat-wireless-2.6/compat-wireless-2.6.tar.bz2 and apply the patch from bug 771113.  Use

./scripts/driver-select ath9k

to only compile ath9k and its dependencies (this is optional to save time, but some may want to recompile all modules).  Compile and install compat-wireless.  In case of any questions, see instructions at

http://linuxwireless.org/en/users/Download

Make sure "modinfo ath9k" shows "ath9k" under "update", not under "backports":

modinfo ath9k |grep -E '(backports|update)'

Reload the wireless modules or just reboot.  Once the warning happens, run dmesg to see what was printed before the stack trace and post it here.
Comment 11 Gustavo 2012-01-15 12:42:07 EST
Applied patch, compiled, installed and reload ath9k. No problems, so far.
--
[root@raptor compat-wireless-2012-01-14]# modinfo ath9k
filename:       /lib/modules/3.1.7-1.fc16.x86_64/updates/drivers/net/wireless/ath/ath9k/ath9k.ko
license:        Dual BSD/GPL
description:    Support for Atheros 802.11n wireless LAN cards.
author:         Atheros Communications
srcversion:     75B717F4BD5D00B29888FB1
alias:          pci:v0000168Cd00000034sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000033sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000032sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000030sv*sd*bc*sc*i*
alias:          pci:v0000168Cd0000002Esv*sd*bc*sc*i*
alias:          pci:v0000168Cd0000002Dsv*sd*bc*sc*i*
alias:          pci:v0000168Cd0000002Csv*sd*bc*sc*i*
alias:          pci:v0000168Cd0000002Bsv*sd*bc*sc*i*
alias:          pci:v0000168Cd0000002Asv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000029sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000027sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000024sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000023sv*sd*bc*sc*i*
depends:        ath9k_hw,ath9k_common,mac80211,ath,cfg80211
vermagic:       3.1.7-1.fc16.x86_64 SMP mod_unload 
parm:           debug:Debugging mask (uint)
parm:           nohwcrypt:Disable hardware encryption (int)
parm:           blink:Enable LED blink on activity (int)
parm:           btcoex_enable:Enable wifi-BT coexistence (int)
Comment 12 Justin Stitcher 2012-01-15 14:14:44 EST
I was just downloading from the internet.

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 13 Josh Boyer 2012-01-17 09:57:12 EST
*** Bug 782392 has been marked as a duplicate of this bug. ***
Comment 14 Josh Boyer 2012-01-17 11:59:20 EST
*** Bug 782544 has been marked as a duplicate of this bug. ***
Comment 15 Aaron Hamid 2012-01-21 14:22:55 EST
this error started popping up all of a sudden as a abrt warning.  first time i have seen this, have no idea what it is.  wireless seems to still be functioning, errors keep getting dumped into abrt, and then disappearing.. :(

msi-cr620 laptop


Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 16 Aaron Hamid 2012-01-21 14:33:10 EST
using my laptop function key to (presumably hardware?) toggle the wireless off and on again stopped the stream of warnings.
Comment 17 Gustavo 2012-01-22 15:58:40 EST
One week with no problems at all. I think it's OK, now.
Comment 18 Josh Boyer 2012-01-23 10:46:01 EST
*** Bug 783569 has been marked as a duplicate of this bug. ***
Comment 19 Josh Boyer 2012-01-23 10:52:39 EST
*** Bug 783700 has been marked as a duplicate of this bug. ***
Comment 20 Josh Boyer 2012-01-23 10:54:04 EST
*** Bug 783720 has been marked as a duplicate of this bug. ***
Comment 21 Josh Boyer 2012-01-23 10:56:48 EST
*** Bug 783773 has been marked as a duplicate of this bug. ***
Comment 22 Josh Boyer 2012-01-23 11:15:25 EST
*** Bug 783983 has been marked as a duplicate of this bug. ***
Comment 23 bethebeast 2012-01-26 06:31:53 EST
this bug happen many many times, every 2 seconds until i desactivate wireless with fn+f2

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 24 MERCIER Jonathan 2012-01-26 08:21:46 EST
i do this for stop and clean message:
---------------------Console----------------------------
# service abrt-ccpp stop
Redirecting to /bin/systemctl  stop abrt-ccpp.service

# service abrtd stop
Redirecting to /bin/systemctl  stop abrtd.service

# service abrt-oops stop
Redirecting to /bin/systemctl  stop abrt-oops.service

# service abrt-vmcore stop
Redirecting to /bin/systemctl  stop abrt-vmcore.service

# for dir in /var/spool/abrt/*;do abrt-cli rm $dir;done
'/var/spool/abrt/abrt-db' does not exist
Can't connect to '/var/run/abrt/abrt.socket': Connection refused
'/var/spool/abrt/last-ccpp' does not exist
Can't connect to '/var/run/abrt/abrt.socket': Connection refused
'/var/spool/abrt/oops-2011-12-30-14:55:15-1079-60' is not a problem directory
Can't connect to '/var/run/abrt/abrt.socket': Connection refused
rm '/var/spool/abrt/oops-2012-01-26-14:10:35-1193-615'
rm '/var/spool/abrt/oops-2012-01-26-14:10:35-1193-625'
rm '/var/spool/abrt/oops-2012-01-26-14:10:35-1193-626'
rm '/var/spool/abrt/oops-2012-01-26-14:16:43-1193-1'
rm '/var/spool/abrt/oops-2012-01-26-14:17:02-1193-1'
rm '/var/spool/abrt/oops-2012-01-26-14:17:08-1193-2'
rm '/var/spool/abrt/pyhook-2012-01-26-14:12:37-2162'
---------------------------------------------------------


But they are always the bug!!! I have try kernel 3.3 tagged to f17, my wifi card do not works
Comment 25 Josh Boyer 2012-01-26 08:30:41 EST
*** Bug 784830 has been marked as a duplicate of this bug. ***
Comment 26 Pavel Roskin 2012-01-26 18:01:29 EST
Created attachment 557762 [details]
Patch for the ath9k driver to print what is going on

Everyone who can reproduce the bug, please download the latest compat-wireless from http://linuxwireless.org/en/users/Download, apply this patch, compile and install compat-wireless, reload the "ath9k*' modules (or just reboot) and post the dmesg output once you get the warning.  This patch makes the driver print important information about the problem.  We cannot go further without that information.  If you don't test it, something like this (likely something less verbose) would be applied to the stock kernel and you would get that kernel eventually, maybe months later.  But if you test now, the bug may be fixed tomorrow.
Comment 27 Josh Boyer 2012-01-26 18:39:41 EST
*** Bug 785009 has been marked as a duplicate of this bug. ***
Comment 28 MERCIER Jonathan 2012-01-27 06:46:13 EST
# tar xf compat-wireless-3.3-rc1-2.tar.bz2 

# cd compat-wireless-3.3-rc1-2

# wget https://bugzilla.redhat.com/attachment.cgi?id=557762&action=diff&context=patch&collapsed=&headers=1&format=raw

# mv attachment.cgi\?id\=557762 atheros.patch

# patch -p0 --dry-run  atheros.patch

# ./scripts/driver-select ath9k

# make
/root/compat-wireless-3.3-rc1-2/config.mk:254: "WARNING: CONFIG_CFG80211_WEXT will be deactivated or not working because kernel was compiled with CONFIG_WIRELESS_EXT=n. Tools using wext interface like iwconfig will not work. To activate it build your kernel e.g. with CONFIG_LIBIPW=m."
make -C /lib/modules/3.2.0-2.fc17.x86_64/build M=/root/compat-wireless-3.3-rc1-2 modules
make: *** /lib/modules/3.2.0-2.fc17.x86_64/build: No such file or directory.  Stop.
make: *** [modules] Error 2
Comment 29 Dave Johnson 2012-01-27 10:58:33 EST
Browsing via firefox, about a hundred windows popped up informing me that there's a problem with my wireless drivers, something about a kernal package, now I have this window.  Atheros wireless, it's been a problem for some time but never like this.  Also, the connection randomly disconnects and will not reconnect until I reboot, that has been happening since at least F15.

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 30 John W. Linville 2012-01-27 11:25:52 EST
MERCIER Jonathan -- 'yum install kernel-devel' and then retry...
Comment 31 Alexander 2012-01-29 00:57:17 EST
How i patch:
# wget http://linuxwireless.org/download/compat-wireless-2.6/compat-wireless-2.6.tar.bz2
# tar xf compat-wireless-2.6.tar.bz2
# cd compat-wireless-2012-01-26
# wget https://bugzilla.redhat.com/attachment.cgi?id=557762&action=diff&context=patch&collapsed=&headers=1&format=raw                                                                                                      
# mv attachment.cgi\?id\=557762 atheros.patch

# patch -p1 --dry-run  < atheros.patch
patching file drivers/net/wireless/ath/ath9k/rc.c

# patch -p1   < atheros.patch
patching file drivers/net/wireless/ath/ath9k/rc.c

# ./scripts/driver-select ath9k
# make
# make install
# modinfo ath9k |grep -E '(backports|update)'
filename:       /lib/modules/3.2.2-1.fc16.x86_64/updates/drivers/net/wireless/ath/ath9k/ath9k.ko
# make wlunload
Unloading ath9k...
# modprobe ath9k
-----------------------------
And dmesg output:
-----------------------------
[54487.570053] ------------[ cut here ]------------
[54487.570069] WARNING: at /tmp/compat-wireless-2012-01-26/drivers/net/wireless/ath/ath9k/rc.c:706 ath_rc_get_highest_rix+0x26e/0x280 [ath9k]()
[54487.570075] Hardware name: P5K SE/EPU
[54487.570077] Modules linked in: tcp_lp lockd nf_conntrack_tftp nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_REJECT nf_conntrack_ftp nf_conntrack_ipv6 nf_defrag_ipv6 nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack ip6table_filter ip6_tables sunrpc arc4 ath9k(O) mac80211(O) ath9k_common(O) nvidia(P) ath9k_hw(O) ath(O) raid1 cfg80211(O) snd_hda_codec_hdmi microcode rfkill snd_hda_codec_realtek iTCO_wdt iTCO_vendor_support snd_hda_intel snd_hda_codec snd_hwdep i2c_i801 snd_seq serio_raw snd_seq_device snd_pcm asus_atk0110 binfmt_misc atl1 mii snd_timer snd i2c_core soundcore snd_page_alloc uinput usb_storage [last unloaded: scsi_wait_scan]
[54487.570137] Pid: 4965, comm: kworker/u:1 Tainted: P        W  O 3.2.2-1.fc16.x86_64 #1
[54487.570139] Call Trace:
[54487.570146]  [<ffffffff8106dd1f>] warn_slowpath_common+0x7f/0xc0
[54487.570149]  [<ffffffff8106dd7a>] warn_slowpath_null+0x1a/0x20
[54487.570154]  [<ffffffffa0dae7ce>] ath_rc_get_highest_rix+0x26e/0x280 [ath9k]
[54487.570158]  [<ffffffffa0dae91c>] ath_get_rate+0x8c/0x410 [ath9k]
[54487.570175]  [<ffffffffa0d30ae6>] rate_control_get_rate+0x96/0x170 [mac80211]
[54487.570186]  [<ffffffffa0d3c8cf>] invoke_tx_handlers+0x6ff/0x13e0 [mac80211]
[54487.570194]  [<ffffffffa0d1bdbc>] ? sta_info_get+0x6c/0x80 [mac80211]
[54487.570204]  [<ffffffffa0d3d700>] ieee80211_tx+0x60/0xc0 [mac80211]
[54487.570214]  [<ffffffffa0d3d7e1>] ieee80211_xmit+0x81/0xd0 [mac80211]
[54487.570225]  [<ffffffffa0d3e7ef>] ieee80211_tx_skb_tid+0x5f/0x70 [mac80211]
[54487.570234]  [<ffffffffa0d27c2b>] ieee80211_send_nullfunc+0x5b/0x70 [mac80211]
[54487.570243]  [<ffffffffa0d2943f>] ieee80211_dynamic_ps_enable_work+0x28f/0x530 [mac80211]
[54487.570253]  [<ffffffffa0d291b0>] ? ieee80211_dynamic_ps_disable_work+0x50/0x50 [mac80211]
[54487.570256]  [<ffffffff81089dad>] process_one_work+0x11d/0x470
[54487.570259]  [<ffffffff8108b1af>] worker_thread+0x15f/0x350
[54487.570262]  [<ffffffff8108b050>] ? manage_workers+0x230/0x230
[54487.570265]  [<ffffffff8108fb6c>] kthread+0x8c/0xa0
[54487.570269]  [<ffffffff815eb934>] kernel_thread_helper+0x4/0x10
[54487.570272]  [<ffffffff8108fae0>] ? kthread_worker_fn+0x190/0x190
[54487.570274]  [<ffffffff815eb930>] ? gs_change+0x13/0x13
[54487.570276] ---[ end trace 90fc630e55bf6a0d ]---
[54487.647935] legacy = 0, minindex = 0, maxindex = 9, ath_rc_priv->probe_time = 34481809, now_msec = 54187647, best_thruput = -939514064, this_thruput = 264, rate = 11, next_rate = 0, best_rate = 11, rate_table->info[rate].rate_flags = 0x0, ath_rc_priv->ht_cap = 0x0, ath_rc_priv->rate_table_size = 12, ath_rc_priv->hw_maxretry_pktcnt = 0, ath_rc_priv->rate_max_phy = 11
[54487.647942] ------------[ cut here ]------------
Comment 32 Alexander 2012-01-29 02:38:12 EST
dmesg command:
# dmesg --level=warn,err,crit,alert,emerg > var/log/dmesg.log

I have dmesg.log ~9,5 Mb. Do you need any other examples?
Comment 33 Dale Wilcox 2012-01-29 12:59:11 EST
Was watching a news cast when I received this message

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 34 Mitch Davis 2012-01-29 21:43:01 EST
Toggling wireless on/off stops the spewing of messages for me too.  I wonder if it will restart at some stage?
Comment 35 Josh Boyer 2012-01-30 09:03:35 EST
*** Bug 785294 has been marked as a duplicate of this bug. ***
Comment 36 Josh Boyer 2012-01-30 09:15:40 EST
*** Bug 785578 has been marked as a duplicate of this bug. ***
Comment 37 Josh Boyer 2012-01-30 09:15:56 EST
*** Bug 785579 has been marked as a duplicate of this bug. ***
Comment 38 Josh Boyer 2012-01-30 09:16:53 EST
*** Bug 785597 has been marked as a duplicate of this bug. ***
Comment 39 John W. Linville 2012-01-30 14:06:23 EST
*** Bug 785285 has been marked as a duplicate of this bug. ***
Comment 40 Pavel Roskin 2012-01-30 15:58:18 EST
Huge logs are not needed.  The line starting with "legacy" is all that was needed.  Thank you for posting it!
Comment 41 Alexander 2012-01-31 00:51:19 EST
Created attachment 558526 [details]
lines starting with "legacy"
Comment 42 Neil 2012-01-31 05:42:31 EST
I have a firefox window open; one tab connection to an Oracle XE 11g / apex 4.1 session (hosted off my Fedora machine, and one tab a google window looking for debug information.

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 43 Rupert Roth 2012-01-31 12:53:23 EST
Try download VMware Player from https://www.vmware.com/tryvmware/p/activate.php?p=player&lp=1

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 44 Josh Boyer 2012-02-01 10:44:08 EST
*** Bug 786409 has been marked as a duplicate of this bug. ***
Comment 45 Dave Jones 2012-02-01 16:19:44 EST
*** Bug 786579 has been marked as a duplicate of this bug. ***
Comment 46 Robert Buchholz 2012-02-02 23:12:43 EST
abrtd is running at 100% cpu here, filling up /var/spool. There are currently two workarounds, wireless-testing has a commit [1] to only issue a warning once, whereas discussion on the mailing list [2] suggests the offending commit 7a532fe7131216a02c81a6c1b1f8632da1195a58 [3] should be reverted or fixed.

[1] http://git.kernel.org/?p=linux/kernel/git/linville/wireless-testing.git;a=commit;h=41b2d62702730b0c6bc5a40722e423bb0338311a
[2] http://thread.gmane.org/gmane.linux.kernel.wireless.general/84582/focus=84626
[3] https://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=commit;h=7a532fe7131216a02c81a6c1b1f8632da1195a58
Comment 47 Matej Košík 2012-02-03 05:55:59 EST
I was only but connected via "wired connection" when this problem occurred.
I haven't see this error/warning with a prior kernel-version.


Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 48 Matej Košík 2012-02-03 06:10:24 EST
Also, I started to get these warnings/errors after I suspended and subsequently unsuspended my notebook. Whether it could triggered the problem, I am not sure but it is not excluded.
Comment 49 Josh Boyer 2012-02-03 09:33:00 EST
*** Bug 787052 has been marked as a duplicate of this bug. ***
Comment 50 Dave Johnson 2012-02-03 10:08:37 EST
It looks like most people are seeing this on a notebook, I'm seeing it on my desktop for the record.
Comment 51 John W. Linville 2012-02-03 13:43:37 EST
A patch has been committed to f16 to turn this into a WARN_ON_ONCE -- there
will still be a single report, but it shouldn't flood the logs anymore.
Comment 52 Dave Johnson 2012-02-03 14:33:47 EST
Awesome news John, I can surely live with a single report.  I'll finally be able to see my desktop.
Comment 53 Pavel Roskin 2012-02-04 11:31:24 EST
The values in the Alexander's attachment have next_rate=179.  That's clearly bogus and it comes from ath_rc_get_nextvalid_txrate().

Since we are seeing negative best_thruput, it's an indication of an overflow.  I tried printing rate_table->info[rate].user_ratekbps in the first loop in ath_rc_get_highest_rix(), and those are some values I got:

rate_table->info[2].user_ratekbps = 0x2000013
rate_table->info[8].user_ratekbps = 0x8000043
rate_table->info[11].user_ratekbps = 0xb000072

No wonder we have overflows.

I see a pattern here, it's rate*0x100000+n where n is a small number.  It must be some memory corruption that happens earlier.
Comment 54 Flos Lonicerae 2012-02-05 06:33:59 EST
abrt report this bug repeatedly

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 55 Pavel Roskin 2012-02-06 07:40:28 EST
ath_rc_priv->rate_table is incremented by one:

rate_table = ffffffffa044dea1, ar5416_11g_ratetable = ffffffffa044dea0

I suspect one of the fields preceding rate_table in struct ath_rate_priv is used with a wrong index.  In particular, I see elements of valid_phy_ratecnt incremented by one.

Sorry for reporting every little step to this large audience, but the bug is hard to reproduce, so I never know when I'll catch it the next time with the new debugging code.
Comment 56 Dave Johnson 2012-02-06 07:45:50 EST
I don't mind the reports at all, thanks for making them.  I also noticed that my data rates are.uber slow on the affected machine in my house, I've started using another machine for high network traffic stuff, not sure if that helps at all.
Comment 57 Dave Jones 2012-02-06 08:48:46 EST
*** Bug 787385 has been marked as a duplicate of this bug. ***
Comment 58 Dave Jones 2012-02-06 08:48:58 EST
*** Bug 787374 has been marked as a duplicate of this bug. ***
Comment 59 Pavel Roskin 2012-02-06 13:48:22 EST
Created attachment 559730 [details]
Fix for memory corruption

This patch is based on my analysis of printk() output I added to the ath9k driver.  I didn't have a chance to test the patch, so testing would be greatly appreciated.

The corruption must be happening in ath_debug_stat_rc(), which is given the result of ath_rc_get_rateindex().  ath_rc_get_rateindex() can return -1, which causes ath_debug_stat_rc() to increment the value that lies 16 bytes before rcstats in struct ath_rate_priv.  On 64-bit systems, that happens to be rate_table.  Once the rate_table pointer is incremented, all data there becomes invalid, which leads to the warning.  On 32-bit systems, the corruption should happen in neg_ht_rates.

The -1 value of idx in struct ieee80211_tx_rate is described in net/mac80211.h.  I don't know why we have -1 there and how to reproduce the problem reliably.  But -1 can be there and ath9k has no checks for it.

The patch introduces two protections: ath_rc_get_rateindex() never returns a negative value and ath_debug_stat_rc() checks the array bounds.

It may not be good enough for the kernel, but it may be good enough for Fedora.
Comment 60 Pavel Roskin 2012-02-06 14:08:26 EST
Created attachment 559733 [details]
Fix for memory corruption (with corrected printk)

This patch fixes a warning in printk() that could crash the kernel.  Sorry for the noise.  Please test the latest patch.
Comment 61 Josh Boyer 2012-02-06 19:54:37 EST
*** Bug 787859 has been marked as a duplicate of this bug. ***
Comment 62 Josh Boyer 2012-02-07 09:40:00 EST
*** Bug 788053 has been marked as a duplicate of this bug. ***
Comment 63 Josh Boyer 2012-02-07 09:41:18 EST
*** Bug 787965 has been marked as a duplicate of this bug. ***
Comment 64 Dave Johnson 2012-02-07 10:21:32 EST
I'm seeing the kernel panic as mentioned in duplicate bug 787965 as well, though I don't have any interfering wireless devices that I'm aware of.
Comment 65 Dave Johnson 2012-02-07 10:25:04 EST
I'm seeing the kernel panic as mentioned in duplicate bug 787965 as well, though I don't have any interfering wireless devices that I'm aware of.
Comment 66 Dave Johnson 2012-02-07 10:26:27 EST
(In reply to comment #65)
> I'm seeing the kernel panic as mentioned in duplicate bug 787965 as well,
> though I don't have any interfering wireless devices that I'm aware of.

Not sure what happened here, I have to remember to use the reply option more appropriately as not to bomb everyone with new messages.
Comment 67 khm 2012-02-07 11:51:54 EST
seems to be sporadic

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 68 John W. Linville 2012-02-07 15:31:34 EST
Test kernels w/ patch from comment 60 are building now:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3770211

Please give them a try when the build is finished and post the results here...thanks!
Comment 69 gcarter 2012-02-07 17:51:48 EST
Created attachment 560080 [details]
Photo of my crash screen...looks like a rate table issue with the ath9k driver.

Very nice explosion, pretty colors, then everything went black.

My God....the bits that died in the creating of this oops must never be forgotten.

A moment of silence please...

-gc
Comment 70 Yann Droneaud 2012-02-08 05:45:41 EST
*** Bug 788499 has been marked as a duplicate of this bug. ***
Comment 71 Yann Droneaud 2012-02-08 05:57:47 EST
*** Bug 788503 has been marked as a duplicate of this bug. ***
Comment 72 Yann Droneaud 2012-02-08 05:58:31 EST
*** Bug 788505 has been marked as a duplicate of this bug. ***
Comment 73 Yann Droneaud 2012-02-08 05:59:07 EST
*** Bug 788507 has been marked as a duplicate of this bug. ***
Comment 74 Pavel Roskin 2012-02-08 08:40:07 EST
I was able to catch two "minus one" events in a short sequence:

[18311.688446] wlan0: moving STA 00:21:29:a0:c7:b2 to state 1
[18311.688453] wlan0: moving STA 00:21:29:a0:c7:b2 to state 2
[18311.711759] wlan0: moving STA 00:21:29:a0:c7:b2 to state 3
[19634.009730] ath_rc_get_rateindex: rate->idx = -1
[19634.009762] ath_rc_get_rateindex: rate->idx = -1
[23124.212050] wlan0: moving STA 00:21:29:a0:c7:b2 to state 2
[23124.212061] wlan0: moving STA 00:21:29:a0:c7:b2 to state 1
[23124.212068] wlan0: moving STA 00:21:29:a0:c7:b2 to state 0

No kernel warning in abrt anymore.  That confirms that negative rate->idx is indeed the cause of the memory corruption and that my patch addresses it.  I just left the laptop turned on overnight.  Nothing was happening with the laptop, but who knows what was going on on the air...
Comment 75 Dave Jones 2012-02-09 16:59:04 EST
*** Bug 789130 has been marked as a duplicate of this bug. ***
Comment 76 Robert Buchholz 2012-02-09 17:23:08 EST
(In reply to comment #68)
> Test kernels w/ patch from comment 60 are building now:
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=3770211

I can confirm that since I switched to this kernel, I did not see an OOPS anymore. The data rate went up and stabilized as well, where I was seeing flakyness (going down to ~1Mbit) before.
Comment 77 John W. Linville 2012-02-10 09:02:52 EST
Pavel, do you think this fix (or some version of it) is worth pushing upstream?
Comment 78 Pavel Roskin 2012-02-10 09:51:59 EST
We certainly need a fix upstream.  The recent commits that fix minstrel_ht don't fix this issue.  Figuring out the problem on the higher levels may take some time, and I tend to think that ath9k/rc.c would benefit from having its own sanity checks in reasonable amounts.  Most of the code in ath9k/rc.c can deal with ath_rc_get_rateindex() returning -1.  Only ath_debug_stat_rc() lacks the checks, so they need to be added.  As for ath_rc_get_rateindex(), it should probably return -1 if the rate->idx is -1 (without looking at rate->flags).  It would be more honest than 0.  Even though I hate posting patches without understanding the whole picture (with the mac80211 level), I think such minimal change would be justified.

It takes me one day to run another test, so it would take time to figure out.  But I checked my kernels logs from the recent days, and here's a backtrace that shows the callers above ath_tx_status() when -1 is passed.  validate_rate_table() is a debugging function I added.  That's compat-wireless 3.3-rc1-2, not the bleeding edge.

[  309.004650] validate: rate_table = ffffffffa0355ea1, ar5416_11g_ratetable = ffffffffa0355ea0
[  309.004662] ------------[ cut here ]------------
[  309.004692] WARNING: at /home/proski/src/compat-wireless-3.3-rc1-2/drivers/net/wireless/ath/ath9k/rc.c:393 validate_rate_table+0x84/0xc0 [ath9k]()
[  309.004702] Hardware name: 1005PE
[  309.004708] Modules linked in: ppdev parport_pc lp parport fuse fcoe libfcoe libfc scsi_transport_fc scsi_tgt 8021q garp stp llc ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack arc4 ath9k(O) mac80211(O) eeepc_wmi asus_wmi sparse_keymap ath9k_common(O) ath9k_hw(O) snd_hda_codec_realtek uvcvideo videodev media v4l2_compat_ioctl32 snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device ath(O) microcode snd_pcm joydev cfg80211(O) i2c_i801 iTCO_wdt iTCO_vendor_support snd_timer snd atl1c soundcore snd_page_alloc rfkill uinput wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
[  309.004861] Pid: 1747, comm: kworker/u:25 Tainted: G           O 3.2.2-1.fc16.x86_64 #1
[  309.004870] Call Trace:
[  309.004890]  [<ffffffff8106dd1f>] warn_slowpath_common+0x7f/0xc0
[  309.004905]  [<ffffffff8106dd7a>] warn_slowpath_null+0x1a/0x20
[  309.004924]  [<ffffffffa03523f4>] validate_rate_table+0x84/0xc0 [ath9k]
[  309.004943]  [<ffffffffa0352c9f>] ath_tx_status+0x24f/0x320 [ath9k]
[  309.004979]  [<ffffffffa02bef00>] ieee80211_tx_status+0x210/0xbc0 [mac80211]
[  309.005000]  [<ffffffffa034e24f>] ath_txq_unlock_complete+0xaf/0xd0 [ath9k]
[  309.005067]  [<ffffffffa0350413>] ath_draintxq+0x173/0x190 [ath9k]
[  309.005086]  [<ffffffffa0350548>] ath_drain_all_txq+0x118/0x160 [ath9k]
[  309.005103]  [<ffffffffa0347c5c>] ath_prepare_reset+0x5c/0xd0 [ath9k]
[  309.005120]  [<ffffffffa03491fd>] ath_reset_internal+0x8d/0x150 [ath9k]
[  309.005139]  [<ffffffffa03497a0>] ath9k_config+0x260/0x5b0 [ath9k]
[  309.005172]  [<ffffffffa02be557>] ieee80211_hw_config+0x127/0x230 [mac80211]
[  309.005205]  [<ffffffffa02c4b55>] ieee80211_scan_work+0x105/0x610 [mac80211]
[  309.005218]  [<ffffffff81013866>] ? __switch_to+0x276/0x310
[  309.005246]  [<ffffffffa02c4a50>] ? ieee80211_scan_rx+0x1a0/0x1a0 [mac80211]
[  309.005259]  [<ffffffff81089dad>] process_one_work+0x11d/0x470
[  309.005269]  [<ffffffff8108b1af>] worker_thread+0x15f/0x350
[  309.005278]  [<ffffffff8108b050>] ? manage_workers+0x230/0x230
[  309.005288]  [<ffffffff8108fb6c>] kthread+0x8c/0xa0
[  309.005300]  [<ffffffff815eb934>] kernel_thread_helper+0x4/0x10
[  309.005311]  [<ffffffff8108fae0>] ? kthread_worker_fn+0x190/0x190
[  309.005322]  [<ffffffff815eb930>] ? gs_change+0x13/0x13
[  309.005330] ---[ end trace fa23d04ad3471e16 ]---
Comment 79 Pavel Roskin 2012-02-11 10:00:33 EST
Created attachment 561099 [details]
One-line patch to be submitted upstream

rate->idx being -1 should stop processing.  Other rate control algorithms do it, ath9k/rc doesn't.  That's the only terminator in the rate set documented in net/mac80211.h.  Check for count 0 is probably not needed, but other rate control algorithms do it, and I want to keep it, as the patch is intended for stable kernels and should change as little as possible.
Comment 80 Olen 2012-02-11 17:00:13 EST
browsing web with firefox, connection via wifi on my laptop

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 81 Dave Jones 2012-02-12 17:37:32 EST
*** Bug 789657 has been marked as a duplicate of this bug. ***
Comment 82 Dave Jones 2012-02-12 17:37:42 EST
*** Bug 789716 has been marked as a duplicate of this bug. ***
Comment 83 Dave Jones 2012-02-12 17:38:43 EST
*** Bug 789629 has been marked as a duplicate of this bug. ***
Comment 84 Josh Boyer 2012-02-13 10:06:11 EST
*** Bug 789882 has been marked as a duplicate of this bug. ***
Comment 85 John W. Linville 2012-02-13 13:35:17 EST
Test kernels with the patch from comment 79 are available here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3787209

When the finish building, please give them a try and post the results here...thanks!
Comment 86 Travis 2012-02-13 16:53:46 EST
At the time I noticed the error I was pulling from a repository with mercurial over ssh. I'm getting a string of new notifications that look the same while starting up Firefox.

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 87 Olen 2012-02-13 23:57:38 EST
I think its fixed for me.  I have tried the koji test kernel this evening, and haven't had a oops message yet.
Comment 88 Iván Jiménez 2012-02-14 14:48:11 EST
(In reply to comment #85)
> Test kernels with the patch from comment 79 are available here:
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=3787209
> 
> When the finish building, please give them a try and post the results
> here...thanks!

I've been using it since yesterday without any crash so far. connecting and disconnecting from wifi works, rfkill works.  it's slow to reconnect after suspend, but it was the same before.
Comment 89 Josh Boyer 2012-02-15 09:24:15 EST
*** Bug 790646 has been marked as a duplicate of this bug. ***
Comment 90 Dave Jones 2012-02-15 12:43:09 EST
*** Bug 790906 has been marked as a duplicate of this bug. ***
Comment 91 Pavel Roskin 2012-02-15 12:58:20 EST
I have a definite confirmation that my patch is working.  I observed the condition when rate->idx is -1, but rate->count is not 0.  That's the full rate set:

rate 0, idx 0, count 10, flags 0x0
rate 1, idx -1, count 1, flags 0x0
rate 2, idx -1, count 1, flags 0x0
rate 3, idx -1, count 1, flags 0x0

That appears to be a valid set, not some random data.  So I think my last patch addresses the real problem in the code and there is no underlying problem to be fixed.
Comment 92 Stephen Girouard 2012-02-16 01:34:09 EST
I closed the lid of my laptop, let it go into sleep mode and took it back out of sleep. I've been having problems with the system coming out of sleep mode since I installed FC16.

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 93 Paul DeStefano 2012-02-16 18:47:07 EST
Not sure.  Recently, I've been having trouble with DNS on the wireless at a certiain location (where I am now).  But not at the other place I use it often.

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 94 Stephen Girouard 2012-02-16 23:04:46 EST
I was getting this error multiple times --I don't seem to get it anymore now that I enabled "wake on LAN" and "wake on keyboard" in the BIOS
Comment 95 Quentin Armitage 2012-02-17 05:04:10 EST
I wasn't getting any log messages that I noticed on my systems, but the ath9k devices is both my laptops weren't working with recent kernels.

I have now installed the kernel referenced at comment 79, and the ath9k devices are working again.

The laptops are a Dell D800 (32 bit) and a Toshiba C660-29W (64 bit).
Comment 96 Neil 2012-02-17 05:43:25 EST
I installed the patch on 3.2.5 on Wednesday, and my system seems fine now.  I haven't checked logs or anything, but I had been crashing at least once every 24 hours - I believe you've fixed it.
Comment 97 Paul DeStefano 2012-02-17 14:07:04 EST
I'm pretty sure my crash was after that patch, though.
Comment 98 Neil 2012-02-17 14:29:21 EST
I spoke too soon; it literally crashed out on me this morning a few minutes after I posted.  I'm going to try a fresh patch again this evening to make sure I didn't goof it up.  I'm a total linux newbie...if any of my log information might be useful, please let me know how to acquire it/where to post it.
Comment 99 Josh Boyer 2012-02-18 13:10:29 EST
*** Bug 795013 has been marked as a duplicate of this bug. ***
Comment 100 Josh Boyer 2012-02-18 13:11:30 EST
*** Bug 794969 has been marked as a duplicate of this bug. ***
Comment 101 Josh Boyer 2012-02-18 13:12:22 EST
*** Bug 794938 has been marked as a duplicate of this bug. ***
Comment 102 Josh Boyer 2012-02-20 09:28:08 EST
*** Bug 795236 has been marked as a duplicate of this bug. ***
Comment 103 Josh Boyer 2012-02-20 14:07:41 EST
*** Bug 795486 has been marked as a duplicate of this bug. ***
Comment 104 Josh Boyer 2012-02-20 14:07:48 EST
*** Bug 795485 has been marked as a duplicate of this bug. ***
Comment 105 Josh Boyer 2012-02-20 14:08:52 EST
*** Bug 795483 has been marked as a duplicate of this bug. ***
Comment 106 Dave Jones 2012-02-21 18:52:01 EST
*** Bug 795985 has been marked as a duplicate of this bug. ***
Comment 107 Josh Boyer 2012-02-22 09:07:25 EST
*** Bug 796029 has been marked as a duplicate of this bug. ***
Comment 108 blaineglover 2012-02-22 11:00:16 EST
No idea.  I opened a new tab in Firefox, and then it happened.

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 109 Dale Wilcox 2012-02-24 07:10:19 EST
Was on the Internet when the crash happened.

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 110 Josh Boyer 2012-02-24 08:39:17 EST
*** Bug 797058 has been marked as a duplicate of this bug. ***
Comment 111 Keith 2012-02-24 10:41:53 EST
I was connecting to my school wifi and I got this error message.

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 112 Josh Boyer 2012-02-24 13:45:41 EST
*** Bug 797275 has been marked as a duplicate of this bug. ***
Comment 113 Tomas Toth 2012-02-25 05:09:46 EST
I hit this/similar kernel crash/panic with kernel 3.2.7-1.fc16.x86_64.

Cuts from /var/log/messages follow. Let me know if you need anything else.

Feb 24 00:12:47 omega kernel: [  605.818951] ------------[ cut here ]------------
Feb 24 00:12:47 omega kernel: [  605.818973] WARNING: at /builddir/build/BUILD/kernel-3.2.fc16/compat-wireless-3.3-rc1-2/drivers/net/wireless/ath/ath9k/rc.c:697 ath_rc_get_highest_rix+0x1f9/0x210 [ath9k]()
Feb 24 00:12:47 omega kernel: [  605.818980] Hardware name: N73JQ
Feb 24 00:12:47 omega kernel: [  605.818983] Modules linked in: tcp_lp lockd rfcomm bnep coretemp ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm atl1c asus_laptop btusb bluetooth snd_timer uvcvideo videodev i7core_edac edac_core media v4l2_compat_ioctl32 serio_raw uinput joydev arc4 sparse_keymap iTCO_wdt snd ath9k mac80211 ath9k_common ath9k_hw ath cfg80211 rfkill input_polldev iTCO_vendor_support soundcore snd_page_alloc sunrpc microcode nouveau ttm drm_kms_helper drm i2c_algo_bit i2c_core mxm_wmi wmi video [last unloaded: scsi_wait_scan]
Feb 24 00:12:47 omega kernel: [  605.819063] Pid: 77, comm: kworker/u:5 Not tainted 3.2.7-1.fc16.x86_64 #1
Feb 24 00:12:47 omega kernel: [  605.819067] Call Trace:
Feb 24 00:12:47 omega kernel: [  605.819070]  <IRQ>  [<ffffffff8106dd4f>] warn_slowpath_common+0x7f/0xc0
Feb 24 00:12:47 omega kernel: [  605.819091]  [<ffffffff8106ddaa>] warn_slowpath_null+0x1a/0x20
Feb 24 00:12:47 omega kernel: [  605.819103]  [<ffffffffa02e7769>] ath_rc_get_highest_rix+0x1f9/0x210 [ath9k]
Feb 24 00:12:47 omega kernel: [  605.819114]  [<ffffffffa02e78bc>] ath_get_rate+0x8c/0x410 [ath9k]
Feb 24 00:12:47 omega kernel: [  605.819143]  [<ffffffffa02847c6>] rate_control_get_rate+0x96/0x170 [mac80211]
Feb 24 00:12:47 omega kernel: [  605.819169]  [<ffffffffa029059f>] invoke_tx_handlers+0x6ff/0x13e0 [mac80211]
Feb 24 00:12:47 omega kernel: [  605.819188]  [<ffffffffa026fdac>] ? sta_info_get+0x6c/0x80 [mac80211]
Feb 24 00:12:47 omega kernel: [  605.819213]  [<ffffffffa02913d0>] ieee80211_tx+0x60/0xc0 [mac80211]
Feb 24 00:12:47 omega kernel: [  605.819239]  [<ffffffffa02914b1>] ieee80211_xmit+0x81/0xd0 [mac80211]
Feb 24 00:12:47 omega kernel: [  605.819264]  [<ffffffffa0291b5f>] ieee80211_subif_start_xmit+0x3af/0x9f0 [mac80211]
Feb 24 00:12:47 omega kernel: [  605.819275]  [<ffffffff814d4d72>] dev_hard_start_xmit+0x322/0x6e0
Feb 24 00:12:47 omega kernel: [  605.819285]  [<ffffffff814f087f>] sch_direct_xmit+0xef/0x1c0
Feb 24 00:12:47 omega kernel: [  605.819292]  [<ffffffff814f09f6>] __qdisc_run+0xa6/0x130
Feb 24 00:12:47 omega kernel: [  605.819300]  [<ffffffff810e4854>] ? __rcu_process_callbacks+0x54/0x380
Feb 24 00:12:47 omega kernel: [  605.819308]  [<ffffffff814d2e83>] net_tx_action+0xe3/0x1f0
Feb 24 00:12:47 omega kernel: [  605.819317]  [<ffffffff810964ed>] ? sched_clock_cpu+0xbd/0x110
Feb 24 00:12:47 omega kernel: [  605.819324]  [<ffffffff81075378>] __do_softirq+0xb8/0x230
Feb 24 00:12:47 omega kernel: [  605.819332]  [<ffffffff815ebfec>] call_softirq+0x1c/0x30
Feb 24 00:12:47 omega kernel: [  605.819336]  <EOI>  [<ffffffff81016275>] do_softirq+0x65/0xa0
Feb 24 00:12:47 omega kernel: [  605.819349]  [<ffffffff810752b4>] local_bh_enable_ip+0x94/0xa0
Feb 24 00:12:47 omega kernel: [  605.819358]  [<ffffffff815e1dd5>] _raw_spin_unlock_bh+0x15/0x20
Feb 24 00:12:47 omega kernel: [  605.819370]  [<ffffffffa02e3229>] ath_txq_unlock_complete+0x79/0xd0 [ath9k]
Feb 24 00:12:47 omega kernel: [  605.819381]  [<ffffffffa02e3316>] ath_tx_complete_poll_work+0x96/0xf0 [ath9k]
Feb 24 00:12:47 omega kernel: [  605.819402]  [<ffffffffa0274a50>] ? ieee80211_scan_rx+0x1a0/0x1a0 [mac80211]
Feb 24 00:12:47 omega kernel: [  605.819414]  [<ffffffffa02e3280>] ? ath_txq_unlock_complete+0xd0/0xd0 [ath9k]
Feb 24 00:12:47 omega kernel: [  605.819421]  [<ffffffff81089ddd>] process_one_work+0x11d/0x470
Feb 24 00:12:47 omega kernel: [  605.819428]  [<ffffffff8108b1df>] worker_thread+0x15f/0x350
Feb 24 00:12:47 omega kernel: [  605.819435]  [<ffffffff8108b080>] ? manage_workers+0x230/0x230
Feb 24 00:12:47 omega kernel: [  605.819442]  [<ffffffff8108fb9c>] kthread+0x8c/0xa0
Feb 24 00:12:47 omega kernel: [  605.819448]  [<ffffffff815ebef4>] kernel_thread_helper+0x4/0x10
Feb 24 00:12:47 omega kernel: [  605.819479]  [<ffffffff8108fb10>] ? kthread_worker_fn+0x190/0x190
Feb 24 00:12:47 omega kernel: [  605.819489]  [<ffffffff815ebef0>] ? gs_change+0x13/0x13
Feb 24 00:12:47 omega kernel: [  605.819502] ---[ end trace 12c6d6adfc89bfc8 ]---

Feb 25 00:55:21 omega kernel: [ 2614.843800] ------------[ cut here ]------------
Feb 25 00:55:21 omega kernel: [ 2614.843822] WARNING: at /builddir/build/BUILD/kernel-3.2.fc16/compat-wireless-3.3-rc1-2/drivers/net/wireless/ath/ath9k/rc.c:697 ath_rc_get_highest_rix+0x1f9/0x210 [ath9k]()
Feb 25 00:55:21 omega kernel: [ 2614.843829] Hardware name: N73JQ
Feb 25 00:55:21 omega kernel: [ 2614.843832] Modules linked in: tcp_lp lockd rfcomm bnep coretemp ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack snd_hda_codec_hdmi snd_hda_codec_realtek asus_laptop uvcvideo videodev media v4l2_compat_ioctl32 i7core_edac edac_core btusb atl1c joydev sparse_keymap serio_raw iTCO_wdt snd_hda_intel snd_hda_codec arc4 bluetooth ath9k mac80211 ath9k_common ath9k_hw ath cfg80211 rfkill snd_hwdep uinput iTCO_vendor_support snd_seq sunrpc snd_seq_device snd_pcm snd_timer snd soundcore snd_page_alloc input_polldev microcode nouveau ttm drm_kms_helper drm i2c_algo_bit i2c_core mxm_wmi wmi video [last unloaded: scsi_wait_scan]
Feb 25 00:55:21 omega kernel: [ 2614.843913] Pid: 6972, comm: kworker/u:2 Not tainted 3.2.7-1.fc16.x86_64 #1
Feb 25 00:55:21 omega kernel: [ 2614.843917] Call Trace:
Feb 25 00:55:21 omega kernel: [ 2614.843920]  <IRQ>  [<ffffffff8106dd4f>] warn_slowpath_common+0x7f/0xc0
Feb 25 00:55:21 omega kernel: [ 2614.843940]  [<ffffffff8101b949>] ? sched_clock+0x9/0x10
Feb 25 00:55:21 omega kernel: [ 2614.843948]  [<ffffffff8106ddaa>] warn_slowpath_null+0x1a/0x20
Feb 25 00:55:21 omega kernel: [ 2614.843960]  [<ffffffffa034e769>] ath_rc_get_highest_rix+0x1f9/0x210 [ath9k]
Feb 25 00:55:21 omega kernel: [ 2614.843968]  [<ffffffff8107574b>] ? irq_exit+0x5b/0xc0
Feb 25 00:55:21 omega kernel: [ 2614.843974]  [<ffffffff81065639>] ? scheduler_ipi+0x69/0x120
Feb 25 00:55:21 omega kernel: [ 2614.843985]  [<ffffffffa034e8bc>] ath_get_rate+0x8c/0x410 [ath9k]
Feb 25 00:55:21 omega kernel: [ 2614.843993]  [<ffffffff8105e97c>] ? update_group_power+0x9c/0x130
Feb 25 00:55:21 omega kernel: [ 2614.844020]  [<ffffffffa02eb7c6>] rate_control_get_rate+0x96/0x170 [mac80211]
Feb 25 00:55:21 omega kernel: [ 2614.844046]  [<ffffffffa02f759f>] invoke_tx_handlers+0x6ff/0x13e0 [mac80211]
Feb 25 00:55:21 omega kernel: [ 2614.844053]  [<ffffffff8105eb81>] ? find_busiest_group+0x171/0xbb0
Feb 25 00:55:21 omega kernel: [ 2614.844071]  [<ffffffffa02d6dac>] ? sta_info_get+0x6c/0x80 [mac80211]
Feb 25 00:55:21 omega kernel: [ 2614.844096]  [<ffffffffa02f83d0>] ieee80211_tx+0x60/0xc0 [mac80211]
Feb 25 00:55:21 omega kernel: [ 2614.844121]  [<ffffffffa02f84b1>] ieee80211_xmit+0x81/0xd0 [mac80211]
Feb 25 00:55:21 omega kernel: [ 2614.844226]  [<ffffffffa02f8b5f>] ieee80211_subif_start_xmit+0x3af/0x9f0 [mac80211]
Feb 25 00:55:21 omega kernel: [ 2614.844238]  [<ffffffff814d4d72>] dev_hard_start_xmit+0x322/0x6e0
Feb 25 00:55:21 omega kernel: [ 2614.844247]  [<ffffffff814f087f>] sch_direct_xmit+0xef/0x1c0
Feb 25 00:55:21 omega kernel: [ 2614.844260]  [<ffffffff814f09f6>] __qdisc_run+0xa6/0x130
Feb 25 00:55:21 omega kernel: [ 2614.844272]  [<ffffffff810e4854>] ? __rcu_process_callbacks+0x54/0x380
Feb 25 00:55:21 omega kernel: [ 2614.844285]  [<ffffffff814d2e83>] net_tx_action+0xe3/0x1f0
Feb 25 00:55:21 omega kernel: [ 2614.844299]  [<ffffffff810964ed>] ? sched_clock_cpu+0xbd/0x110
Feb 25 00:55:21 omega kernel: [ 2614.844312]  [<ffffffff81075378>] __do_softirq+0xb8/0x230
Feb 25 00:55:21 omega kernel: [ 2614.844326]  [<ffffffff815ebfec>] call_softirq+0x1c/0x30
Feb 25 00:55:21 omega kernel: [ 2614.844335]  <EOI>  [<ffffffff81016275>] do_softirq+0x65/0xa0
Feb 25 00:55:21 omega kernel: [ 2614.844355]  [<ffffffff810752b4>] local_bh_enable_ip+0x94/0xa0
Feb 25 00:55:21 omega kernel: [ 2614.844371]  [<ffffffff815e1dd5>] _raw_spin_unlock_bh+0x15/0x20
Feb 25 00:55:21 omega kernel: [ 2614.844388]  [<ffffffffa034a229>] ath_txq_unlock_complete+0x79/0xd0 [ath9k]
Feb 25 00:55:21 omega kernel: [ 2614.844406]  [<ffffffffa034a316>] ath_tx_complete_poll_work+0x96/0xf0 [ath9k]
Feb 25 00:55:21 omega kernel: [ 2614.844434]  [<ffffffffa02dba50>] ? ieee80211_scan_rx+0x1a0/0x1a0 [mac80211]
Feb 25 00:55:21 omega kernel: [ 2614.844453]  [<ffffffffa034a280>] ? ath_txq_unlock_complete+0xd0/0xd0 [ath9k]
Feb 25 00:55:21 omega kernel: [ 2614.844467]  [<ffffffff81089ddd>] process_one_work+0x11d/0x470
Feb 25 00:55:21 omega kernel: [ 2614.844480]  [<ffffffff8108b1df>] worker_thread+0x15f/0x350
Feb 25 00:55:21 omega kernel: [ 2614.844493]  [<ffffffff8108b080>] ? manage_workers+0x230/0x230
Feb 25 00:55:21 omega kernel: [ 2614.844506]  [<ffffffff8108fb9c>] kthread+0x8c/0xa0
Feb 25 00:55:21 omega kernel: [ 2614.844518]  [<ffffffff815ebef4>] kernel_thread_helper+0x4/0x10
Feb 25 00:55:21 omega kernel: [ 2614.844532]  [<ffffffff8108fb10>] ? kthread_worker_fn+0x190/0x190
Feb 25 00:55:21 omega kernel: [ 2614.844545]  [<ffffffff815ebef0>] ? gs_change+0x13/0x13
Feb 25 00:55:21 omega kernel: [ 2614.844554] ---[ end trace a9938f3b69965e8b ]---
Comment 114 Josh Boyer 2012-02-28 12:08:17 EST
*** Bug 798201 has been marked as a duplicate of this bug. ***
Comment 115 Josh Boyer 2012-02-28 12:08:27 EST
*** Bug 798140 has been marked as a duplicate of this bug. ***
Comment 116 Quentin Armitage 2012-03-01 04:01:27 EST
The patch at comment 79 is now incorporated in upstream kernel 3.2.9.

Have downloaded and installed kernel-3.2.9-1 from http://koji.fedoraproject.org/koji/buildinfo?buildID=303856. ath9k device are now working without a problem, whereas without the comment 79 patch, the ath9k devices would not associate with any access points.

Is this bug now resolved?
Comment 117 Mark Lawford 2012-03-01 14:29:57 EST
Just woke up from sleep and connected to wireless network

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 118 gcarter 2012-03-04 22:04:45 EST
Now using Kernel 3.3.-rc6. with the latest tarball from kernel.org.

No signs of trouble yet.  I did not apply your patches.

I will do more thorough testing in the days ahead.

-gc
Comment 119 Josh Boyer 2012-03-06 07:37:57 EST
*** Bug 800248 has been marked as a duplicate of this bug. ***
Comment 120 Josh Boyer 2012-03-06 16:26:26 EST
*** Bug 800651 has been marked as a duplicate of this bug. ***
Comment 121 mikey 2012-03-08 10:45:28 EST
Wireless was enabled but nothing else was happening at the time of the problem.

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 122 Dave Jones 2012-03-08 11:45:55 EST
*** Bug 801272 has been marked as a duplicate of this bug. ***
Comment 123 Travis 2012-03-08 16:41:41 EST
I called a script to back up to an external drive.

Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 124 Tomas Toth 2012-03-09 14:47:08 EST
It seems that the issue is fixed in kernel-3.2.9-2.fc16.x86_64.
I have been running it since Mar 6th, no oops, no panic, works fine.
I updated from bodhi/koji. 
The update should be available in updates-testing now.
Comment 125 Daniel Berns 2012-03-15 13:50:47 EDT
I was editing a text file with gedit, just writing text.
I did no specific operation


Package: kernel
OS Release: Fedora release 16 (Verne)
Comment 126 MyRealName 2012-03-15 15:06:06 EDT
Before this i updated to 3.2.9 kernel, the problem alert bit the speed was too slow, it took more than 1 minute to load a web page.

I updated to 3.2.10-1.fc16.x86_64. Problem free now, but the speed is a bit slow compared to Windows 7, but bearable. Using the same machine, same router.
Comment 127 Dave Jones 2012-03-19 10:25:34 EDT
*** Bug 804137 has been marked as a duplicate of this bug. ***
Comment 128 Dave Jones 2012-03-22 13:09:32 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 129 Dave Jones 2012-03-22 13:12:22 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 130 Dave Jones 2012-03-22 13:21:57 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 131 MyRealName 2012-03-22 17:42:02 EDT
Updated to kernel-3.3.0-4.fc16. Using atheros AR9285. No problems, No warnings. But still, the speed is very very slow.
Comment 132 Tomas Toth 2012-03-24 16:45:18 EDT
kernel 3.3.0-4.fc16.x86_64, uptime 2 days, no issues.
Comment 133 Francesco 2012-03-30 05:29:25 EDT
kernel-3.3.0-4.fc16 x86_64 solve for me the kernel warning but wifi still disconnects. Using Atheros AR9287.

Smolt: http://www.smolts.org/client/show/pub_d75cd421-edb4-4101-9f92-f49606047f35

rilevant dmesg output for an disconnection:

[ 3754.815539] wlan0: moving STA 00:01:36:e2:ea:94 to state 2
[ 3754.815545] wlan0: moving STA 00:01:36:e2:ea:94 to state 1
[ 3754.815550] wlan0: moving STA 00:01:36:e2:ea:94 to state 0
[ 3754.823040] cfg80211: Calling CRDA to update world regulatory domain
[ 3754.840492] cfg80211: World regulatory domain updated:
[ 3754.840498] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 3754.840504] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 3754.840510] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 3754.840516] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 3754.840521] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 3754.840526] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 3754.840546] cfg80211: Calling CRDA for country: IT
[ 3754.846852] cfg80211: Regulatory domain changed to country: IT
[ 3754.846857] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 3754.846864] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 3754.846869] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 3754.846874] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 3754.846879] cfg80211:   (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm)
[ 3756.176145] wlan0: authenticate with 00:01:36:e2:ea:94 (try 1)
[ 3756.178764] wlan0: authenticated
[ 3756.179271] wlan0: associate with 00:01:36:e2:ea:94 (try 1)
[ 3756.378693] wlan0: associate with 00:01:36:e2:ea:94 (try 2)
[ 3756.578567] wlan0: associate with 00:01:36:e2:ea:94 (try 3)
[ 3756.778437] wlan0: association with 00:01:36:e2:ea:94 timed out
[ 3762.723410] wlan0: authenticate with 00:01:36:e2:ea:94 (try 1)
[ 3762.725514] wlan0: authenticated
[ 3762.725800] wlan0: associate with 00:01:36:e2:ea:94 (try 1)
[ 3762.925822] wlan0: associate with 00:01:36:e2:ea:94 (try 2)
[ 3763.125799] wlan0: associate with 00:01:36:e2:ea:94 (try 3)
[ 3763.325717] wlan0: association with 00:01:36:e2:ea:94 timed out
[ 3769.270646] wlan0: authenticate with 00:01:36:e2:ea:94 (try 1)
[ 3769.272862] wlan0: authenticated
[ 3769.273191] wlan0: associate with 00:01:36:e2:ea:94 (try 1)
[ 3769.473083] wlan0: associate with 00:01:36:e2:ea:94 (try 2)
[ 3769.672916] wlan0: associate with 00:01:36:e2:ea:94 (try 3)
[ 3769.872830] wlan0: association with 00:01:36:e2:ea:94 timed out

For reconnect: 

# systemctl restart NetworkManager.service

Note You need to log in before you can comment on or make changes to this bug.