Bug 801312 - webob deprecation warnings
webob deprecation warnings
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python-webob (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Runge
Fedora Extras Quality Assurance
:
: 892934 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-08 04:33 EST by Mark McLoughlin
Modified: 2013-01-19 21:56 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-19 21:56:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2012-03-08 04:33:20 EST
Seeing lots of this spewed in /var/log/messages:

Mar  8 09:30:28 zig keystone-all[20646]: /usr/lib/python2.7/site-packages/webob/dec.py:142: DeprecationWarning: Response.request and Response.environ are deprecated
Mar  8 09:30:28 zig keystone-all[20646]: req.response.request = req
Comment 1 Pádraig Brady 2012-03-08 07:15:03 EST
Though not directly related to the above, it's worth noting new deprecation introduced in webob 1.2

https://lists.launchpad.net/openstack/msg08387.html
Comment 2 Alan Pevec 2012-03-08 08:57:33 EST
Also worth nothing for EPEL6:
https://lists.launchpad.net/openstack/msg08387.html
" Since Python < 2.7 does not ignore DeprecationWarning, and I am running on Python 2.6, the warnings are being thrown as exceptions."
Comment 3 Alan Pevec 2012-03-09 06:44:14 EST
(In reply to comment #2)
> " Since Python < 2.7 does not ignore DeprecationWarning, and I am running on
> Python 2.6, the warnings are being thrown as exceptions."

False alarm: that was webob 1.2 throwing exceptions, not python version difference https://lists.launchpad.net/openstack/msg08416.html
Comment 4 Fedora Admin XMLRPC Client 2012-05-22 13:34:19 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Alan Pevec 2012-06-22 12:22:29 EDT
(In reply to comment #0)
> /usr/lib/python2.7/site-packages/webob/dec.py:142: DeprecationWarning:
> Response.request and Response.environ are deprecated
> req.response.request = req

But that's webob code using own deprecated stuff, not Keystone, moving component to WebOb for further discussion.
Comment 6 Dan Prince 2012-12-04 12:54:20 EST
AFAIK this issue still stands on Fedora 17 (or any distro using webob 1.1).

From the webob docs:

http://docs.webob.org/en/latest/news.html

webob 1.1.1:

 Deprecate Response.request and Response.environ attrs.

Furthermore it looks like this has been reversed in webob 1.2a1+:

 Response.request and .environ attrs are deprecated and raise exceptions when used.

-----

This issue could be really annoying in a production deployment of OpenStack because keystone is such a central component. This deprecation warning gets logged into /var/log/messages and I can see it exhausting disk space quite easily.
Comment 7 Matthias Runge 2013-01-08 06:48:31 EST
*** Bug 892934 has been marked as a duplicate of this bug. ***
Comment 8 Alan Pevec 2013-01-08 08:23:34 EST
Patch proposed by Matthias in bug 892934 taken that from webob-1.2.3

--- dec.py.bak	2013-01-08 12:43:24.945513816 +0100
+++ dec.py	2013-01-08 12:43:38.826463501 +0100
@@ -139,7 +139,6 @@
             start_response = args[0]
             req = self.RequestClass(environ)
             req.response = req.ResponseClass()
-            req.response.request = req
             try:
                 args = self.args
                 if self.middleware_wraps:


Ricky, do you mind carrying that patch in f18 rpm?
Would you consider to update webob to 1.2.3 in f19 and f18?
Comment 9 Pádraig Brady 2013-01-08 08:32:51 EST
Note f17 probably should be updated along with f18 for consistency.

Note also that updating to 1.2.3 is a bit complicated as we currently have:

          F16 F17 F18 F19 EL5 EL6 RHEL6
webob-0.9                  *        *
webob-1.0  *
webob-1.1      *    *   *
webob1.0                       *
webob1.2       *        *      * 

I've asked rbean about consolidating some of these in Fedora at least.
Comment 10 Alan Pevec 2013-01-08 09:57:24 EST
Clearing needinfo, I got response from Luke Macken:

> We use WebOb within the TurboGears2 and Pyramid web stacks, as well
> as a variety of other packages:
>     https://apps.fedoraproject.org/packages/python-webob/relationships/required_by/
> 
> TurboGears2 currently requires 'WebOb <= 1.1.1'
> Pyramid requires 'WebOb >= 1.2b3', # request.path_info is unicode
> 
> There is a forward compat python-webob1.2 in Fedora & EPEL that
> currently provides python-webob1.2-1.2.1
> 
> It feels like we should eventually flip this around so that python-webob
> provides the latest and we have backward-compat packages for things like
> TG2, but in the mean time you could probably update the
> python-webob1.2 package to 1.2.3 without any issues.
> 
> luke
Comment 11 Fedora Update System 2013-01-09 05:16:48 EST
python-webob-1.1.1-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-webob-1.1.1-4.fc18
Comment 12 Fedora Update System 2013-01-09 17:51:00 EST
Package python-webob-1.1.1-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-webob-1.1.1-4.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-0513/python-webob-1.1.1-4.fc18
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2013-01-19 21:56:41 EST
python-webob-1.1.1-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.