Bug 801378 - squid no more working with IP in URL
squid no more working with IP in URL
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: squid (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jiri Skala
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-08 07:02 EST by Joachim Jaeckel
Modified: 2014-11-09 17:35 EST (History)
4 users (show)

See Also:
Fixed In Version: squid-3.2.0.16-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-24 19:19:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
squid.conf (1.83 KB, application/download)
2012-03-08 07:02 EST, Joachim Jaeckel
no flags Details

  None (edit)
Description Joachim Jaeckel 2012-03-08 07:02:52 EST
Created attachment 568608 [details]
squid.conf

Description of problem:
Clients cannot access URL with IP in it. Clients get timeout.
Example: http://62.157.61.206/
Same problem with https.


Version-Release number of selected component (if applicable):
squid-3.2.0.15-1.fc16.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Timout


Expected results:
Web Page


Additional info:
Nameserver bind-9.8.2-0.2.rc1.fc16.x86_64 running on the same host.
tcpdump shows:
squid does a reverse lookup for the ip address and gets an answer from the nameserver. squid does not try to open a connection to the requested IP.

squid access log shows (failing squid version):
1331159595.194  50524 192.168.0.2 NONE_ABORTED/000 0 GET http://62.157.61.206/ - HIER_NONE/- -
1331205455.638  75060 192.168.0.2 TCP_MISS/200 0 CONNECT 193.109.238.27:443 - HIER_DIRECT/193.109.238.27 -

I reinstalled my last working version squid-3.2.0.13

squid access log shows (working squid version):
1331160462.322      2 192.168.0.2 TCP_MISS/403 290 GET http://62.157.61.206/ - HIER_DIRECT/62.157.61.206 text/html
1331206068.202   2027 192.168.0.2 TCP_MISS/200 4045 CONNECT 193.109.238.26:443 - HIER_DIRECT/193.109.238.26 -

Attached: squid.conf


Affected version:
squid-3.2.0.15-1.fc16.x86_64
Working version:
squid-3.2.0.13-5.fc16.x86_64
Comment 1 Joachim Jaeckel 2012-03-11 09:57:06 EDT
Solved in
squid-3.2.0.16-1.fc16.x86_64.rpm
(loaded from fedora 16 repo updates-testing)
Comment 2 Joachim Jaeckel 2012-03-11 10:15:44 EDT
Seems to be
  http://bugs.squid-cache.org/show_bug.cgi?id=3503
  Bug 3503 - DNS PTR queries timeout due to wrong QIDs 
  Status: 	RESOLVED FIXED

Maybe you wait until squid-3.2.0.16-1.fc16 is released to updates repo.
Bug can be closed.
Comment 3 Fedora Update System 2012-03-11 23:44:46 EDT
squid-3.2.0.16-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-3415/squid-3.2.0.16-1.fc16
Comment 4 Fedora Update System 2012-03-24 19:19:46 EDT
squid-3.2.0.16-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.