This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 801517 - [ALL LANG][RHSM GUI] 'Fetching certificates' is not localized when register system with automatically subscribing to the most appropriate subscriptions .
[ALL LANG][RHSM GUI] 'Fetching certificates' is not localized when register s...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.3
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: Bryan Kearney
Entitlement Bugs
: Translation
Depends On:
Blocks: 738066 781266
  Show dependency treegraph
 
Reported: 2012-03-08 12:50 EST by Bryan Kearney
Modified: 2012-06-20 09:06 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 781266
Environment:
Last Closed: 2012-06-20 09:06:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bryan Kearney 2012-03-08 12:50:39 EST
+++ This bug was initially created as a clone of Bug #781266 +++

Description of problem:
'Fetching certificates' is not localized when register system with automatically subscribing to the most appropriate subscriptions 

Version-Release number of selected component (if applicable):
subscription-manager-0.98.10-1.el5


How reproducible:
100%

Steps to Reproduce:
1. Install rhel5.8 snapshot-3 OS build via
http://download.englab.nay.redhat.com/pub/rhel/rel-eng/RHEL5.8-Server-20120105.0/5/i386/os/

2.On the Subscription Manager main window, click Register button. Input RHN account and password,  select 'select the most appropriate subscriptions for this system' option.

3. Click Register button.
  
Actual results:
'Fetching certificates' is not localized when register system with automatically subscribing to the most appropriate subscriptions 

Expected results:
It should be localized.


Additional info:

--- Additional comment from lijli@redhat.com on 2012-01-13 01:03:04 EST ---

Created attachment 554987 [details]
'Fetching certificates' is not localized
Comment 1 Bryan Kearney 2012-03-09 12:30:03 EST
Patch sent to the list.
Comment 2 Bryan Kearney 2012-03-12 18:19:46 EDT
fixed in master at 3affeb51d8b9353a1e6d6aa3757dabbeeec805bb.
Comment 5 John Sefler 2012-04-10 15:16:23 EDT
Note, this bug was cloned from a rhel58 bug were the string "Fetching certificates" was never externalized (as demonstrated here...)

[root@ibm-z10-27 ~]# rpm -q subscription-manager-gnome
subscription-manager-gnome-0.98.14-1.el5

[root@ibm-z10-27 ~]# grep -r Fetching /usr/share/rhsm/subscription_manager/gui/*.py
/usr/share/rhsm/subscription_manager/gui/registergui.py:        self._set_register_details_label(_("Fetching list of possible organizations"))
/usr/share/rhsm/subscription_manager/gui/registergui.py:        self._set_register_details_label("Fetching certificates")
[root@ibm-z10-27 ~]# msgunfmt /usr/share/locale/ja/LC_MESSAGES/rhsm.mo | grep Fetching -A1
msgid "Fetching list of possible organizations"
msgstr "可能性のある組織の一覧の取り込み"
[root@ibm-z10-27 ~]# 

^^^ NOTICE HERE THAT "Fetching list of possible organizations" WAS EXTERNALIZED FOR TRANSLATION, BUT "Fetching certificates" WAS NOT EXTERNALIZED FOR TRANSLATION.


Now in the current subscription-manager-gnome package targeted for rhel63 release, you will see that this string has been completely removed thereby making this bug not applicable to rhel63....

[root@jsefler-r63-server ~]# rpm -q subscription-manager-gnome
subscription-manager-gnome-0.99.13-1.el6.x86_64

[root@jsefler-r63-server ~]# grep -r Fetching /usr/share/rhsm/subscription_manager/gui/*.py
/usr/share/rhsm/subscription_manager/gui/registergui.py:        self._set_register_details_label(_("Fetching list of possible organizations"))
[root@jsefler-r63-server ~]# msgunfmt /usr/share/locale/ja/LC_MESSAGES/rhsm.mo | grep Fetching -A1
msgid "Fetching list of possible organizations"
msgstr "可能性のある組織の一覧の取り込み"
[root@jsefler-r63-server ~]# 

^^^ HERE YOU WILL NOTICE THAT "Fetching list of possible organizations" CONTINUES TO EXIST AND IS EXTERNALIZED FOR TRANSLATION, BUT "Fetching certificates" IS NO LONGER USED.  IT HAS BEEN ELIMINATED.

Moving to VERIFIED that "Fetching certificates" has been entirely eliminated.
Comment 7 errata-xmlrpc 2012-06-20 09:06:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0804.html

Note You need to log in before you can comment on or make changes to this bug.