Bug 801685 - horizon: no VNC console
horizon: no VNC console
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: python-django-horizon (Show other bugs)
el6
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Pádraig Brady
Fedora Extras Quality Assurance
:
Depends On: 822182 822187
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-09 01:57 EST by Mark McLoughlin
Modified: 2016-01-04 09:45 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-19 05:03:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2012-03-09 01:57:08 EST
In the "Instance Detail" page, the VNC tab doesn't work

There's more to this than horizon work, so we should break down what's needed into individual bugs and turn this into a tracker bug
Comment 1 Mark McLoughlin 2012-05-11 05:33:14 EDT
Adam is working on packaging novnc:

  http://lists.fedoraproject.org/pipermail/cloud/2012-April/001385.html
  http://lists.fedoraproject.org/pipermail/cloud/2012-April/001398.html
  http://lists.fedoraproject.org/pipermail/cloud/2012-May/001438.html

I'm not clear whether just packaging novnc is all that's needed, or whether more will be required?

Adam - could you summarise the plan/status for this bug?
Comment 2 Adam Young 2012-05-11 08:57:17 EDT
There will be two Source RPMS and three RPMS in the final product.  They all come from the same upstream developer.

From https://github.com/kanaka/websockify  there will be python-websockify
From https://github.com/kanaka/noVNC  there will be python-novnc-server and novnc-common.  The server will have Python code and will depend on the other two packages.  novnc-common will have the Javascript client and should be deployable with other webservers.

Short term we ship this.  I'm trying to get the files reorganized upstream to a configuration compatable with the Fedora packaging standards,  but if it takes too long,  I will apply  patches to restructure the code.

There might need to be a change to the init script to start the server as well, as the current one,  in the nova-novnc package, does not map to how novnc is started.  Either I will get it to work by patching python-novnc-server,  or I'll submit a new init script to the nova package. 


Long term,  websockets should be run out of the Apache server just like the rest of the code,  but that is beyond the Folsom timeframe.

I should have something runnable/reviewable next week.
Comment 3 Jan van Eldik 2012-05-11 09:12:49 EDT
Hi Adam,

Do you think the "short term packages" will work on RHEL6 and F16 as well?
Should I open separate BZ's for that?

     thanks for your efforts, cheers, Jan
Comment 4 Adam Young 2012-05-11 09:31:49 EDT
I think the SPEC file will be identical for both.  Keep it as one BZ for now, and we can clone if it proves to be necessary.
Comment 5 Jose Castro Leon 2012-06-01 09:36:58 EDT
I am not sure it should be here or on BZ#822187

I installed the package in a cloud controller and it seems that there is a issue when using websockify rpm. It fails to start because a missing dependency. I found that needs wsproxy python module. Solved if you modify it like this

diff /usr/bin/nova-novncproxy.nopatch /usr/bin/nova-novncproxy
29c29
< import wsproxy
---
> import websockify as wsproxy


BTW in the RPM, I think that it need a way to start this service as it is on openstack in other distributions

/lib/systemd/system/openstack-nova-novncproxy.service
[Unit]
Description=OpenStack Nova NoVNC Proxy Server
After=syslog.target network.target

[Service]
Type=simple
User=nova
ExecStart=/usr/bin/nova-novncproxy --flagfile=/etc/nova/nova.conf --web /usr/share/novnc/

[Install]
WantedBy=multi-user.target
Comment 6 Adam Young 2012-06-11 10:09:13 EDT
Packaging work is here for noVNC
https://bugzilla.redhat.com/show_bug.cgi?id=822187

Depends on Webscokify which has been completed.
https://bugzilla.redhat.com/show_bug.cgi?id=822182
Comment 7 Pádraig Brady 2012-06-18 17:34:39 EDT
Reassigning to EPEL as this is where the testing is mainly taken place.
Should have the same Essex logic as Fedora 17

Karma on these would be appreciated:

https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-6179/novnc-0.3-10.el6
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-6138/python-websockify-0.1.0-5.el6

Note You need to log in before you can comment on or make changes to this bug.