Bug 801711 - file -z doesn't uncompress bzip2 archives
Summary: file -z doesn't uncompress bzip2 archives
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: file
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Jan Kaluža
QA Contact: Karel Srot
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 847936
TreeView+ depends on / blocked
 
Reported: 2012-03-09 08:56 UTC by Karel Srot
Modified: 2012-10-08 15:46 UTC (History)
1 user (show)

(edit)
Cause: Because of bad condition in File code, File used read timeout when decompressing files using file -z parameter.
Consequence: File was not able to detect files compressed by bzip2.
Fix: Bad condition has been fixed and file now doesn't use timeout when decompressing compressed files.
Result: File now detects compressed file when using -z parameter as expected.
Clone Of:
: 847936 881789 (view as bug list)
(edit)
Last Closed: 2012-10-04 12:21:35 UTC


Attachments (Terms of Use)
proposed patch (445 bytes, patch)
2012-08-07 06:32 UTC, Jan Kaluža
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1339 normal SHIPPED_LIVE file bug fix update 2012-10-04 16:15:20 UTC

Description Karel Srot 2012-03-09 08:56:09 UTC
Description of problem:

on RHEL6 file -z cannot extract bzip2 archives when using -z option

file-5.04-6.el6.x86_64
$ file -z gfs1partition.bz2 
gfs1partition.bz2: data (bzip2 compressed data, block size = 900k)

this is working on RHEL5:

file-4.17-20
:: [   PASS   ] :: Running 'file -z gfs1partition.bz2 &> log1'
gfs1partition.bz2: Linux GFS1 Filesystem (blocksize 4096, lockproto lock_nolock) (bzip2 compressed data, block size = 900k)

Comment 1 Karel Srot 2012-03-09 10:35:18 UTC
also tested with file-5.04-11.el6 and file-5.04-13.el6, still not working.

Comment 2 Jan Kaluža 2012-03-09 11:32:20 UTC
It's bug file-5.x branch caused by addition of built-in zlib decompressing support.

Comment 3 Jan Kaluža 2012-08-07 06:32:29 UTC
Created attachment 602653 [details]
proposed patch

Comment 4 Jan Kaluža 2012-08-07 06:35:11 UTC
Upstream bug report: http://bugs.gw.com/view.php?id=192

Comment 8 Jan Kaluža 2012-08-14 07:37:54 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: Because of bad condition in File code, File used read timeout when decompressing files using file -z parameter.
Consequence: File was not able to detect files compressed by bzip2.
Fix: Bad condition has been fixed and file now doesn't use timeout when decompressing compressed files.
Result: File now detects compressed file when using -z parameter as expected.

Comment 12 errata-xmlrpc 2012-10-04 12:21:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1339.html


Note You need to log in before you can comment on or make changes to this bug.