Bug 802041 - boot.fedoraproject.org (BFO) don't install Fedora 17 Alpha
boot.fedoraproject.org (BFO) don't install Fedora 17 Alpha
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gpxe (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-10 08:58 EST by Pavel Šimerda (pavlix)
Modified: 2012-03-19 18:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-19 18:21:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Šimerda (pavlix) 2012-03-10 08:58:18 EST
There is no Fedora 17 Alpha menu item in boot.fedoraproject.org. There is, however, a PRE-RELEASE Fedora 17 menu item that boots to an installation
system.

But this pre-release version failes probably when scanning disks (I have MBR and LVM with several partitions including a CentOS root filesystem). Anaconda lets me
open Pdb that says it fails in the versionMatches() function on line that converts
a part of the version info to string. I couldn't take a snap because my camera battery was dead.

I believe the problem is that this „pre-release“ installer is older than current Alpha and only needs to be replaced by F17 Alpha (and properly labeled so that people know what it actually is).
Comment 1 Pavel Šimerda (pavlix) 2012-03-10 09:03:54 EST
http://fedoraproject.org/en/get-prerelease links to http://boot.fedoraproject.org/ to boot Fedora 17 Alpha by network, even though BFO lacks the F17 Alpha menu item.
Comment 2 Pavel Šimerda (pavlix) 2012-03-10 17:23:16 EST
I regret to confirm that proper F17 netboot with proper kernel, initrd and squashfs from test/17-Alpha fail the same way on x86_64 machine with CentOS 6 in LVM in DOS partition table already installed. The problem seems to be related to search for upgradable systems.

Unfortunately, on an empty disk, the x86_64 kernel fails with something like:

swapper/0 Not tainted 3.3.0-0.rc3.git7.2.fc17.x86_64

And with i386 it fails later when choosing network interfaces. The bad thing is that the installer lets me choose the wired ethernet device and then lets me choose from wireless networks (it scans them instead of just ignoring
wireless at all).

Somewhere on the way I also got HDIO_GET_IDENTITY failed (when using USB-to-IDE cable to install on a USB disk). But I only have handwritten notes, so I don't know the exact circumstances.
Comment 3 Pavel Šimerda (pavlix) 2012-03-10 17:29:29 EST

*** This bug has been marked as a duplicate of bug 802042 ***
Comment 4 Pavel Šimerda (pavlix) 2012-03-10 17:32:30 EST
I'm sorry for the confusion. If you realise BFO's PRE-RELEASE is actually different from F17 Alpha, please reopen.
Comment 5 Pavel Šimerda (pavlix) 2012-03-10 17:46:58 EST
So... I changed back the summary, this bugreport is about BFO not booting
Fedora Installer because of the version check.
Comment 6 Adam Williamson 2012-03-12 17:39:36 EDT
It would help if you could get the actual traceback from the crash; it seems pretty difficult to tell what the problem actually is from the information posted so far.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Pavel Šimerda (pavlix) 2012-03-12 17:47:46 EDT
I don't know how to get and save the traceback from pdb. IMO the code that checks versions of installed systems just converts non-number to float.
Comment 8 Daniel Berrange 2012-03-19 18:21:43 EDT
Unfortunately this is not the right place for this kind of request. You need to file a ticket with the Fedora Infrastructure team:

https://fedorahosted.org/fedora-infrastructure/

Note You need to log in before you can comment on or make changes to this bug.