Bug 802042 - Fedora 17 Alpha Installation doesn't boot from pxeboot/vmlinuz and pxeboot/initrd.img
Fedora 17 Alpha Installation doesn't boot from pxeboot/vmlinuz and pxeboot/in...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-10 09:05 EST by Pavel Šimerda (pavlix)
Modified: 2013-02-04 14:00 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-04 14:00:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pavel Šimerda (pavlix) 2012-03-10 09:05:39 EST
I used to boot Fedora 16 Installation from network, either through boot.fedoraproject.org (BFO) or through my own boot server referencing
vmlinuz and initrd.img on a Fedora mirror.

For Fedora 17 Alpha it no longer works, dracut fails:

No or empty root=

It seems boot.fedoraproject.org has some pre-release F17 installation option
but it doesn't seem to be F17 Alpha and it doesn't work for me (bug 802041). But
it uses more than just kernel and initrd and it seems to be referencing a squashfs file system in “os/LiveOS/squashfs.img” directory. But there's no README
about it in “os/images/pxeboot” and BFO sources and configuration are AFAIK not available (bug 802031).

I'll report about the workaround of setting the root option in a manner similar
to what BFO's pre-release F17 does.
Comment 1 Pavel Šimerda (pavlix) 2012-03-10 17:29:05 EST
 regret to confirm that proper F17 netboot with proper kernel, initrd and
squashfs from test/17-Alpha fail the same way on x86_64 machine with CentOS 6
in LVM in DOS partition table already installed. The problem seems to be
related to search for upgradable systems.

Unfortunately, on an empty disk, the x86_64 kernel fails with something like:

swapper/0 Not tainted 3.3.0-0.rc3.git7.2.fc17.x86_64

And with i386 it fails later when choosing network interfaces. The bad thing is
that the installer lets me choose the wired ethernet device and then lets me
choose from wireless networks (it scans them instead of just ignoring
wireless at all).

Somewhere on the way I also got HDIO_GET_IDENTITY failed (when using USB-to-IDE
cable to install on a USB disk). But I only have handwritten notes, so I don't
know the exact circumstances.
Comment 2 Pavel Šimerda (pavlix) 2012-03-10 17:29:29 EST
*** Bug 802041 has been marked as a duplicate of this bug. ***
Comment 4 Pavel Šimerda (pavlix) 2012-03-10 17:39:11 EST
By the way, who thinks LiveOS/squashfs.img is a good name for the installer image?
Comment 5 Bill Nottingham 2012-03-12 11:19:27 EDT
Moving to lorax, as it creates these structures.
Comment 6 Pete Travis 2012-03-21 02:40:06 EDT
These structures are all working:

LABEL Fedora with NFS exported ISO
      kernel release-export/vmlinuz
      append initrd=release-export/initrd.img inst.repo=nfs:10.0.1.16:/var/exports/fedora/install/F17-x86_64

LABEL Fedora with NFS Repo and http Kickstart
      kernel release-export/vmlinuz
      append initrd=release-export/initrd.img inst.ks=http://10.0.1.16:/cobbler/aux/ks-basic.cfg repo=nfs:10.0.1.16:/var/exports/fedora/install/\
F17-x86_64

LABEL Fedora Basic Netinstall, Using fp.o repo
      kernel release-export/vmlinuz
      append initrd=release-export/initrd.img root=live:http://10.0.1.16/cobbler/aux/squashfs.img

LABEL Fedora VNC attended Install 
      kernel release-export/vmlinuz
      append initrd=release-export/initrd.img root=live:http://10.0.1.16/cobbler/aux/squashfs.img inst.vnc inst.vncconnect=10.0.1.100:5500 inst.\
ks=http://10.0.1.16:/var/exports/fedora/ks/ks-autopart.cfg


As this bug appears to be on the options build into the release media, not the product itself, I will add that root=live:nfs:server:/path works now on TC2 and ks=nfs:server:/path does not appear to be functioning. Please advise if this is a non issue or a seperate issue.


I'm tracking this for inclusion in the release notes, and it would be nice to have some clarification. If anaconda needs the root image, I don't see the 'fix' for this bug other than to advise users to provide it.
Comment 7 Will Woods 2012-06-02 12:32:05 EDT
(In reply to comment #4)
> By the way, who thinks LiveOS/squashfs.img is a good name for the installer
> image?

dracut requires that path/name, so that's what we're using. When dracut can take arbitrary path/names for the runtime image, we'll go back to using images/install.img.
Comment 8 Will Woods 2012-06-02 13:04:22 EDT
(In reply to comment #6)

> As this bug appears to be on the options build into the release media, not
> the product itself, I will add that root=live:nfs:server:/path works now on
> TC2 and ks=nfs:server:/path does not appear to be functioning. Please advise
> if this is a non issue or a seperate issue.

ks=nfs:server:/path should work; file a bug if it doesn't.

> I'm tracking this for inclusion in the release notes, and it would be nice
> to have some clarification. If anaconda needs the root image, I don't see
> the 'fix' for this bug other than to advise users to provide it.

Yes, unless there is installer media in the CDROM drive, one of root=XXX, repo=XXX, or stage2=XXX is required. This is roughly the same behavior as in Fedora 14 and earlier.

We're updating the documentation for anaconda's boot options for Fedora 17. A draft can be found here:

  http://wwoods.fedorapeople.org/doc/boot-options.html
Comment 9 Fedora Admin XMLRPC Client 2013-02-04 10:06:55 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Note You need to log in before you can comment on or make changes to this bug.