This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 802052 - Enable ibus-indicator@example.com extension -> Enable or disable doesn't work with Hangul Key
Enable ibus-indicator@example.com extension -> Enable or disable doesn't wor...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
: 802054 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-10 10:14 EST by sangu
Modified: 2012-05-06 00:55 EDT (History)
4 users (show)

See Also:
Fixed In Version: ibus-1.4.99.20120428-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-06 00:55:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description sangu 2012-03-10 10:14:11 EST
Description of problem:
Enable ibus-indicator@example.com extension ->  Enable or disable shortkey doesn't work with  Hangul Key 

Version-Release number of selected component (if applicable):
1.4.99.20120304-3.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1. gsettings set org.gnome.shell enabled-extensions "['ibus-indicator@example.com']"

2. gnome-shell restart
3. Click Hangul Key
  
Actual results:


Expected results:


Additional info:
After disable ibus-indicator@example.com extension -> Hangul Key works well.
Comment 1 fujiwara 2012-03-13 23:08:48 EDT
As you may notice, GTK ibus icon provides Hangul hotkey on ko locale.
But the shell ibus icon doesn't work with Hangul hotkey because it seems mutter keybinding requires a modifier key likes Control.
So I added a workaround in GTK ibus icon only.

Probably this would be difficult to be fixed in F17 release since it's handled out of ibus. We need to fix mutter.

The current workaround is to use GTK ibus icon unfortunately.
Comment 2 fujiwara 2012-03-13 23:14:17 EDT
*** Bug 802054 has been marked as a duplicate of this bug. ***
Comment 3 fujiwara 2012-04-24 06:15:42 EDT
I investigated this issue. It seems meta_display_add_keybinding() works with one short cut key only but I bus supports multiple shortcut keys.
If I assigned Zenkaku_Hankaku only on ibus-setup and removed the shift reverse, I could use Zenkaku_Hankaku key with gnome-shell.

The following is the suggested fix:
https://github.com/fujiwarat/ibus-gjs/commit/ae5767b24395147d3f29a9945cddb512d1ac6de3
Comment 4 Fedora Update System 2012-04-28 04:07:11 EDT
ibus-1.4.99.20120428-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-1.4.99.20120428-1.fc17
Comment 5 Fedora Update System 2012-04-28 13:11:26 EDT
Package ibus-1.4.99.20120428-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.4.99.20120428-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6889/ibus-1.4.99.20120428-1.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-05-06 00:55:08 EDT
ibus-1.4.99.20120428-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.