Bug 802054 - Needless Second Korean Input Method.
Needless Second Korean Input Method.
Status: CLOSED DUPLICATE of bug 802052
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-10 10:27 EST by sangu
Modified: 2012-03-14 01:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-13 23:14:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
in ibus-setup (37.99 KB, image/png)
2012-03-10 10:27 EST, sangu
no flags Details

  None (edit)
Description sangu 2012-03-10 10:27:17 EST
Created attachment 569094 [details]
in ibus-setup

Description of problem:
Needless Second Korean Input Method.

Version-Release number of selected component (if applicable):
1.4.99.20120304-3.fc17.x86_64

How reproducible:
always

Steps to Reproduce:
1. ctrl + space 
2. 
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 fujiwara 2012-03-13 23:14:17 EDT
Since bug 802052 is not fixed, I cannot remove Control+Space for Korean.
At the moment, I close this bug as duplicated of 802052.

If you use GTK ibus icon only, the workaround is to modify dconf editor directly (bug 795082).
1. Invoke dconf-editor
2. Change /desktop/ibus/general/hotkey/trigger-accel from '<Control>space' to 'Hangul'.
3. Restart ibus-daemon

But once this modification is applied, you won't be able to switch ibus engines on shell due to bug 802052.

I will enhance the GUI with bug 795082.

*** This bug has been marked as a duplicate of bug 802052 ***
Comment 2 sangu 2012-03-14 01:31:17 EDT
Thanks your reply.

I don't understand Input method switch system in current ibus.
ctrlspace window is complicated as only hangul & eng input method user.


Addtional information
A few keyboard doesn't have Hangul key.
Shift + space is de facto standard in Korean.
Comment 3 fujiwara 2012-03-14 01:45:51 EDT
BTW, normally I swap Control for CapsLock in US keyboard using 'gnome-control-center region'.

Note You need to log in before you can comment on or make changes to this bug.