Bug 802055 - /etc/init.d/network buggy (initscripts-9.34.1-1.fc16.x86_64)
/etc/init.d/network buggy (initscripts-9.34.1-1.fc16.x86_64)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
16
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
: 802134 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-10 10:30 EST by Harald Reindl
Modified: 2014-03-16 23:30 EDT (History)
8 users (show)

See Also:
Fixed In Version: initscripts-9.37-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-14 22:22:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix typos (1.10 KB, patch)
2012-03-12 06:18 EDT, Lubos Stanek
no flags Details | Diff

  None (edit)
Description Harald Reindl 2012-03-10 10:30:43 EST
something is broken in /etc/init.d/network
first my (minimal) obfuscated configuration

last block are strange error-messages from /var/log/messages
after "systemctl restart network.service" or "service network restart"
_________________________________________________

[root@testserver:~]$ cat /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
IPADDR=**********
GATEWAY=**********
NETMASK=255.255.255.0
ONBOOT=yes
BOOTPROTO=static
TYPE=Ethernet
MODE=Managed
IPV6INIT=no
NM_CONTROLLED=no
USERCTL=no
MTU=1500

[root@testserver:~]$ cat /etc/sysconfig/network-scripts/ifcfg-eth1
DEVICE=eth1
IPADDR=**********
NETMASK=255.255.255.0
ONBOOT=yes
BOOTPROTO=static
TYPE=Ethernet
MODE=Managed
IPV6INIT=no
NM_CONTROLLED=no
USERCTL=no
MTU=1500
_________________________________________________

eth0      Link encap:Ethernet  Hardware Adresse 00:0C:29:76:12:E9
          inet Adresse:**********  Bcast:**********  Maske:255.255.255.0
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:10227 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1919 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:753725 (736.0 KiB)  TX bytes:1128945 (1.0 MiB)

eth1      Link encap:Ethernet  Hardware Adresse 00:0C:29:AC:D9:D0
          inet Adresse:**********  Bcast:**********  Maske:255.255.255.0
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:40 errors:0 dropped:0 overruns:0 frame:0
          TX packets:45 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000
          RX bytes:2932 (2.8 KiB)  TX bytes:8905 (8.6 KiB)
_________________________________________________

Mar 10 13:20:41 testserver network[2453]: Schnittstelle eth0 beenden:  ./ifdown: Zeile 64: [: x: Zweistelliger
(binärer) Operator erwartet.
Mar 10 13:20:41 testserver network[2453]: [  OK  ]
Mar 10 13:20:41 testserver network[2453]: Schnittstelle eth1 beenden:  ./ifdown: Zeile 64: [: x: Zweistelliger
(binärer) Operator erwartet.
Mar 10 13:20:41 testserver network[2453]: [  OK  ]
Mar 10 13:20:41 testserver network[2453]: Loopback-Schnittstelle beenden:  ./ifdown: Zeile 64: [: x: Zweistelliger
(binärer) Operator erwartet.
Mar 10 13:20:41 testserver network[2453]: ./ifdown: Zeile 68: /etc/sysconfig/network-scripts/ifdown-: Datei oder
Verzeichnis nicht gefunden
Mar 10 13:20:41 testserver network[2453]: [FEHLGESCHLAGEN]
Mar 10 13:20:41 testserver network[2586]: Loopback-Schnittstelle hochfahren:  ./ifup: Zeile 145: [: x:
Zweistelliger (binärer) Operator erwartet.
Mar 10 13:20:41 testserver network[2586]: ./ifup: Zeile 149: /etc/sysconfig/network-scripts/ifup-: Datei oder
Verzeichnis nicht gefunden
Mar 10 13:20:41 testserver network[2586]: [FEHLGESCHLAGEN]
Mar 10 13:20:41 testserver network[2586]: Schnittstelle eth0 hochfahren:  ./ifup: Zeile 145: [: x: Zweistelliger
(binärer) Operator erwartet.
Mar 10 13:20:41 testserver kernel: eth0: intr type 3, mode 0, 5 vectors allocated
Mar 10 13:20:41 testserver kernel: eth0: NIC Link is Up 10000 Mbps
Mar 10 13:20:43 testserver network[2586]: [  OK  ]
Mar 10 13:20:43 testserver network[2586]: Schnittstelle eth1 hochfahren:  ./ifup: Zeile 145: [: x: Zweistelliger
(binärer) Operator erwartet.
Mar 10 13:20:43 testserver kernel: eth1: intr type 3, mode 0, 5 vectors allocated
Mar 10 13:20:43 testserver kernel: eth1: NIC Link is Up 10000 Mbps
Mar 10 13:20:45 testserver network[2586]: [  OK  ]
Mar 10 13:20:45 testserver network[2586]: RTNETLINK answers: File exists
Mar 10 13:20:45 testserver network[2586]: RTNETLINK answers: File exists
Mar 10 13:20:45 testserver network[2586]: RTNETLINK answers: File exists
Mar 10 13:20:45 testserver network[2586]: RTNETLINK answers: File exists
Mar 10 13:20:45 testserver network[2586]: RTNETLINK answers: File exists
Mar 10 13:20:45 testserver network[2586]: RTNETLINK answers: File exists
Mar 10 13:20:45 testserver network[2586]: RTNETLINK answers: File exists
Mar 10 13:20:45 testserver network[2586]: RTNETLINK answers: File exists
Mar 10 13:20:45 testserver network[2586]: RTNETLINK answers: File exists
Comment 1 Frank Murphy 2012-03-11 12:51:56 EDT
Started seeing this too F16 KVM Guests,
But unlike the similar x binary F17 bug I came across
https://bugzilla.redhat.com/show_bug.cgi?id=802134
this instance doesn't prevent
my F16.guests from accessing the network.
Comment 2 Harald Reindl 2012-03-11 12:57:51 EDT
yes, network is working but as far as i understand the messages a restart doe snot stop it corectly and whatever happens here needs to be fixed
Comment 3 Lubos Stanek 2012-03-12 06:18:37 EDT
Created attachment 569351 [details]
fix typos
Comment 4 Bill Nottingham 2012-03-12 10:05:14 EDT
Thx, fixed in git.
Comment 5 Bill Nottingham 2012-03-12 10:47:13 EDT
*** Bug 802134 has been marked as a duplicate of this bug. ***
Comment 6 Harald Reindl 2012-03-12 12:07:33 EDT
a koji build would be fine to test/confirm the fix
Comment 7 Fedora Update System 2012-03-12 14:22:06 EDT
initscripts-9.34.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/initscripts-9.34.2-1.fc16
Comment 8 Fedora Update System 2012-03-12 14:32:00 EDT
initscripts-9.36-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/initscripts-9.36-1.fc17
Comment 9 Fedora Update System 2012-03-13 13:08:44 EDT
Package initscripts-9.36-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing initscripts-9.36-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3654/initscripts-9.36-1.fc17
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-03-14 22:22:50 EDT
initscripts-9.34.2-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2012-03-23 13:44:15 EDT
initscripts-9.37-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.