Bug 802134 - Fedora 17 x: binary operator expected (initscripts)
Fedora 17 x: binary operator expected (initscripts)
Status: CLOSED DUPLICATE of bug 802055
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-11 12:05 EDT by Frank Murphy
Modified: 2014-03-16 23:30 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-12 10:47:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Murphy 2012-03-11 12:05:42 EDT
Description of problem: 
systemctl status network.service
network.service - LSB: Bring up/down networking
	  Loaded: loaded (/etc/rc.d/init.d/network)
	  Active: failed (Result: exit-code) since Sun, 11 Mar 2012 15:50:44 +0000; 28s ago
	 Process: 2083 ExecStart=/etc/rc.d/init.d/network start (code=exited, status=1/FAILURE)
	  CGroup: name=systemd:/system/network.service

Mar 11 15:50:44 testvm network[2083]: [FAILED]
Mar 11 15:50:44 testvm network[2083]: RTNETLINK answers: File exists
Mar 11 15:50:44 testvm network[2083]: RTNETLINK answers: File exists
Mar 11 15:50:44 testvm network[2083]: RTNETLINK answers: File exists
Mar 11 15:50:44 testvm network[2083]: RTNETLINK answers: File exists
Mar 11 15:50:44 testvm network[2083]: RTNETLINK answers: File exists
Mar 11 15:50:44 testvm network[2083]: RTNETLINK answers: File exists
Mar 11 15:50:44 testvm network[2083]: RTNETLINK answers: File exists
Mar 11 15:50:44 testvm network[2083]: RTNETLINK answers: File exists
Mar 11 15:50:44 testvm network[2083]: RTNETLINK answers: File exists


ifdown eth0
/sbin/ifdown: line 64: [: x: binary operator expected

ifup eth0
/sbin/ifup: line 145: [: x: binary operator expected

lspci 05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)

Downgrading to initscripts-9.34-3.fc17.x86_64 restores network


Version-Release number of selected component (if applicable):
initscripts-9.35-1.fc17.x86_64


How reproducible: always


Steps to Reproduce:
1. service network restart
2. ifup ethX
3. ifdown ethX 
  
Actual results: No network


Expected results: network


Additional info: NM not installed
Comment 1 Bill Nottingham 2012-03-12 10:47:13 EDT

*** This bug has been marked as a duplicate of bug 802055 ***

Note You need to log in before you can comment on or make changes to this bug.