Bug 802098 - atl1c_wait_until_idle triggers watchdog.
atl1c_wait_until_idle triggers watchdog.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
abrt_hash:770845898d72ccb629c341c395d...
:
: 803848 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-11 03:48 EDT by admin
Modified: 2012-05-21 10:21 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-21 10:20:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: smolt_data (2.79 KB, text/plain)
2012-03-11 03:49 EDT, admin
no flags Details

  None (edit)
Description admin 2012-03-11 03:48:48 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.3.0-0.rc6.git0.2.fc17.x86_64 root=/dev/mapper/vg_raistlin-lv_root ro LANG=ru_RU.UTF-8 rd.md=0 rd.dm=0 quiet rhgb rd.luks=0 KEYTABLE=ru rd.lvm.lv=vg_raistlin/lv_swap rd.lvm.lv=vg_raistlin/lv_root
comment:        I'm suspended the netbook into suspend mode for 2 hours and power on back. It was kernel panic, I'm rebooted the netbook with cold reset and abrt given this bug. Sorry for my bad English.
event_log:      2012-03-11-14:48:04> Smolt profile successfully saved
kernel:         3.3.0-0.rc6.git0.2.fc17.x86_64
reason:         WARNING: at kernel/watchdog.c:241 watchdog_overflow_callback+0x9a/0xc0()
time:           Вс. 11 марта 2012 11:38:21

smolt_data:     Binary file, 2857 bytes

backtrace:
:WARNING: at kernel/watchdog.c:241 watchdog_overflow_callback+0x9a/0xc0()
:Hardware name: AOD260
:Watchdog detected hard LOCKUP on cpu 1
:Modules linked in: fuse lockd sunrpc coretemp uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev v4l2_compat_ioctl32 arc4 media ath9k ath9k_common ath9k_hw ath mac80211 cfg80211 acer_wmi sparse_keymap iTCO_wdt rfkill i2c_i801 microcode iTCO_vendor_support snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_page_alloc snd_timer snd soundcore atl1c binfmt_misc uinput wmi i915 video i2c_algo_bit drm_kms_helper drm i2c_core [last unloaded: scsi_wait_scan]
:Pid: 584, comm: NetworkManager Not tainted 3.3.0-0.rc6.git0.2.fc17.x86_64 #1
:Call Trace:
: <NMI>  [<ffffffff8105671f>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff81056816>] warn_slowpath_fmt+0x46/0x50
: [<ffffffff810e0a70>] ? touch_nmi_watchdog+0x80/0x80
: [<ffffffff810e0b0a>] watchdog_overflow_callback+0x9a/0xc0
: [<ffffffff8111773d>] __perf_event_overflow+0x9d/0x230
: [<ffffffff81115061>] ? perf_event_update_userpage+0x11/0xc0
: [<ffffffff81023d29>] ? x86_perf_event_set_period+0xd9/0x160
: [<ffffffff81118124>] perf_event_overflow+0x14/0x20
: [<ffffffff8102812a>] intel_pmu_handle_irq+0x16a/0x2e0
: [<ffffffff815ea83d>] perf_event_nmi_handler+0x1d/0x20
: [<ffffffff815ea009>] nmi_handle.isra.0+0x49/0x80
: [<ffffffff815ea138>] do_nmi+0xf8/0x330
: [<ffffffff815e9644>] restart_nmi+0x1a/0x1e
: [<ffffffff812bd74c>] ? kobject_cleanup+0x9c/0x1b0
: [<ffffffffa00ea83d>] ? atl1c_wait_until_idle.isra.27+0x6d/0x80 [atl1c]
: [<ffffffffa00ea83d>] ? atl1c_wait_until_idle.isra.27+0x6d/0x80 [atl1c]
: [<ffffffffa00ea83d>] ? atl1c_wait_until_idle.isra.27+0x6d/0x80 [atl1c]
: <<EOE>>  [<ffffffffa00ea8cc>] atl1c_stop_mac+0x7c/0xc0 [atl1c]
: [<ffffffffa00ea945>] atl1c_reset_mac+0x35/0xb0 [atl1c]
: [<ffffffffa00ebc7b>] atl1c_down+0xcb/0x110 [atl1c]
: [<ffffffffa00ec168>] atl1c_close+0x28/0x50 [atl1c]
: [<ffffffff814d919d>] __dev_close_many+0x8d/0xe0
: [<ffffffff814dac5b>] __dev_close+0x3b/0x60
: [<ffffffff814df831>] __dev_change_flags+0xa1/0x180
: [<ffffffff814df9c8>] dev_change_flags+0x28/0x70
: [<ffffffff814eb4ea>] do_setlink+0x34a/0x9d0
: [<ffffffff812d8ff1>] ? nla_parse+0x31/0xe0
: [<ffffffff814ed6de>] rtnl_newlink+0x37e/0x560
: [<ffffffff814ecf44>] rtnetlink_rcv_msg+0x114/0x2e0
: [<ffffffff814ece30>] ? __rtnl_unlock+0x20/0x20
: [<ffffffff815062b1>] netlink_rcv_skb+0xa1/0xb0
: [<ffffffff814ea9a5>] rtnetlink_rcv+0x25/0x40
: [<ffffffff81505c2d>] netlink_unicast+0x19d/0x1f0
: [<ffffffff81505f3d>] netlink_sendmsg+0x2bd/0x330
: [<ffffffff814c6758>] sock_sendmsg+0xf8/0x130
: [<ffffffff814c65cd>] ? sock_recvmsg+0xfd/0x130
: [<ffffffff814c7eaa>] ? move_addr_to_kernel+0x5a/0xc0
: [<ffffffff814d3aa6>] ? verify_iovec+0x56/0xd0
: [<ffffffff814c6c0e>] __sys_sendmsg+0x41e/0x430
: [<ffffffff8108c4cf>] ? __dequeue_entity+0x2f/0x50
: [<ffffffff8101276e>] ? __switch_to+0x16e/0x420
: [<ffffffff814c8e59>] sys_sendmsg+0x49/0x90
: [<ffffffff815f0ce9>] system_call_fastpath+0x16/0x1b
Comment 1 admin 2012-03-11 03:49:02 EDT
Created attachment 569165 [details]
File: smolt_data
Comment 2 admin 2012-03-15 14:36:49 EDT
*** Bug 803848 has been marked as a duplicate of this bug. ***
Comment 3 Stanislaw Gruszka 2012-05-18 07:00:53 EDT
We update atl1c driver in kernel-3.3.6-3.fc17, do you still can reproduce this problem on that kernel?
Comment 4 admin 2012-05-21 10:20:24 EDT
Have no issue by now. Closing bug.

Note You need to log in before you can comment on or make changes to this bug.