Bug 802153 - Discuss possibility of Django 1.3 update in EPEL6
Summary: Discuss possibility of Django 1.3 update in EPEL6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: Django
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Runge
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 802154 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-11 18:02 UTC by Kevin Fenzi
Modified: 2018-04-11 11:11 UTC (History)
9 users (show)

Fixed In Version: Django-1.3.1-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-19 18:35:00 UTC


Attachments (Terms of Use)

Description Kevin Fenzi 2012-03-11 18:02:54 UTC
Is there any chance of upgrading Django to 1.3.x in epel6? 

There do seem to be some incompatible changes: https://docs.djangoproject.com/en/dev/releases/1.3/#backwards-incompatible-changes-1-3

But I'm not sure how incompatible they are in practice. 

https://docs.djangoproject.com/en/1.2/internals/release-process/ has more info and claims 'minor releases' are compatible. 

In Fedora Infrastructure we have reviewboard and askbot using Django, and both of them would work fine with 1.3.x I am pretty sure. 

Thoughts?

Comment 1 Kevin Fenzi 2012-03-11 18:09:49 UTC
*** Bug 802154 has been marked as a duplicate of this bug. ***

Comment 2 Stephen Gallagher 2012-03-11 20:26:57 UTC
It's worth noting a few things:

1) Django 1.4 is now in beta, with a final release imminent.
2) Django upstream supports only two minor releases at a time, which means that when 1.4 final is released, 1.2 will cease receiving updates.
3) There are already Django-based applications that require Django 1.3 at a minimum, one such is ReviewBoard (which is in use in Fedora Infrastructure and is currently held on the 1.5.x branch because 1.6.x requires Django 1.3). ReviewBoard's upstream has informed me that 1.7.0 will likely require Django 1.4.

If we're planning to bump the version, we may want to look at going straight to Django 1.4.

Comment 3 Kevin Fenzi 2012-03-23 21:07:30 UTC
ok. 1.4 is out now. 

Any further thoughts? ;)

Comment 4 Matthias Runge 2012-03-23 21:17:21 UTC
Hmm, I'd do the update to 1.3.

I didn't experience no regressions in a mixed environment (development on fedora/django-1.3, production environment on rhel 6.2/django-1.2)

If there are no objections, I'd do an update (once my commit acl request is answered for epel6 branch)

Comment 5 Matthias Runge 2012-03-23 21:20:17 UTC
additional remark: django developers recommend, to change to version 1.3, and later to 1.4.

django Update to 1.4 tracking ticket: https://bugzilla.redhat.com/show_bug.cgi?id=806463

- I'd like to unbundle jquery from django-(1.4).

Comment 6 Matthias Runge 2012-03-29 06:54:58 UTC
EPEL Packaging guidelines[1] are pretty clear:

For other - non-security - updates, the maintainer MUST NOT push those types of changes to the stable package. Instead, a new package must be made, pass review, and be branched for EPEL only. 


It looks like we need to make a new package, e.g. django13 to provide a newer version. 

Another way would be to get an exception from that general rule. Sadly, I can't find a pointer to this.
Thoughts?


[1]
http://fedoraproject.org/wiki/EPEL_incompatible_upgrades_policy#Procedure_for_other_packages

Comment 7 Kevin Fenzi 2012-03-29 14:05:21 UTC
Thats in the case of 'incompatible' upgrades. 

My understanding is that 1.2->1.3 isn't very incompatible...

Comment 8 Fedora Update System 2012-04-17 20:47:34 UTC
Django-1.3.1-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/Django-1.3.1-1.el6

Comment 9 Fedora Update System 2012-04-17 23:35:59 UTC
Package Django-1.3.1-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing Django-1.3.1-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-5607/Django-1.3.1-1.el6
then log in and leave karma (feedback).

Comment 10 Alan Pevec 2012-04-27 16:19:01 UTC
This is now FTBFS due to wrong Sphinx update in EPEL https://admin.fedoraproject.org/updates/python-sphinx-1.0.8-1.el6 which was untagged on 2012-04-20

See bug 815055 for the same FTBFS issue in other package and how to patch .spec to use python-sphinx10

Comment 11 Alan Pevec 2012-04-27 16:49:35 UTC
This should fix docs building on el6 branch:

--- a/Django.spec
+++ b/Django.spec
@@ -19,9 +19,7 @@ BuildArch:      noarch
 # Note: No longer required in development version > 0.95
 # BuildRequires:  python-setuptools
 BuildRequires:  python-devel
-%if 0%{?rhel} > 4 || 0%{?fedora} > 12
-BuildRequires:  python-sphinx
-%endif
+BuildRequires:  python-sphinx10
 
 Requires:       python-simplejson
 
@@ -73,11 +71,8 @@ rm -rf $RPM_BUILD_ROOT
   's:\(.*/locale/\)\([^/_]\+\)\(.*\.mo$\):%lang(\2) \1\2\3:' \
   >> %{name}.lang
 
-# If it's rhel5+ or any Fedora over 12 build docs
-%if 0%{?rhel} > 4 || 0%{?fedora} >= 12
-    # build documentation
-    (cd docs && mkdir djangohtml && mkdir -p _build/{doctrees,html} && make html)
-%endif
+# build documentation
+(cd docs && mkdir djangohtml && mkdir -p _build/{doctrees,html} && make SPHINXBUILD=sphinx-1.0-build html)
 
 # install man pages
 mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1/

Comment 12 Alan Pevec 2012-04-27 16:53:18 UTC
Reassigning to Matthias who was actually doing the work here.

Comment 13 Matthias Runge 2012-04-27 19:06:44 UTC
Thank you Alan for fixing this issue. I even wasn't aware of it.

Comment 14 Alan Pevec 2012-04-27 22:11:27 UTC
Django-1.3.1-2.el6 fixes FTBFS, please replace the build in https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-5607
and push again to testing. Thanks!

Comment 15 Fedora Update System 2012-05-02 20:30:49 UTC
Package Django-1.3.1-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing Django-1.3.1-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-5607/Django-1.3.1-2.el6
then log in and leave karma (feedback).

Comment 16 Fedora Update System 2012-05-19 18:35:00 UTC
Django-1.3.1-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.