Bug 802312 - no default keymap selected for language, even login to local language
no default keymap selected for language, even login to local language
Status: CLOSED DUPLICATE of bug 797023
Product: Fedora
Classification: Fedora
Component: ibus-m17n (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daiki Ueno
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 05:49 EDT by A S Alam
Modified: 2013-07-02 21:10 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-19 06:11:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A S Alam 2012-03-12 05:49:35 EDT
Description of problem:
while login to local desktop (Hindi, Punjabi, Tamil), No default keymap selected as there was in Fedora 16 Version. You can need to go to preference and select locale.

Version-Release number of selected component (if applicable):
[root@mole ~]# rpm -qa|grep ibus|sort
ibus-1.4.99.20120304-3.fc17.x86_64
ibus-anthy-1.3.99.20120304-1.fc17.x86_64
ibus-chewing-1.3.10-3.fc17.x86_64
ibus-gnome3-1.4.99.20120304-3.fc17.x86_64
ibus-gtk2-1.4.99.20120304-3.fc17.x86_64
ibus-gtk3-1.4.99.20120304-3.fc17.x86_64
ibus-hangul-1.4.0-5.fc17.x86_64
ibus-indic-table-1.3.1-23.fc17.noarch
ibus-libs-1.4.99.20120304-3.fc17.x86_64
ibus-m17n-1.3.3-9.fc17.x86_64
ibus-pinyin-1.4.0-14.fc17.x86_64
ibus-pinyin-db-android-1.4.0-14.fc17.noarch
ibus-qt-1.3.1-8.fc17.x86_64
ibus-rawcode-1.3.1.20100707-7.fc17.x86_64
libusb-0.1.3-10.fc17.x86_64
libusb1-1.0.9-0.4.rc1.fc17.x86_64
libuser-0.57.5-1.fc17.x86_64
libuser-python-0.57.5-1.fc17.x86_64


How reproducible:
Everytime

Steps to Reproduce:
1. Add user and login with Hindi locale
2. Try to press Ctrl + Space
3.
  
Actual results:
No input for Hindi

Expected results:
there should be some default layout.

Additional info:
1) cat .config/ibus/bus/af77df81e7c8d5ace27fe6740000000d-unix-0 
# This file is created by ibus-daemon, please do not modify it
IBUS_ADDRESS=unix:abstract=/tmp/dbus-YrMGCxnY,guid=05bb0cbf1b7607bf60bebb374f5dc344
IBUS_DAEMON_PID=4692

2) $set|grep ibus
OLDPWD=/home/test3/ibus_config
QT_IM_MODULE=ibus
XMODIFIERS=@im=ibus
__ibus () 
            __ibus_engine;
            __ibus_list_engine;
__ibus_engine () 
        local imes=$( ibus list-engine --name-only 2>/dev/null );
__ibus_list_engine () 


3)$locale
LANG=hi_IN.utf8
LC_CTYPE="hi_IN.utf8"
LC_NUMERIC="hi_IN.utf8"
LC_TIME="hi_IN.utf8"
LC_COLLATE="hi_IN.utf8"
LC_MONETARY="hi_IN.utf8"
LC_MESSAGES="hi_IN.utf8"
LC_PAPER="hi_IN.utf8"
LC_NAME="hi_IN.utf8"
LC_ADDRESS="hi_IN.utf8"
LC_TELEPHONE="hi_IN.utf8"
LC_MEASUREMENT="hi_IN.utf8"
LC_IDENTIFICATION="hi_IN.utf8"
LC_ALL=

4) $echo $LANG
hi_IN.utf8
Comment 1 Daiki Ueno 2012-03-13 22:21:25 EDT
Presumably this is a duplicate of bug 797023.
Comment 2 Daiki Ueno 2012-03-19 06:11:39 EDT

*** This bug has been marked as a duplicate of bug 797023 ***

Note You need to log in before you can comment on or make changes to this bug.