Bug 802477 - deduplication false positive
deduplication false positive
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
16
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 12:31 EDT by Jan Kratochvil
Modified: 2012-10-26 07:16 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-29 20:57:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2012-03-12 12:31:32 EDT
Description of problem:
ABRT filed two absolutely different problems into a single Bug for GDB.

Version-Release number of selected component (if applicable):
I have no idea how to find it out.

How reproducible:
Noticed it the first time now.

Steps to Reproduce:
?

Actual results:
Bug 738482 Comment 0:
  ../../gdb/dwarf2loc.c:188: internal-error:
    dwarf_expr_frame_base: Assertion `framefunc != NULL' failed.
Bug 738482 Comment 13:
  ../../gdb/thread.c:623: internal-error:
    is_thread_state: Assertion `tp' failed.

Expected results:
"Assertion `tp' failed." should be filed as a new Bug.

Additional info:
I understand ABRT got confused by the common internal-error code of GDB.
Comment 1 Miroslav Lichvar 2012-03-12 12:45:12 EDT
The problem seems to be that the first three function names used for the dedup hash are identical in both backtraces.

There is not much we can do with the hash, but this should be handled better in the new deduplication which uses 8 frames for comparison.
Comment 2 Jan Kratochvil 2012-03-12 13:02:00 EDT
The easy way would be to have application-specific info about crash functions.
For GDB it would be "internal_error".

The better design would be to store __attribute__((noreturn)) marker into DWARF so that ABRT can consider such marker as the crash code path start.
Comment 3 Jiri Moskovcak 2012-08-10 03:19:10 EDT
> Version-Release number of selected component (if applicable):
> I have no idea how to find it out.

- $ rpm -q abrt

The limitation of the deduplication using the hash is known. The ABRT server which just has been deployed should deal with this better.
Comment 4 Fedora Update System 2012-08-10 03:21:16 EDT
libreport-2.0.12-2.fc17, abrt-2.0.11-1.fc17, btparser-0.18-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-11529/abrt-2.0.11-1.fc17,libreport-2.0.12-2.fc17,btparser-0.18-2.fc17
Comment 5 Fedora Update System 2012-08-23 19:28:27 EDT
Package abrt-2.0.12-1.fc17, libreport-2.0.13-1.fc17, btparser-0.18-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.12-1.fc17 libreport-2.0.13-1.fc17 btparser-0.18-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11529/abrt-2.0.12-1.fc17,libreport-2.0.13-1.fc17,btparser-0.18-2.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-08-29 20:57:19 EDT
abrt-2.0.12-1.fc17, libreport-2.0.13-2.fc17, btparser-0.18-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Yann Droneaud 2012-10-26 07:16:14 EDT
I have the same problem, see bug #870371
This is going to be fixed as part of bug #845097

Note You need to log in before you can comment on or make changes to this bug.