Bug 802486 - WARNING: at block/genhd.c:1568 disk_clear_events+0x106/0x110()
WARNING: at block/genhd.c:1568 disk_clear_events+0x106/0x110()
Status: CLOSED DUPLICATE of bug 752175
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 12:52 EDT by Mads Kiilerich
Modified: 2012-03-12 14:35 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-12 14:35:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2012-03-12 12:52:58 EDT
I got this when running fsck.vfat on a ro mounted vfat and then remounting rw.

[    8.551550] ------------[ cut here ]------------
[    8.551559] WARNING: at block/genhd.c:1568 disk_clear_events+0x106/0x110()
[    8.551562] Hardware name: iMac11,2
[    8.551563] Modules linked in: snd_hda_codec_hdmi arc4 snd_hda_codec_cirrus ath9k mac80211 snd_hda_intel snd_hda_codec ath9k_common ath9k_hw snd_hwdep snd_seq uvcvideo ath snd_seq_device snd_pcm videodev btusb media snd_timer cfg80211 bluetooth tg3 v4l2_compat_ioctl32 snd applesmc intel_ips shpchp i2c_i801 iTCO_wdt soundcore apple_bl snd_page_alloc iTCO_vendor_support rfkill input_polldev squashfs vfat fat usb_storage firewire_ohci firewire_core crc_itu_t video radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
[    8.551603] Pid: 998, comm: udisks-part-id Not tainted 3.2.9-1.fc16.x86_64 #1
[    8.551605] Call Trace:
[    8.551614]  [<ffffffff8106e53f>] warn_slowpath_common+0x7f/0xc0
[    8.551617]  [<ffffffff8106e59a>] warn_slowpath_null+0x1a/0x20
[    8.551620]  [<ffffffff812a8146>] disk_clear_events+0x106/0x110
[    8.551625]  [<ffffffff811ae687>] check_disk_change+0x37/0x80
[    8.551631]  [<ffffffff813c039d>] sd_open+0xad/0x1e0
[    8.551635]  [<ffffffff811afb86>] __blkdev_get+0x306/0x470
[    8.551638]  [<ffffffff811afd43>] blkdev_get+0x53/0x300
[    8.551641]  [<ffffffff811b004d>] blkdev_open+0x5d/0x80
[    8.551646]  [<ffffffff81177740>] __dentry_open+0x290/0x360
[    8.551649]  [<ffffffff811afff0>] ? blkdev_get+0x300/0x300
[    8.551652]  [<ffffffff81178b51>] nameidata_to_filp+0x71/0x80
[    8.551657]  [<ffffffff8118882c>] do_last+0x26c/0x8f0
[    8.551660]  [<ffffffff81188fc2>] path_openat+0xd2/0x3c0
[    8.551663]  [<ffffffff811893d2>] do_filp_open+0x42/0xa0
[    8.551668]  [<ffffffff8119510f>] ? alloc_fd+0x4f/0x150
[    8.551671]  [<ffffffff81178c57>] do_sys_open+0xf7/0x1d0
[    8.551673]  [<ffffffff81178d50>] sys_open+0x20/0x30
[    8.551679]  [<ffffffff815eaac2>] system_call_fastpath+0x16/0x1b
[    8.551681] ---[ end trace 8ccaf502a1683ed2 ]---
Comment 1 Justin M. Forbes 2012-03-12 14:35:54 EDT

*** This bug has been marked as a duplicate of bug 752175 ***

Note You need to log in before you can comment on or make changes to this bug.