Bug 802545 - Using RHUI admin to delete repos should make content unavailable to clients
Using RHUI admin to delete repos should make content unavailable to clients
Status: CLOSED DUPLICATE of bug 802547
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: RHUA (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: James Slagle
wes hayutin
:
: 810105 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-12 15:23 EDT by wes hayutin
Modified: 2012-05-08 15:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-08 15:36:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2012-03-12 15:23:49 EDT
Description of problem:

Found in RHUI 2.0.2

1. create repoA, sync content to cds
2. create client entitlment certs/rpms
3. install package from repoA on client
4. using rhui-manager delete repoA
5. sync cds
6. on guest yum clean all
7. install package from repoA on guest

results:
content and package still avail to guest

expected results:
If a RHUI admin deletes a repo and sync the cds's a client should no longer have access to the content

The content may still live on the cds/rhua, however access should be denied


[root@qeblade30 RHUI201-02]# rpm -qa | grep pulp
pulp-admin-0.0.263-18.el6.noarch
python-isodate-0.4.4-4.pulp.el6.noarch
pulp-consumer-0.0.263-18.el6.noarch
pulp-0.0.263-18.el6.noarch
pulp-common-0.0.263-18.el6.noarch
m2crypto-0.21.1.pulp-7.el6.x86_64
pulp-selinux-server-0.0.263-18.el6.noarch
pulp-client-lib-0.0.263-18.el6.noarch
mod_wsgi-3.3-2.pulp.el6.x86_64
python-oauth2-1.5.170-2.pulp.el6.noarch
[root@qeblade30 RHUI201-02]# rpm -qa | grep rhui
rh-rhui-tools-2.0.60-1.el6.noarch
Comment 1 wes hayutin 2012-03-12 15:43:51 EDT
just to clarify.. the content is left on the cds, even though the content has been removed from the rhui
Comment 2 wes hayutin 2012-04-05 09:10:25 EDT
*** Bug 810105 has been marked as a duplicate of this bug. ***
Comment 3 James Slagle 2012-05-08 15:36:23 EDT
When Bug 802547 is implemented, this will also be fixed.  Closing it as a dupe.

*** This bug has been marked as a duplicate of bug 802547 ***

Note You need to log in before you can comment on or make changes to this bug.