Bug 802791 - qpid-cpp examples building error
qpid-cpp examples building error
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qpid-cpp (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Darryl L. Pierce
Fedora Extras Quality Assurance
:
: 830797 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-13 10:14 EDT by Leonid Zhaldybin
Modified: 2015-06-21 20:07 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:28:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-4371 None None None 2012-10-12 15:53:52 EDT

  None (edit)
Description Leonid Zhaldybin 2012-03-13 10:14:27 EDT
Description of problem:
After installing package qpid-cpp-client-devel, I was unable to build some of the examples in /usr/share/qpidc/examples/messaging directory. For example:

[root@localhost messaging]# make spout
cc -lqpidmessaging  spout.o OptionParser.o   -o spout
/bin/ld: /usr/lib/gcc/x86_64-redhat-linux/4.7.0/../../../../lib64/libqpidmessaging.so: undefined reference to symbol '_ZN4qpid5types9ExceptionD2Ev'
/bin/ld: note: '_ZN4qpid5types9ExceptionD2Ev' is defined in DSO /lib64/libqpidtypes.so.1 so try adding it to the linker command line
/lib64/libqpidtypes.so.1: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status
make: *** [spout] Error 1

To be able to build successfully all the examples, I had to add two more linker options to the Makefile: "-lqpidtypes -lstdc++"


Version-Release number of selected component (if applicable):
qpid-cpp-client-devel-0.14-1.fc17.1.x86_64


How reproducible:
always

Steps to Reproduce:
1. Install qpid-cpp-client-devel package.
2. Try to build example applications.
3.
  
Actual results:
Build failed on the linking stage.

Expected results:
Examples built successfully.

Additional info:
Comment 1 Darryl L. Pierce 2012-10-12 15:55:22 EDT
*** Bug 830797 has been marked as a duplicate of this bug. ***
Comment 2 Fedora Update System 2012-10-12 20:56:21 EDT
qpid-cpp-0.18-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/qpid-cpp-0.18-4.fc17
Comment 3 Fedora Update System 2012-10-13 21:47:47 EDT
qpid-cpp-0.18-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/qpid-cpp-0.18-3.fc16
Comment 4 Fedora Update System 2012-10-13 22:42:16 EDT
qpid-cpp-0.18-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qpid-cpp-0.18-4.fc18
Comment 5 Fedora Update System 2012-10-13 23:52:49 EDT
Package qpid-cpp-0.18-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qpid-cpp-0.18-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16097/qpid-cpp-0.18-4.fc17
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-10-16 09:45:07 EDT
qpid-cpp-0.18-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/qpid-cpp-0.18-4.fc16
Comment 7 Fedora Update System 2012-10-16 11:30:41 EDT
qpid-cpp-0.18-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/qpid-cpp-0.18-5.fc17
Comment 8 Fedora Update System 2012-10-16 13:14:43 EDT
qpid-cpp-0.18-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qpid-cpp-0.18-5.fc18
Comment 9 Gilles J. Seguin 2012-10-18 04:01:07 EDT
#830797 is resolved by qpid-cpp-0.18-4.fc17

Steps to Reproduce:
1. Install qpid-cpp-client-devel package.
2. Try to build example applications.

succeed on x86_64
Comment 10 Fedora Update System 2012-12-20 11:28:46 EST
qpid-cpp-0.18-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.